Find the answer to your Linux question:
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 11
Does any one know where to edit the browser fonts. Because mine are really tiny, barely readable. I have looked in kdeglobals, the fonts in Control Center, and the fonts ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux Guru budman7's Avatar
    Join Date
    Oct 2004
    Location
    Knee deep in Grand Rapids, Michigan
    Posts
    3,242

    Tiny browser fonts


    Does any one know where to edit the browser fonts.
    Because mine are really tiny, barely readable.

    I have looked in kdeglobals, the fonts in Control Center, and the fonts that are in Preferences in Firefox. No joy.

    Your help is appreciated.
    How to know if you are a geek.
    when you respond to "get a life!" with "what's the URL?"
    - Birger

    New users read The FAQ

  2. #2
    Just Joined!
    Join Date
    Apr 2005
    Posts
    2
    i have a problem like yours too: View->Text Size->Increase should increase all fonts used on a site...

  3. #3
    Linux Guru budman7's Avatar
    Join Date
    Oct 2004
    Location
    Knee deep in Grand Rapids, Michigan
    Posts
    3,242
    The fonts that are on the web page are just fine.
    But the View->Text Size->Increase
    is really tiny.

    How do I use the font size changer in the post reply?
    How to know if you are a geek.
    when you respond to "get a life!" with "what's the URL?"
    - Birger

    New users read The FAQ

  4. #4
    Linux Engineer
    Join Date
    Mar 2005
    Posts
    1,431
    Firefox is written in GTK, change the GTK-fonts. You can either do this with a control called "switch2", it's in the portage three (called "x11-themes/gtk-theme-switch"). I beleve you also could do this in the gtk-qt controlpanel, you can test them both

  5. #5
    Linux Guru budman7's Avatar
    Join Date
    Oct 2004
    Location
    Knee deep in Grand Rapids, Michigan
    Posts
    3,242
    I emerged gtk-theme-switch. Executed switch2 in a terminal. It brought up 3 options, default, emacs and gentoo.
    I clicked on gentoo, but no change in FF.
    So, I clicked on the + for more options, but I still can't figure out how to change my fonts.


    And what is the gtk-qt controlpanel?
    How to know if you are a geek.
    when you respond to "get a life!" with "what's the URL?"
    - Birger

    New users read The FAQ

  6. #6
    Linux Engineer
    Join Date
    Mar 2005
    Posts
    1,431
    I think you can find i in the gtk-qt panel, "ACCEPT_KEYWORDS="~x86" emerge gtk-qt-engine"

    Switch2 works for me, I can change fonts + change GTK2-theme without it asking any questions at all...

  7. #7
    Linux Guru budman7's Avatar
    Join Date
    Oct 2004
    Location
    Knee deep in Grand Rapids, Michigan
    Posts
    3,242
    So I type into a teminal
    Code:
     "ACCEPT_KEYWORDS="~x86" emerge gtk-qt-engine"


    I will try this later today or tomorrow.
    I am dl'ing FC4-r3 and don't want to reboot.
    How to know if you are a geek.
    when you respond to "get a life!" with "what's the URL?"
    - Birger

    New users read The FAQ

  8. #8
    Linux Engineer
    Join Date
    Mar 2005
    Posts
    1,431
    Yeah, that'll install gtk-qt. The gtk-qt engina also makes it possible to use you KDE-styles on GTK-apps, for example plastik on gtk/gnome-apps.

  9. #9
    Linux Engineer spencerf's Avatar
    Join Date
    Jan 2005
    Location
    Syracuse, NY
    Posts
    1,144
    Quote Originally Posted by budman7
    So I type into a teminal
    Code:
     "ACCEPT_KEYWORDS="~x86" emerge gtk-qt-engine"


    I will try this later today or tomorrow.
    I am dl'ing FC4-r3 and don't want to reboot.
    instead of ACCEPT_KEYWORDS you should edit /etc/portage/package.keywords

    and add a line like

    x11-themes/gtk-engines-qt ~x86

    because with the ACCEPT_KEYWORDS method whenever you emerge --update --deep world it will revert back to the x86 version because your installation of ~x86 was temporary and it will revert back to the latest stable release. But when you edit package.keywords the use of a ~x86 version of a program will be permanent.

    I know this thread is sort of old but I saw it linked in another post and just wanted anybody to know how to use testing branch.

    edit: I can't find an ebuild for gtk-qt-engine so who knows???????

    edit2: ok I found it but it is called gtk-engines-qt
    All right, brain. You don't like me and I don't like you, but let's just do this and I can get back to killing you with beer. All New Users Read This!!! If you have a grub problem please look at GRUB MANUAL

  10. #10
    Just Joined!
    Join Date
    Jul 2006
    Posts
    2
    Hi, this is my 1st post in this board.. I was searching in google for some font-related topics and found this. I hope my discovery isn't too late (more than two monthes)

    Your DPI seems to be 75x75, this is why things appear smaller. execute the command "xdpyinfo | grep reso" and see your DPI.

    if it's below 96 then this is the reason behind all this

    mac uses 100 as it's default, windows uses 96 and X choses the DPI value based on some factors, so in some cases it appears 100x100, sometimes more or less.. personally mine was 75x75 and changed it.


    so your problem is solved by "man startx"

    don't execute the command "startx" as it is.. instead execute it with the following options
    Code:
    startx -- -dpi 96

    eech55 - hero from middle east



    [edit]
    althought I feel your problem is DPI wrong value, but just in case, try this:-
    - change the fon't value mentioned in ~/.Xdefaults, since many X clients take thier values from there, such as xterm among others that _may_ include FireFox
    [/edit]

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •