Find the answer to your Linux question:
Page 3 of 3 FirstFirst 1 2 3
Results 21 to 23 of 23
Originally Posted by drakebasher I'm not a LILO guy, so pardon my asking, but how come the config says "boot=/dev/hda" and not "boot=/dev/hda1"? Seems wrong: how would it know where ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #21
    Just Joined! bigjohn's Avatar
    Join Date
    Nov 2004
    Location
    504944N, 01912W
    Posts
    66

    Quote Originally Posted by drakebasher
    I'm not a LILO guy, so pardon my asking, but how come the config says "boot=/dev/hda" and not "boot=/dev/hda1"? Seems wrong: how would it know where /boot/kernel is unless it just ASSUMES that the boot directory?/partition? is on the first partition of hda? Okay, maybe it's a typo....

    Only other thing I can think of would be to go through the kernel configuration, mostly checking for filesystem support: but you haven't done anything weird with file system types. So like you, I'm stumped.
    To be honest, I don't really know, other than it just needs to know which disc (if multi disc setup) it will find the info on??? Thats about all I can think of i.e. grasping at straws (like me with most "things linux").

    I just tried what the install manual said, and as my system is pretty much the same as the example in the manual, I just followed their example.

    Logic says, that if both instances of bootloader (grub and lilo) are finding the same error, then it must be something other than the bootloader. Maybe kernel or something or some setting in the kernel that it doesn't like.

    I just don't know where to start looking.

    So if you do have any other ideas, they'd be much appreciated.

    regards

    John

  2. #22
    Just Joined! bigjohn's Avatar
    Join Date
    Nov 2004
    Location
    504944N, 01912W
    Posts
    66
    Just for info, I've managed to get my second kernel (newer) kernel version booting.

    The problem was the way that I'd used genkernel originally, I'm guessing that the latest version must have made some changes in how it needs to be used.

    This is what I did:

    Code:
    genkernel --udev --menuconfig --bootloader=grub --clean --install all[quote]
    
    and now it seems to boot fine.
    
    Plus, the grub problem that I've been experiencing i.e. a black screen with just a cursor blinking but with the system booting if I hit return, seems to be something to do with the splash image entry in my grub.conf.
    
    I've just commented it out and now I can see the grub OS selection dialogue box again - excellent.
    
    thanks very much for all the ideas and suggestions, they've been very much appreciated.
    
    regards
    
    John[/quote]

  3. #23
    Just Joined!
    Join Date
    May 2005
    Posts
    1

    just edited grub.conf (Problem solved!!!)

    hey bigjohn and all,

    This is my first post on this forum. So try to be nice.
    I realize you (bigjohn) had other problems, weird grub screen, etc...
    and that rebuilding the kernel worked 4 u;
    But, for those that actually get the grub color screen to come up,
    but just get the error message: "/dev/hda3 is not a valid root device"

    Here's howto fix it, or at least it worked for me

    Reboot to Gentoo Live Cd, then at prompt, execute the following commands:
    mount -t ext2 /dev/hda1 /mnt/gentoo
    cd /mnt/gentoo/grub
    nano -w grub.conf

    delete these parts "ramdisk=8192", "real_root=/dev/hda3",
    and "root=/dev/ram0", BUT leave the "init=/linuxrc" part.
    Add root=/dev/hda3
    so the line reads:
    "kernel /kernel-2.6.11-gentoo-r3 root=/dev/hda3 init=/linuxrc"

    Save, quit, and restart. Should work. Did 4 me.
    I don't understand why (in the install instructs) they tell you
    to make "/dev/ram0" the "root". This seems like they are
    telling you to tell grub that your ramdisk has the filesystem
    "/" on it?? My grub.conf listed below:

    default 0
    timeout 30
    splashimage=(hd0,0)/grub/splash.xpm.gz

    title=Gentoo Linux 2.6.11-r3
    root (hd0,0)
    kernel /kernel-2.6.11-gentoo-r3 root=/dev/hda3 init=/linuxrc
    initrd /initrd-2.6.11-gentoo-r3
    vga=0x318
    video=vesafb:mtrr,ywrap,1024x768-32@85

    Later,
    GK

  4. $spacer_open
    $spacer_close
Page 3 of 3 FirstFirst 1 2 3

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •