Find the answer to your Linux question:
Results 1 to 5 of 5
I am having trouble getting my wireless card to work. It is a Netgear WG311 using the Atheros chip set. After scouring the Internet, I found the following; ACCEPT_KEYWORDS="~x86" emerge ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined! gaz_dc's Avatar
    Join Date
    Oct 2004
    Posts
    40

    PCI / wireless problem


    I am having trouble getting my wireless card to work. It is a Netgear WG311 using the Atheros chip set. After scouring the Internet, I found the following;

    ACCEPT_KEYWORDS="~x86" emerge madwifi-driver
    emerge wireless-tools
    cp /etc/init.d/net.eth0 /etc/init.d/net.ath0
    modprobe ath_hal
    modprobe ath_pci
    modprobe wlan
    echo "ath_hal" >> /etc/modules.autoload.d/kernel-2.6
    echo "ath_pci" >> /etc/modules.autoload.d/kernel-2.6
    echo "wlan" >> /etc/modules.autoload.d/kernel-2.6

    After typing this in, I have got the wireless tools installed. However, when typing iwconfig, I get the following;

    lo no wireless extensions.
    dummy0 no wireless extensions.

    I then tried iwconfig ath0, but obviously got the reply “No such device”. Also, when I type in modprobe ath_pci from the above instructions, I get the following error;

    FATAL: Error inserting ath_pci (/lib/modules/2.6.11-gentoo-r8/net/ath_pci.ko): Unknown symbol in module, or unknown parameter (see dmesg)

    At the bottom of the output from dmesg is the following;

    ath_pci: Unknown symbol ieee80211_ioctl
    ath_pci: Unknown symbol ieee80211_ioctl

    Also, I have tried lspci, but got back a command not found message.

    Have I missed something from my kernel?

    Thanks

    Gaz

  2. #2
    Linux Guru sarumont's Avatar
    Join Date
    Apr 2003
    Location
    /dev/urandom
    Posts
    3,682
    lspci is part of pciutils. Emerge this then post the output of lspci.
    "Time is an illusion. Lunchtime, doubly so."
    ~Douglas Adams, The Hitchhiker's Guide to the Galaxy

  3. #3
    Just Joined! gaz_dc's Avatar
    Join Date
    Oct 2004
    Posts
    40
    Okay, thanks for that. I thought lspci was an internal command

    Now that I have pciutils installed, the output from lspci shows the following;

    0000:01:0a.0 Ethernet controller: Atheros Communications, Inc. AR5212 802.11abg NIC (rev01)

    So it looks like my card is being seen. What is next?

    Thanks for your help so far

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Newbie
    Join Date
    Sep 2003
    Location
    St.Charles, Missouri, USA
    Posts
    201
    I got an error like that for a while then i rebuilt my kernel. I dont think I changed anything other than making all the wireless stuff into a module. Seems to work very well after that.
    Powered by Gentoo
    never ever ever use the hardened option in make.conf!

  6. #5
    Just Joined! gaz_dc's Avatar
    Join Date
    Oct 2004
    Posts
    40
    Tried that with no joy.

    Thanks for the idea though

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •