Find the answer to your Linux question:
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 20
I have this problem when I reboot after install can anyone help. This is my error message: Code: >>Mounting filesystems Mount: Mounting devfs on /dev failed: No such device Error ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux Newbie
    Join Date
    Nov 2004
    Location
    Jersey
    Posts
    102

    Error when reboot after install [solved]


    I have this problem when I reboot after install can anyone help. This is my error message:

    Code:
    >>Mounting filesystems
    Mount: Mounting devfs on /dev failed: No such device
    Error opening file: "/devfsb" No such file or directory
    >>Determining root device...
    >>Block device /dev/hda3 is not a valid root device...
    >>The root block device is unspecified or not detected.
         Please specify a device to boot, or "shell" for a shell...
    Please help....
    Registered user #372186 -- http://counter.li.org

  2. #2
    Linux Engineer
    Join Date
    Mar 2005
    Posts
    1,431
    Devfs is deprecated, use udev instead. First, disable devfs in the kernel, "filesystems --> Pseudo filesystems --> /dev filesystem support". Then, recompile the kernel and reinstall the modules and kernel. Then, just follow gentoo's own udev guide: http://www.gentoo.org/doc/en/udev-guide.xml

  3. #3
    Linux Newbie
    Join Date
    May 2005
    Posts
    222
    Jaboua, will you explain this in more detail..please.

    I'm trying to install Gentoo from stage3 for the sixth time,
    and now having this exact problem.

    The closest thing to computer anything that I do is
    programming in Assembly, this problem is totally
    beyond my realm of understanding....please help

  4. #4
    Linux Engineer
    Join Date
    Mar 2005
    Posts
    1,431
    Short brief of whats in the udev guide:

    The first step is to disable the kernel option "filesystems --> Pseudo filesystems --> /dev filesystem support". It's probably set to <*> now, press space until it is deselected < >.

    Then you recompile and reinstall the kernel as you installed it the first time. At last, you have to emerge some apps:
    Code:
    emerge udev hotplug coldplug
    rc-update add coldplug boot
    rc-update add hotplug default
    That should generally let you have a working /dev-filesystem, but if you don't want all the device nodes, only those detected by udev, you'll have to deactivate some options in /etc/conf.d/rc described at the link over. You should take a look at the gentoo guide, it is really usefull and describes everything you need to know when you're setting up udev. Good luck

    PS: if there is something more you didnt get or did'nt work, just ask

  5. #5
    Linux Newbie
    Join Date
    May 2005
    Posts
    222
    Thank you very much......Jaboua.....I will try it soon. Right now I'm using
    Ubuntu.
    I followed Gentoo Handbook installing 2005.0 version, it's very strange that
    problem like this still occur.

  6. #6
    Linux Newbie
    Join Date
    May 2005
    Posts
    222
    I now can get around that problem for the moment by typing

    /dev/hda3

    and it continues to boot up to this line

    starting devfsd
    /sbin/rc: line 271 /sbin/devfsd: No such file or directory

    I need some help with this additional problem......

  7. #7
    Linux Engineer
    Join Date
    Mar 2005
    Posts
    1,431
    Devfsd is disabled during the first part of my explaination - recompile the kernel with disabled devfs, it lies here in the kernel tree: filesystems --> Pseudo filesystems --> /dev filesystem support

  8. #8
    Linux Newbie
    Join Date
    Apr 2005
    Posts
    110
    I had the same problem myself. If you do a forum search for it you should find it, there is a good solution.

  9. #9
    Linux Newbie
    Join Date
    May 2005
    Posts
    222
    I tried to follow your instructions to disable kernel option...
    by typing at prompt.....

    filesystems -->Pseudo filesystems -->/dev filesystem support

    This is what I got.....

    bash: Pseudo: Read-only file system

    Forgive me if I am a little thick when it comes to this sort
    of things...but if I seem incredibly stupid please be specific
    of what step I should do to get to the point where I can
    disable devfs.

    When I compiled the kernel the first time .... I used the
    supplied genkernel and I do not remember specify any
    option at all.

  10. #10
    Linux Guru budman7's Avatar
    Join Date
    Oct 2004
    Location
    Knee deep in Grand Rapids, Michigan
    Posts
    3,242
    If you used genkernel, there wouldn't have been any options, unless you did, "makemenuconfig".

    The only reason to use make menuconfig would be if you don't have a separate /boot partition.
    How to know if you are a geek.
    when you respond to "get a life!" with "what's the URL?"
    - Birger

    New users read The FAQ

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •