Find the answer to your Linux question:
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 13
I have compiled a kernel successfully I follow the instruction for grub but when it boots after a while it gives me an error: kernel panic..... can't find root device ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Mar 2005
    Posts
    15

    Grub errorrrr


    I have compiled a kernel successfully I follow the instruction for grub but when it boots after a while it gives me an error: kernel panic..... can't find root device or unknown block (0,0)
    but the device is right and I have done everything sccording to the handbook

  2. #2
    Linux Engineer
    Join Date
    Mar 2005
    Posts
    1,431
    You are sure you gave the right root= option? And you know that hda1 = (hd0,0), not (hd0,1)? If you can't find out of it, LILO probably works, it (almost) always does, you could try LILO as a temporary loader until you get grub correctly...

  3. #3
    Linux Engineer
    Join Date
    Oct 2004
    Location
    Vancouver
    Posts
    1,366
    I agree with Jaboua about Lilo, but since you asked about grub could you please post your grub.conf file and tell us whether you did a manual compile or genkernel, and how you have your hardrives setup, which is boot, swap, /, etc. With this we should be able to have you cooking with gas in no time flat
    Operating System: GNU Emacs

  4. #4
    Just Joined!
    Join Date
    Mar 2005
    Posts
    15
    I have linux installed on /dev/hda2 no swap
    Manual compiletion of kernel
    boot partition /dev/hda4

    grub.conf


    default 0
    timeout=10

    title=gentoo
    root(hd0,3)
    kernel /kernel-2.6.11-gentoo-r3 root=/dev/hda2
    jsut like the manual

  5. #5
    Linux Engineer
    Join Date
    Oct 2004
    Location
    Vancouver
    Posts
    1,366
    sometimes the manual isn't updated as often as the sources for the kernel. when you chroot check out if kernel-2.6.11-gentoo-r3 is the exact kernel you are using, I know that it is not the one I am using. You can check under /usr/src or by just typing uname -a and make sure. Also make sure that your kernel image after compilation is copied to your boot partition and to run grub to update it after you do this.
    Operating System: GNU Emacs

  6. #6
    Linux Engineer
    Join Date
    Mar 2005
    Posts
    1,431
    But you can name your kernel whatever you want if you don't use "make install", so if you followed the manual about everything I guess the kernel would be called kernel-2.6.blah.blah... But as genesus said, you should check the kernel-name to be sure.

    Also make sure you mounted the boot-partition before compiling the kernel, for if not you kernel would reside in (hd0,3)/boot/ instead.[/code]

  7. #7
    Just Joined!
    Join Date
    Mar 2005
    Posts
    15
    The devices are right.
    I will wright down the last 6 lines in which i think the error resides...

    SLPB PCI0 HUB0 UAR1 UAR2 USB0 USB1 USB2 USB3 USBE MODV
    ACPI: (supports S0 S1 S4 S5)
    VFS: Cannot open device "hda2" or unknown-block(0,0)
    Please append a correct "root=" boot option
    kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(
    0,0)
    <7>uchi_hcd 0000:00:1d.0: suspend_hc

  8. #8
    Just Joined!
    Join Date
    Mar 2005
    Posts
    15
    Quote Originally Posted by jaboua
    You are sure you gave the right root= option? And you know that hda1 = (hd0,0), not (hd0,1)? If you can't find out of it, LILO probably works, it (almost) always does, you could try LILO as a temporary loader until you get grub correctly...
    LILO won't work either

  9. #9
    Linux User
    Join Date
    Oct 2004
    Location
    Serbia&Montenegro
    Posts
    281
    In my grub.conf I have root=/dev/ram0 and real_root=/dev/hda2. Also, isn't there supposed to be a udev in your grub.conf?
    Linux registered user #358842
    Human knowledge belongs to the world.

  10. #10
    Linux Engineer
    Join Date
    Mar 2005
    Posts
    1,431
    Not necesarrily, here's mine (it works fine):
    Code:
    rebootdefault 1
    timeout 30
    splashimage=&#40;hd0,0&#41;/boot/grub/splash.xpm.gz
    
    title=Gentoo Linux 2005.0
    root &#40;hd0,0&#41;
    kernel /boot/vmlinuz root=/dev/hda1
    boot
    
    title FreeBSD 5.4
    root &#40;hd0,1,a&#41;
    kernel /boot/loader
    boot
    (I have /boot on the /-partition, not seperate)

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •