Find the answer to your Linux question:
Results 1 to 4 of 4
I am having a bit of a problem with my fresh install of Gentoo Linux. Im not quite sure if the problem is in my kernel configuration, USB setups, X ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    May 2005
    Posts
    4

    Microsoft IntelliMouse 2.0 + Gentoo


    I am having a bit of a problem with my fresh install of Gentoo Linux. Im not quite sure if the problem is in my kernel configuration, USB setups, X Config, or whatnot.

    Here is the problem: Basically, my mouse doesn't work. I have a Microsoft Wireless Optical Desktop Elite keyboard and mouse set. It has worked in Linux before, (though the keyboard is a bit off). Its PS/2 Keyboard and USB mouse.

    What i have done: I install gentoo using the 2005.1 universal install, and used the GRP packages to install X11 and KDE. In the kernel configurtion i opted to add USB HID support (not as a module) and after 4 or 5 different tries, i know have just about everything listed in USB added, as well as all the mice and keyboard options. (If configs are needed, ill be glad to post, but as you will see soon, im not sure it will help).

    Here is where the "problem" starts. When i try and configure X i am given an error that my mouse isnt detected. (/dev/mouse) After googleing some, i find that it might be /dev/input/mouseX or /dev/psaux. (I installed Redhat Fedora Core at one point and found it used /dev/psaux) I change the X config file to use several different devices, all with failure.

    At one point, i found an article that said to cat the device file, and see if anything happens as you move the mouse. This only showed me that nothing was working. I tried doing that on another machine (the red hat box again) and i got lots and lots of odd data spilling out at me.

    What i need, is an answer to where/how i configure my mouse.
    that line, was most likely all that was needed....

  2. #2
    Linux Engineer
    Join Date
    Mar 2005
    Posts
    1,431
    /dev/psaux is only for PS/2-connected devices. Have you tried the device /dev/input/mice?

  3. #3
    Just Joined!
    Join Date
    May 2005
    Posts
    4
    Quote Originally Posted by jaboua
    /dev/psaux is only for PS/2-connected devices. Have you tried the device /dev/input/mice?
    yes and no.
    /dev/input/mice didnt exist on my system. well, /dev/input didnt for that matter.

    i tried installing about 4 times and each time this particular directory would be a file. /dev/input WAS a file, not a directory. thats the part that was most confusing to me. everything else i found via google, searhing groups and forums told me to try things like /dev/input/mice, dev/input/mouse1, etc. on my system, /dev/input was all there was.

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Engineer
    Join Date
    Mar 2005
    Posts
    1,431
    That is a bit odd, yeah... If you have dual-boot, you can try too boot up a distro working with your mouse and X, and check the config file, maybe you'll find a clue about which device to use. If it says just /dev/mouse, check if /dev/mouse is a symlink and in that case which file it refers to.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •