Find the answer to your Linux question:
Page 2 of 2 FirstFirst 1 2
Results 11 to 19 of 19
I used Stage 1 on my desktop and it works perfectly. I used Stage 3 on my laptop and I also used genkernel on my laptop. The laptop is the ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #11
    Linux Newbie
    Join Date
    Nov 2004
    Location
    Jersey
    Posts
    102

    I used Stage 1 on my desktop and it works perfectly. I used Stage 3 on my laptop and I also used genkernel on my laptop. The laptop is the one giving me the problems.
    Registered user #372186 -- http://counter.li.org

  2. #12
    Linux Newbie
    Join Date
    May 2005
    Posts
    222
    In that case I really can't see why those steps I posted wouldn't work for you . I used it on mine successfully.

  3. #13
    Linux Newbie
    Join Date
    Jul 2005
    Posts
    138
    i had exactly same problem this morning................i am using debian sarge

    check that /dev/dsp -> /dev/dsp0

    if this does not exist then you need to have alsa with the source, mixer and headers specific to your kernel.......all installed....

    also, make sure that you have the kernel source and headers installed too

    now, do "alsaconf" and go through the steps.........maybe reboot first

    ................this worked perfectly for me

  4. #14
    Just Joined!
    Join Date
    Mar 2005
    Location
    South Africa
    Posts
    55

    ALSA problem

    The problem I have with ALSA is that the settings aren't stored permanently
    After running 'alsaconf' the card is detected, etc, etc and sound works fine, but after rebooting I do not get sound
    Running 'alsaconf' again restores sound.
    I HAVE done the 'rc-config add alsasound boot' and does appear on the list after 'rc-update show' but still the settings aren't stored.

    Any help ?

  5. #15
    Linux Newbie daacosta's Avatar
    Join Date
    Sep 2005
    Location
    Medellín, Colombia
    Posts
    213

    Maybe this can help?

    Did you do "alsastore" after running alsaconf ? It is meant to store your settings.

    You could try that...

    btw, I haven't been able to solve my sound problem

  6. #16
    Just Joined!
    Join Date
    Mar 2005
    Location
    South Africa
    Posts
    55
    'alsastore'.........command not found

  7. #17
    Linux Newbie daacosta's Avatar
    Join Date
    Sep 2005
    Location
    Medellín, Colombia
    Posts
    213
    Code:
    alsactl store
    is the command... I am terribly sorry

    Accept my sincerest and deepest apologies

  8. #18
    Linux Engineer
    Join Date
    Mar 2005
    Posts
    1,431
    Another issue I've been having on my box, is that the bios seems to deactivate the sound-card (via 82c686) every second soft reboot, however this doesn't happen if I turn off the computer and then start it again... Not sure why tho. This results in alsaconf AND sound-apps not finding the soundcard. I would check the BIOS just in case.

  9. #19
    Just Joined!
    Join Date
    Aug 2006
    Location
    Cleveland, OH
    Posts
    1
    I had a lot of the same problems. After spending a few hours attempting to fix it, I noticed something on the boot screen.

    Apprently I had enabled a Virtual MIDI Card from "Generic Cards" when I compiled the Kernel. It was using that card as snd-card-0

    It seems that if you enable another sound card, it attempts to use that one as the main one, and does not permit you to complete proper ALSA configurations.

    Either that, or I'm completely helpless.

    Either way, it worked once I disabled it.

Page 2 of 2 FirstFirst 1 2

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •