Find the answer to your Linux question:
Results 1 to 8 of 8
I'm pretty sure I have the right time zone set and i did "date MMDDHHMMYYYY" during the install, but my time resets back to 5 hours late when i restart. ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux Enthusiast
    Join Date
    Jun 2005
    Location
    Odessa, FL
    Posts
    586

    Time is off by 5 Hours


    I'm pretty sure I have the right time zone set and i did "date MMDDHHMMYYYY" during the install, but my time resets back to 5 hours late when i restart.

    i've rerun "date ....." again after the install and I rechecked my time zones and the BIOS clock (which is set correctly btw), but my computer seems to want to set back 5 hours

    Does anyone know of any other causes and how I might fix this?

    Thanks in advance!


    EDIT: maybe it's something to do with "UTC"....what is that? before using linux, i've never even heard of it before. is it a certain time zone used or internet time or what? sorry, i've never really understood it, but now that i think about it....this *may* be the cause (though i'm not sure...it may very well be something else)

  2. #2
    Linux Engineer LondoJowo's Avatar
    Join Date
    May 2005
    Location
    Richmond, TX
    Posts
    804
    UTC is the same as GMT. Set your clock to use local time and the problem should be fixed.

  3. #3
    Linux Enthusiast
    Join Date
    Jun 2005
    Location
    Odessa, FL
    Posts
    586
    Quote Originally Posted by LondoJowo
    UTC is the same as GMT. Set your clock to use local time and the problem should be fixed.
    how would i change that?

    iif you mean the gui clock, than i don't think that's what the problem is (though i thought that at first too). when i type "date" i still get the time that the gui shows. it doesn't seem to store the time when i change it using "date ......." or it resets it at boot (i think that's what it's doing....i remember it saying "setting time to UTC" or something along those lines).

    thanks for helping

  4. $spacer_open
    $spacer_close
  5. #4
    Linux User nalg0rath's Avatar
    Join Date
    Sep 2004
    Location
    Stockholm
    Posts
    303
    On Gentoo:
    Code:
    ln -sf /usr/share/zoneinfo/[yourzone] /etc/localtime
    Replace [yourzone] with the right zone, list zones:
    Code:
    ls /usr/share/zoneinfo/*
    I used this (Sweden):
    Code:
    ln -sf /usr/share/zoneinfo/Europe/Stockholm /etc/localtime

  6. #5
    Linux Enthusiast
    Join Date
    Jun 2005
    Location
    Odessa, FL
    Posts
    586
    Quote Originally Posted by nalg0rath
    On Gentoo:
    Code:
    ln -sf /usr/share/zoneinfo/[yourzone] /etc/localtime
    Replace [yourzone] with the right zone, list zones:
    Code:
    ls /usr/share/zoneinfo/*
    I used this (Sweden):
    Code:
    ln -sf /usr/share/zoneinfo/Europe/Stockholm /etc/localtime
    thanks!

    I didn't know "America" was a folder and not a generlal timezone used :o. I now have my timezone set correctly, I'm sure of this....but the time is still off

    Now it's off by 4 hours....getting closer lol

    When my system is booting up, one of the checks it does says:
    Code:
    Setting system clock to hardware clock [UTC]
    that sounds to me like what my problem might be....i'm now curious how i make it look for my local timezone. i did set it according to your instructions (which seemed like a more detailed version of what the gentoo handbook had ), but for some reason it wants to use UTC still...

  7. #6
    Linux Engineer
    Join Date
    Jul 2003
    Location
    Stockholm, Sweden
    Posts
    1,296
    to keep your clock perfectly in sync with the rest of the world use ntp http://gentoo-wiki.com/HOWTO_NTP its easy

  8. #7
    Linux Guru loft306's Avatar
    Join Date
    Oct 2003
    Location
    The DairyLand
    Posts
    1,666
    Quote Originally Posted by variant
    to keep your clock perfectly in sync with the rest of the world use ntp http://gentoo-wiki.com/HOWTO_NTP its easy
    and if like here on my server if the deamon dosnt do what it is suposed to you can also set it as a cron...though this tut is better than the one i followed
    ~Mike ~~~ Forum Rules
    Testing? What's that? If it compiles, it is good, if it boots up, it is perfect. ~ Linus Torvalds
    http://loft306.org

  9. #8
    Linux Enthusiast
    Join Date
    Jun 2005
    Location
    Odessa, FL
    Posts
    586
    to the above two:

    thanks! i'll give it a shot . i like the idea behind it

    EDIT: yay!! that fixed it!

    thanks a lot!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •