Find the answer to your Linux question:
Results 1 to 4 of 4
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1

    GRUB problems with new genkernel

    I upgraded my kernel and genkernel, and I keep playing around with my grub.conf but all I get at startup is "GRUB _" (the "_" is blinking). Trying to repair based on some forums, I've removed my real_root parameter, my init parameter, my initrd reference, and i've changed root=/dev/ram0 to root=/dev/hda2. I also tried removing everything from "vga=" on.
    title Vidalinux Gentoo (2.6.12-r6)
       root (hd0,0)
       kernel /kernel-genkernel-x86-2.6.12-gentoo-r6 gentoo=nodevfs udev root=/dev/hda2 vga=0x317 video=vesa:ywrap,mtrr splash=silent
    I got rid of my grub.conf completely, to try to boot from the grub shell, but still all i get is "GRUB _". Why would that happen?

    Please help me, as I have been booting knoppix everyday for a few weeks now and I miss my gentoo dearly...

  2. #2
    Linux Guru loft306's Avatar
    Join Date
    Oct 2003
    The DairyLand
    well with a genkernel kernel you do need the "real_root p init parameter, & initrd "
    so lets look elsewhare
    1. did you remember to moumt /boot if it is a seperate partition befor you ran genkernel?
    2. if so did you check in /boot
    ls /boot/kernel* /boot/initrd*
    to see if the kernel and initrd were cp'd to /boot
    3. if they are there didi you check that there are no typo's in /boot/grub/grub.conf

    this sounds as if there is no kernel image for grub to boot.
    ~Mike ~~~ Forum Rules
    Testing? What's that? If it compiles, it is good, if it boots up, it is perfect. ~ Linus Torvalds

  3. #3
    i have a kernel image, but the version of genkernel didn't create an initrd, instead i have an initramfs.

  4. $spacer_open
  5. #4
    how were you able to fix this?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts