Find the answer to your Linux question:
Results 1 to 5 of 5
I used the Universal install CD, using kernel-2.6.11-gentoo-r3. After using genkernel and writing grub.conf, I reboot and see the following: Code: >> Mounting filesystems mount: Mounting devfs on /dev failed: ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Aug 2005
    Posts
    6

    Problem rebooting after writing grub.conf, multibooting Gentoo w/ other OS's [SOLVED]


    I used the Universal install CD, using kernel-2.6.11-gentoo-r3. After using genkernel and writing grub.conf, I reboot and see the following:

    Code:
    >> Mounting filesystems
    mount: Mounting devfs on /dev failed: No such device
    Error opening file: ".devfsd"   No such file or directory
    >> Determining root device...
    >> Block device /dev/hda6 is not a valid root device...
    >> The root block device is unspecified or not detected
       Please specify a device to boot, or "shell" for a shell...
    boot():
    I tried just guessing at /dev/hdak, where k=1,...,7, to see if any of them would work, but none did. It may also be relevant that I am triple-booting (OpenBSD, FreeBSD, and Gentoo), and fdisk shows:

    Code:
    Disk /dev/hda: 12.0 GB,  12072517632 bytes
    32 heads, 63 sectors/track, 11696 cylinders
    Units = cylinders of 2016 * 512 = 1032192 bytes
    
       Device    Boot     Start     End        Blocks    Id   System
    /dev/hda1                 1    3114       3138376+   a6   OpenBSD 
    /dev/hda2              3121    6241       3145464    a5   FreeBSD
    /dev/hda4              6300   11696       5440176     5   Extended
    /dev/hda5    *         6300    6331         32224+   83   Linux
    /dev/hda6              6332    6913        586624+   82   Linux swap / Solaris
    /dev/hda7              6914   11696       4821232+   83   Linux

    My question has several parts:

    1. How can I get back to grub.conf to look at it, so I can show you if you need to see it and also so I can see if I made some mistake there. I originally saved grub.conf in /boot/grub/grub.conf, but when I choose the "shell" option, I find that:

    Code:
    BusyBox v1.00-pre7 (2005.07.31-02:56+0000) Built-in shell (ash)
    Enter 'help' for a list of built-in commands.
    
    /bin/ash: can't access tty: job control turned off
    / # ls
    bin           lib              modules.cache       sbin           usr
    dev           linuxrc          newroot             sys            var
    etc           lost+found       proc                temp
    and this 'ash' is not equipped with an editor, so even if I could find grub.conf, I couldnt do anything to it... is it possible to use the universal install CD to edit things? If so, how would I do this?

    2. Do you have any suggestions on how to fix this so I can at least boot gentoo? My intent was to just make gentoo bootable and then LATER edit grub.conf so that I could boot any of the operating systems. Any advice at all would be much appreciated. Thanks.

  2. #2
    Linux Guru dylunio's Avatar
    Join Date
    Aug 2004
    Location
    Cymru
    Posts
    4,157
    If you boot any live cd you can mount gentoo and chroot into it (these are one of the first steps in the install section of the gentoo handbook) from here you can check your files. From the error message you got, I want to chegk that you settup gentoo's /etc/fstab up correctly? could you post it?
    Registered Linux User #371543!
    Get force-get May The Source Be With You
    /dev/null
    /dev/null2

  3. #3
    Just Joined!
    Join Date
    Aug 2005
    Posts
    6
    Unfortunately, I'm extremely n00b to Linux (using SuSE for about nine months... It may as well be windows, as far as learning goes)... I reinserted the Universal CD, booted gentoo, and tried the following commands from the handbook, but saw:

    Code:
    livecd root # cd mnt/gentoo
    livecd gentoo # ls
    livecd gentoo # mount -t proc none /mnt/gentoo/proc
    mount: mount point /mnt/gentoo/proc does not exist
    livecd gentoo # chroot /mnt/gentoo /bin/bash
    chroot: cannot run command '/bin/bash': No such file or directory
    livecd gentoo # mount -t proc none /mnt/gentoo
    livecd gentoo # chroot /mnt/gentoo /bin/bash
    chroot: cannot run command '/bin/bash': No such file or directory
    livecd gentoo #
    and I suspect I'm misunderstanding the commands you intended me to use...

    BUT, I tried something else and maybe this is what you're after...

    So I reboot (without CD), get to the error message and do:

    Code:
    >> The root block device is unspecified or not detected 
       Please specify a device to boot, or "shell" for a shell... 
    boot(): shell
    
    BusyBox v1.00-pre7 (2005.07.31-02:56+0000) Built-in shell (ash) 
    Enter 'help' for a list of built-in commands. 
    
    /bin/ash: can't access tty; job control turned off
    / # cd etc/
    /etc # ls
    devfsd.conf        initrd.defaults     modules
    fstab              initrd.scripts      udev
    /etc # cat fstab
    /dev/ram0       /        ext2          defaults
    /proc           /proc    proc          defaults     0 0
    /etc #
    I think this is what you're asking for... If not, let me know and I'll try again.

  4. #4
    Linux Newbie
    Join Date
    May 2005
    Posts
    222
    There was a bug in some genkernel versions, so you'll need to add ........udev.........in you grub.conf file as a work around.

    I suggest you print the entire handbook and follow it VERY carefully

  5. #5
    Just Joined!
    Join Date
    Aug 2005
    Posts
    6
    I eventually was able to use the livecd to chroot back onto gentoo and found that my fstab was just fine, as was grub.conf. The problem was most definitely the install order. I keep a transcript of every step I do in any install, and I redid the whole install verbatim, except this time installing first OpenBSD (into /dev/hda1), Linux (extended into /dev/hda4), and FreeBSD last (in /dev/hda2), following advice found at

    http://geodsoft.com/howto/dualboot/combine.htm

    However, grub didn't boot FreeBSD when it's grub.conf entry was as shown in the website above: I just imitated the entry for OpenBSD to make one for FreeBSD and it worked fine.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •