Find the answer to your Linux question:
Results 1 to 5 of 5
It's on the 3rd onboard IDE channel setup as /dev/hde. I've compiled support into the kernel and everything goes fine before I reboot. I fdisk it, create a primary then ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Mar 2005
    Posts
    14

    Problems with new 160gb drive, can mount, but craps after reboot


    It's on the 3rd onboard IDE channel setup as /dev/hde. I've compiled support into the kernel and everything goes fine before I reboot. I fdisk it, create a primary then write out. After that I do a mke2fs -j /dev/hde and it works out fine. Then I mount it and it's fine also.

    When I reboot however, when it's in the process of loading, I get an error saying "wrong fs type, ...., bad superblock,..." Here's the line of my fstab

    /dev/hde /mnt/hde ext3 defaults 0 0

    My other 40 and 60gb drives load fine, but this one won't. It will mount, however, if I format it again.

  2. #2
    Linux Guru lakerdonald's Avatar
    Join Date
    Jun 2004
    Location
    St. Petersburg, FL
    Posts
    5,035
    Try fsck'ing it.

  3. #3
    Just Joined!
    Join Date
    Jul 2005
    Location
    :noitacoL
    Posts
    51
    Have you seen this note in the install docs (4.e)?
    Warning: Due to a bug in the e2fsprogs package, you need to explicitly use the mount -t ext3 option if you are using an ext3 filesystem.
    Since I'm a newb, I'm not sure if it relates to your particular problem, but I thought I'd mention it just incase.

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    Mar 2005
    Posts
    14
    Quote Originally Posted by TheFourthBeast
    Have you seen this note in the install docs (4.e)?
    Warning: Due to a bug in the e2fsprogs package, you need to explicitly use the mount -t ext3 option if you are using an ext3 filesystem.
    Since I'm a newb, I'm not sure if it relates to your particular problem, but I thought I'd mention it just incase.
    Well I know that and it doesn't work. I mount it manually and it's fine, but when I get to loading fstab at startup, it fails.

  6. #5
    Linux Engineer
    Join Date
    Jul 2003
    Location
    Stockholm, Sweden
    Posts
    1,296
    modify the disk with fdisk or cfdisk THEN reboot, only then can you create a filesystem and expect it to work properly. cfdisk clearly states that you must reboot before creating a filesystem. (you could allso do a device reset with hdparm but thats a bad idea unless its essential that you dont reboot)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •