Find the answer to your Linux question:
Results 1 to 3 of 3
Hello, I've recently decided to take the plunge into a Stage 1 install of Gentoo in order to further my knowledge of Linux as a whole. I'm installing through Knoppix, ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Aug 2005
    Posts
    9

    Stage 1 env-update trouble with Gentoo 2005.0 [SOLVED]


    Hello,
    I've recently decided to take the plunge into a Stage 1 install of Gentoo in order to further my knowledge of Linux as a whole. I'm installing through Knoppix, and have been following the Handbook's instructions almost to a t (I had to make some adjustments, because my partition table is different than the one they use). Anyway, I've gotten to the point where I have chrooted into my incomplete Gentoo environment and have to run env-update. However, when I do so, I get this:
    #env-update
    !!! Unexpected end of config file: variable yes"
    !!! ParseError: Unexpected EOF: //etc/make.conf: on/before line 9 in //etc/make.conf
    !!! Incorrect multiline literals can cause this. Do not use them.
    Since I have a strong suspicion it has something to do with it, here's my make.conf:
    # These settings were set by the catalyst build script that automatically built this stage
    # Please consult /etc/make.conf.example for a more detailed example
    CFLAGS="-O2 -march=pentium3 -O3 -pipe -fomit-frame-pointer"
    CHOST="i686-pc-linux-gnu"
    CXXFLAGS="=march=pentium3 O3 -pipe -fomit-frame-pointer"
    MAKEOPTS="j2"
    GENTOO_MIRRORS="ftp://ftp.ussg.iu.edu/pub/linux/gentoo ftp://gentoo.cites.uiuc.edu/pub/gentoo/ ftp://distro.ibiblio.org/pub/linux/d...utions/gentoo/ ftp://mirror.iawnet.sandia.gov/pub/gentoo/ ftp://cs.ubishops.ca/pub/gentoo
    AUTOCLEAN="yes"
    It should be noted that the word at the end of "!!! Unexpected end of config file: variable" is always the last word of the make.conf file.

    I'd really like to get this system going, so ANY help on this is greatly appreciated, and thanks in advance!

  2. #2
    Just Joined!
    Join Date
    Jun 2005
    Location
    Harwich - England
    Posts
    52
    I think you have edited the CFLAGS incorrectly the O2 is there by default and you have added the O3 if I am incorrect then don't bother reading any further.
    I also believe that the entry for CXXFLAGS should read as follows
    Code:
    CXXFLAGS="${CFLAGS}"
    Try this for more info
    http://www.gentoo.org/doc/en/handboo...?part=1&chap=5

  3. #3
    Just Joined!
    Join Date
    Aug 2005
    Posts
    9
    Hmm...that didn't work. Thanks for proofing my script, though.

    EDIT: I fixed it, thanks to you. Your proofing led me to do some of my own, and I found that I was actually missing two quotation marks, which was giving me the error. Thanks a lot.

  4. $spacer_open
    $spacer_close

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •