Find the answer to your Linux question:
Results 1 to 3 of 3
I've searched and not found much that's relevant to my situation, so forgive me if I overlooked something obvious. Here's my problem: I recently upgraded from the 2.6.12-r6 to 2.6.12-r9 ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jun 2005
    Posts
    30

    kernel upgrade broke my sound


    I've searched and not found much that's relevant to my situation, so forgive me if I overlooked something obvious.
    Here's my problem: I recently upgraded from the 2.6.12-r6 to 2.6.12-r9 gentoo kernels and now my sound doesn't work. ALSA and snd-intel8x0 (the driver for my integrated SiS soundcard) are loaded as modules. alsaconf recognizes my sound card will configure it without complaint. However, when I run /etc/init.d/alsasound restart, I get this:
    * Caching service dependencies ... [ ok ]
    * WARNING: you are stopping a boot service.
    * Storing ALSA Mixer Levels ...
    /usr/sbin/alsactl: save_state:1163: No soundcards found... [ !! ]
    * Unloading ALSA ... [ ok ]
    * Unloading ALSA modules ... [ ok ]
    * Loading ALSA modules ...
    * Loading: snd-card-0 ... [ ok ]
    * ERROR: Failed to load necessary drivers [ ok ]
    * Restoring Mixer Levels ... [ ok ]

    my 2.6.12-r6 kernel, which I still have, supports my sound equipment perfectly. Oh, and if i do "cat /dev/urandom > /dev/dsp" I get static in my speakers, just like you're supposed to if the sound card is working right. Strange.

  2. #2
    Linux Guru sdousley's Avatar
    Join Date
    Feb 2004
    Posts
    1,790
    how did u update the kernel? Completely make it again from scratch?

    Not sure if this is how u did it, but the way i do it is to copy the ".config" file from the old kernel sources to the new. then check any changes, and compile.
    "I am not an alcoholic, alcoholics go to meetings"
    Registered Linux user = #372327

  3. #3
    Just Joined!
    Join Date
    Jun 2005
    Posts
    30
    Ummmm, yeah, that fixed it. Thanks. But why would my sound be broken when all the modules were loading correctly, I had run alsaconf, and /dev/dsp was set up and working? I feel like such a newbie.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •