Find the answer to your Linux question:
Results 1 to 6 of 6
Alright...this is getting really annoying! my internet will not work. I have the correct drivers installed for my nic i had /etc/conf.d/net set to do DHCP (exactly as the handbook ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jul 2005
    Location
    look out your window
    Posts
    72

    internet problems...this sucks [SOLVED]


    Alright...this is getting really annoying!
    my internet will not work.
    I have the correct drivers installed for my nic
    i had /etc/conf.d/net set to do DHCP (exactly as the handbook told me to) and it yelled at me about netmount not being right...im lost
    i tried static
    Code:
    /etc/conf.d/net
    config_eth0=( "192.168.123.143 netmask 255.255.255.0" )
    routes_eth0=&#40; "default gw 192.168.123.154" &#41; <- router
    then ifconfig tells me
    Code:
    inet addr&#58; 192.168.123.143 Bcast 192.168.123.255 Mask 255.255.255.0
    i try to ping www.gentoo.org (or anything)
    unknown host www.gentoo.org
    i try to ping my router
    From 192.168.123.143 icmp_sec=2 Destination Host Unreachable

    any ideas would be GREATLY appreciated
    -tuxxman

  2. #2
    Linux Engineer d38dm8nw81k1ng's Avatar
    Join Date
    Mar 2005
    Location
    Newcastle
    Posts
    793
    i'm assuming that you can't connect to the router for some reason (i don't know if that message means you can see your router or not). maybe your network card is configured incorrectly? i know that was the problem for me, i'd configured two network cards into my kernel and it was trying to use the realtek one instead of my VIA onboard adaptor.
    also if you configured the card in after the first kernel compile that could also cause problems, so try uncompiling the kernel and recompiling and see if that works.
    one last idea i have is that you could be using the wrong protocol to try and connect to the router. eg. PPPoE instead of PPPoA.
    Here's why Linux is easier than Windows:
    Package Managers! Apt-Get and Portage (among others) allow users to install programs MUCH easier than Windows can.
    Hardware Drivers. In SuSE, ALL the hardware is detected and installed automatically! How is this harder than Windows' constant disc changing and rebooting?

  3. #3
    Linux Newbie
    Join Date
    Aug 2005
    Location
    South India, 79 E 11 N
    Posts
    109
    Be happy. Life is too short to be unhappy!

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Guru budman7's Avatar
    Join Date
    Oct 2004
    Location
    Knee deep in Grand Rapids, Michigan
    Posts
    3,242
    Doyou have the module for your nic in modules.autoload.d/kernel-2.6 ?

    For instance I have a Realtek 8139 nic, so I put in there "8139too"
    And that allows me to use the internet.

    Could you post the contents of /etc/conf.d/net ?
    How to know if you are a geek.
    when you respond to "get a life!" with "what's the URL?"
    - Birger

    New users read The FAQ

  6. #5
    Linux Engineer
    Join Date
    Jul 2003
    Location
    Stockholm, Sweden
    Posts
    1,296
    how about telling us the error message that was "yelled at you"?

  7. #6
    Just Joined!
    Join Date
    Jul 2005
    Location
    look out your window
    Posts
    72
    solved....
    i cheated and used knoppix to configure the internet for me

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •