Find the answer to your Linux question:
Page 2 of 2 FirstFirst 1 2
Results 11 to 12 of 12
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #11
    Just Joined!
    Join Date
    Sep 2005
    New York

    Hi there !

    The problem you are having more than likely relates to you NOT having a a /dev filesystem at boot.

    The 2005.1 Handbook fails to mention this.

    To fix the problem, boot from your live cd:

    mount /dev/hda3 /mnt/gentoo
    mkdir /mnt/gentoo/boot
    mount /dev/hda1 /mnt/gentoo/boot
    mount -t proc none /mnt/gentoo/proc
    chroot /mnt/gentoo /bin/bash
    source /etc/profile
    The trick now, is simply to emerge udev:

    emerge udev
    You also want to check that you have (though it should already be set) in your kernel config:

    General Setup ->[*] Support for hot-pluggable devices

    And that devfs support is NOT enabled (this would require devfsd, which cannot be emerged from your universal live cd, and is no longer standard):

    File Systems -> Pseudo filesystems -> [ ] /dev file system support (OBSOLETE)

    Then exit:

    cd /
    umount /mnt/gentoo/boot /mnt/gentoo/proc /mnt/gentoo
    Hope this helps !

  2. #12
    Linux Engineer d38dm8nw81k1ng's Avatar
    Join Date
    Mar 2005
    you're missing the point. he can't boot the LiveCD. sounds like your hardware isn't being recognised by the liveCD to me as well. don't know how to fix it tho
    Here's why Linux is easier than Windows:
    Package Managers! Apt-Get and Portage (among others) allow users to install programs MUCH easier than Windows can.
    Hardware Drivers. In SuSE, ALL the hardware is detected and installed automatically! How is this harder than Windows' constant disc changing and rebooting?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts