Find the answer to your Linux question:
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 12
I'm a noob to Gentoo, I have experince with redhat / samba, It seems I'm confused about the installtion of gentoo, I downloaded the universal cd x86, I'm using a ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Sep 2005
    Posts
    5

    Kernel Panic - VFS


    I'm a noob to Gentoo, I have experince with redhat / samba,
    It seems I'm confused about the installtion of gentoo,
    I downloaded the universal cd x86,
    I'm using a 6gb hard drive that has no partitions,
    700mhz processor a little more than 128mb of memory. (128mb+64mb)
    Anyway I used the cd to boot with and got the options to select the kernel.
    selected gentoo and got this error

    (kernel panic - not syncing VFS: unable to mount root fs on unknown-block (1,0)

    This happened when I realized I had a full non formated dos partition,
    I realized my mistake and deleted the partition, now I'm still having this error. I have not setup linux partitions because I thought that the Live CD would allow you to do this during setup, like redhat and the other distro's so now I come to ask what have I done wrong,

    After some research it seems as if I need to setup my drive with a linux fdisk or cfdisk, and if so why doesn't gentoo come with it.
    but my bigger problem is finding the files and being able to make
    a linux fdisk on a windoz machine, btw the new installation of gentoo is on a seperate system than my windoz box.

    I looked for a possible iso to burn that would allow me to configure my drive but found nothing, Am I on the right path or have I veered into the woods, please help?

    Desperate Linux user.

  2. #2
    Linux Engineer
    Join Date
    Jul 2003
    Location
    Stockholm, Sweden
    Posts
    1,296
    the filesystem on the hard disk does not matter, the gentoo live cd should still boot, i sugest redownloading the gentoo live cd iso and burning it again. (be sure to download it again and not just burn the iso you allready have because it may be this that is at fault).

  3. #3
    Just Joined!
    Join Date
    Sep 2005
    Posts
    5
    I did this and checked the md5, but I'm using the latest version which might not be as stable as other versions. Gentoo boots to gentoo-nofb
    but still locks up after it boots.

    It recognizes all my hardware and but something is wrong.

    I will try a ealier version.

    any other suggestions are appreciated.

    I know somebody has run into this problem.

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Guru
    Join Date
    May 2004
    Location
    forums.gentoo.org
    Posts
    1,817
    Quote Originally Posted by NikoInc
    Gentoo boots to gentoo-nofb
    but still locks up after it boots.

    It recognizes all my hardware and but something is wrong.

    I will try a ealier version.
    If you have a good md5 check and -nofb works, that sounds like it may be hardware related. In any case, if are trying to install, using an earlier version to boot to shouldn't be an issue if you install from the internet.
    /IMHO
    //got nothin'
    ///this use to look better

  6. #5
    Just Joined!
    Join Date
    Sep 2005
    Posts
    5
    I also forgot that my harddrive is on the 2nd controller instead of the first because the first controller went out and doesn't work, would that make a difference, also I have no internet connection on the gentoo box so I used the universal cd.

  7. #6
    Linux Engineer
    Join Date
    Jul 2003
    Location
    Stockholm, Sweden
    Posts
    1,296
    try turning off all hardware detection, the frame buffer and DMA disk access.. this might get you further.

  8. #7
    Just Joined!
    Join Date
    Sep 2005
    Posts
    5
    thanks for the tip I will try this
    but just in case, is there anyway
    you could give me the correct commands
    on how to do this, I will research and try and
    figure it out on my own first, (I refuse to be lazy).
    Like most noobs.
    Does anyone think that the harddrive being on the
    2nd IDE controller have anything to do with this problem.
    Thanks...

    Niko...

  9. #8
    Linux Guru
    Join Date
    May 2004
    Location
    forums.gentoo.org
    Posts
    1,817
    Quote Originally Posted by NikoInc
    Does anyone think that the harddrive being on the
    2nd IDE controller have anything to do with this problem.
    I don't. Is your BIOS set to disregard the first 2 IDE channels? I'd set it that way just to be safe (and to save time in booting).
    /IMHO
    //got nothin'
    ///this use to look better

  10. #9
    Just Joined!
    Join Date
    Sep 2005
    Posts
    5
    (Is your BIOS set to disregard the first 2 IDE channels?)

    bios seems uncapable or (arcane) of such feats.
    I tried the cd on my windoz box and it
    worked with no prob, so I will still try
    thanks for all the help.

  11. #10
    Linux Engineer
    Join Date
    Jul 2003
    Location
    Stockholm, Sweden
    Posts
    1,296
    when you instert the live cd the first thing it gives you is a prompt, from there if you press f1 f2 and f3 you will get more boot options.. follow the instructions there to turn of hardware detection, frame buffer (nofb) and dma

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •