Find the answer to your Linux question:
Page 3 of 4 FirstFirst 1 2 3 4 LastLast
Results 21 to 30 of 39
So I did some backtracking and through playing with this thing I found something I want yalls opinion on. After I used the "Genkernel All" command, I was told to ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #21
    Just Joined!
    Join Date
    Sep 2005
    Location
    Dallas, Texas
    Posts
    15

    Here's the next one...


    So I did some backtracking and through playing with this thing I found something I want yalls opinion on. After I used the "Genkernel All" command, I was told to check the created kernel image name and initrd for later reference when configuring the boot loader. (Grub in this case)

    Here's the results:
    Code:
    ls /boot/kernel* /boot/initramfs*
    ls: /boot/initramfs*: No such file or directory
    /boot/kernel-genkernel-x86-2.6.12-gentoo-r6
    So here's my question of course, what's the initramfs/initrd and why is it saying no such file or directory.

    Thanks

  2. #22
    Linux Engineer
    Join Date
    Mar 2005
    Posts
    1,431
    initrd = initial ramdisk

    It may say that it doesn't exist because you don't have one... Not all setups use initrd, I don't use it. Did you check your fstab setup aswell?

  3. #23
    Just Joined!
    Join Date
    Sep 2005
    Location
    Dallas, Texas
    Posts
    15

    Fstab

    Okay, I brought up the Fstab. This was a long process copying by hand, but here it is.
    Code:
    /dev/boot                     /boot           ext2       noauto,noatime       1 2
    /dev/root                     /               ext3       noatime              0 1
    /dev/swap                     none            swap       sw                   0 0
    /dev/cdroms/cdrom0            /mnt/cdrom      iso9660    noauto,ro            0 0
    #/dev/fd0                     /mnt/floppy     auto       noauto               0 0
    
    Note: next line is critical to boot.
    proc                          /proc           proc       defaults             0 0
    
    
    shm                           /dev/shm        tmpfs      nodev,nosuid,noexec  0 0
    /dev/hda1                     /boot           ext2       defaults,noatime     1 2
    /dev/hda2                     none            swap       sw                   0 0
    /dev/hda3                     /               ext3       noatime              0 1
    none                          /proc           proc       defaults             0 0
    none                          /dev/shm        tmpfs      nodev,nosuid,noexec  0 0
    /dev/cdroms/cdrom0            /mnt/cdrom      auto       noauto,user          0 0
    Whew, Well there it is. Getting the thing to format all pretty in this post was a lot of work.
    Let me know what you think.

  4. $spacer_open
    $spacer_close
  5. #24
    Linux Guru
    Join Date
    May 2004
    Location
    forums.gentoo.org
    Posts
    1,817

    Re: Fstab

    Quote Originally Posted by Sovtek
    Getting the thing to format all pretty in this post was a lot of work.
    Let me know what you think.
    That's easy: just write the mono-space stuff in a monospace text editor and then cut-n-paste to the reply box!

    I think the lines for "/dev/boot" and "/dev/root" and /dev/swap" are just for example. I think you should delete them or comment them out with a '#' at the beginning of the line. Your "/dev/boot" is apparently "/dev/hda1". Also, I think proc should be last. So, not counting commented lines, I think this should be your fstab:
    Code:
    shm                           /dev/shm        tmpfs      nodev,nosuid,noexec  0 0
    /dev/hda1                     /boot           ext2       defaults,noatime     1 2
    /dev/hda2                     none            swap       sw                   0 0
    /dev/hda3                     /               ext3       noatime              0 1
    none                          /proc           proc       defaults             0 0
    none                          /dev/shm        tmpfs      nodev,nosuid,noexec  0 0
    /dev/cdroms/cdrom0            /mnt/cdrom      auto       noauto,user          0 0
    proc                          /proc           proc       defaults             0 0
    Maybe someone else can second this?
    /IMHO
    //got nothin'
    ///this use to look better

  6. #25
    Linux Engineer
    Join Date
    Mar 2005
    Posts
    1,431
    Almost, drakebasher you have double lines for proc and shm! Also, in this example I add an entry at the bottom for usb pendrive and floppy disk, remove the "#" in front of them if you need them:
    Code:
    /dev/hda1                     /boot           ext2       defaults,noatime     1 2
    /dev/hda2                     none            swap       sw                   0 0
    /dev/hda3                     /                   ext3       noatime              0 1
    
    none                            /proc              proc       defaults             0 0
    none                            /dev/shm        tmpfs      nodev,nosuid,noexec  0 0
    
    /dev/cdroms/cdrom0    /mnt/cdrom      auto       noauto,user          0 0
    # /dev/fd0                    /mnt/floppy     auto       noauto,user               0 0
    # /dev/sda                    /mnt/usb         vfat       noauto,user               0 0

  7. #26
    Just Joined!
    Join Date
    Sep 2005
    Location
    Dallas, Texas
    Posts
    15

    Continued.

    So I changed my fstab to match the recommendations. I went back through and re-wrote the grub.conf as well. Luckily It goes straight through for the most part, in other words no more hanging and making me type the whole:
    Code:
    kernel /kernel-genkernel-x86..... (etc, etc)
    But here are the remaining issues, first off it goes to a blank screen with a blinking cursor in the upper left hand corner. It waits there until any key is pressed and then completes the boot loader and into the kernel loading phase. Also the text is displayed in a very strange way, it appears garbled and trashy looking as it executes the boot loader phase prior to the kernel phase. Not that this is really an issue to fret over, but if it's a quick fix, by all means let me know...

    And secondly, most importantly, I'm still getting the Kernel Panic - not syncing. Any ideas? I have the fstab completely blank, and wrote ONLY what was posted by jaboua. What else causes this "mis-syncing"?
    Would it have something to do with the fact that it's checking root block (1,0) and not (0,0)? Just a stab in the dark, I'm trying to think of reasons for the failure here.

  8. #27
    Just Joined!
    Join Date
    Sep 2005
    Location
    Dallas, Texas
    Posts
    15

    Again...

    I just thought I should be sure and describe the exact error I was getting, once again, just for the sake of clarity and reference.

    Code:
    (more stuff prior)
    Net: Registered protocol family 1
    Net: Registered protocol family 17
    UDF-fs: No Partition found (1)
    XFS: bad magic number
    XFS: SB validate failed
    Kernel panic - not syncing: VFS: Unable to mount root fs on unknown_block (1,0)
    And this is a Stage3 install of Gentoo Linux, version 2.6.12-r6, x86, and 'genkernel all' was used. The system is using the 2005.1 x86 handbook as the default settings. Also, the partitioning scheme is:
    /dev/hda1 ext2 appx 32Mb (Boot)
    /dev/hda2 (swap) appx 512Mb (Swap)
    /dev/hda3 ext3 rest of the 20Gb (Root)

    Would any other info be of service with this issue?
    Thanks.

  9. #28
    Linux Engineer
    Join Date
    Mar 2005
    Posts
    1,431
    Can you post the grub config as well?

  10. #29
    Just Joined!
    Join Date
    Sep 2005
    Location
    Dallas, Texas
    Posts
    15

    Grub.conf

    Here's my Grub.conf

    Code:
    default 0
    
    timeout 30
    
    splashimage=(hd0,0)/grub/splash.xpm.gz
    
    title= Gentoo
    
    root(hd0,0)
    
    kernel /boot/kernel-genkernel-x86-2.6.12-gentoo-r6 root=/dev/ram0 init=/linuxrc ramdisk=8192 real_root=/dev/hda1
    Anything out of place?

  11. #30
    Linux Engineer
    Join Date
    Mar 2005
    Posts
    1,431
    Try adding a space between "root" and "(hd0,0)"

Page 3 of 4 FirstFirst 1 2 3 4 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •