Find the answer to your Linux question:
Page 4 of 4 FirstFirst 1 2 3 4
Results 31 to 39 of 39
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #31
    Just Joined!
    Join Date
    Sep 2005
    Location
    Dallas, Texas
    Posts
    15

    Correction


    I missed putting that space in (between the root and hd). So yeah, it's already there, and there's still the kernel panic.

    Could I have done something wrong during the install process? Should I just reformat and reinstall or something?

    Thanks

  2. #32
    on your grub.conf file....shouldn't

    real_root=/dev/hda3 ?

  3. #33
    Linux Guru
    Join Date
    May 2004
    Location
    forums.gentoo.org
    Posts
    1,817
    Good eye, junkman4547, If the fstab that jaboua shows a few posts up is right, real_root=/dev/hda3

    Additionally, since /boot is on /dev/hda1, the kernel statement should not include a path through /boot:
    Code:
    kernel /kernel-genkernel-x86-2.6.12-gentoo-r6 root=/dev/ram0 init=/linuxrc ramdisk=8192 real_root=/dev/hda3
    But apparently, since the kernel loads, this isn't a serious problem. But misplacing real_root is.
    /IMHO
    //got nothin'
    ///this use to look better

  4. $spacer_open
    $spacer_close
  5. #34
    I had the same problem and the solution was to change root=/dev/ram0 by root=/dev/hda3

    As far as I know this is uncorrect and shouldn't work ... but it's actually working on my computer ...

    I really don't understand why you should put your /dev/ram0 as root and specify a real_root when you use genkernelall and not when manually compiling the kernel ...

    Perhaps it will cause me serious problems laters using root as my real_root and not the ram, I'm currently gathering infos about genkernel ...

    Either way perhaps you should test ...

  6. #35
    Just Joined!
    Join Date
    Sep 2005
    Location
    Dallas, Texas
    Posts
    15

    Genkernel

    So I made the appropriate changes to the grub.conf and still no joy. I've been told by one source, that I NEED to have an initrd. I know this has been discussed already, but once again, what would it do if I re-emerged and ran genkernel all?

    Would it damage anything, or create any duplicates? Would it overwrite anything?

    Is it even advisable or would it be a logical step?

    I would exectue it like this:
    Code:
    mount /dev/hda3 /mnt/gentoo
    mount /dev/hda1 /mnt/gentoo/boot
    mount -t proc none /mnt/gentoo/proc
    chroot /mnt/gentoo /bin/bash
    env-update
    (and finally)
    emerge genkernel
    genkernel all
    The idea behind this would be in hopes of genkernel actually creating an initrd, or perhaps config-ing something correctly this time... Any opinions?

  7. #36
    Linux Engineer
    Join Date
    Mar 2005
    Posts
    1,431
    It will probably not duplicate anything.

    It won't damage anything.

    It will overwrite the current kernel.

    I would advise you to try, if not perhaps trying to roll your own kernel...

  8. #37
    Just Joined!
    Join Date
    Sep 2005
    Location
    Dallas, Texas
    Posts
    15

    Fixed.

    Jaboua, you're right on the money. I fixed this sucker. So here's the answer folks...

    DON'T USE GENKERNEL.

    I completely reformatted, reinstalled a stage 3, and config-ed my own kernel in like, a few hours.

    Works just fine now, So I know it was genkernel that was causing the issues. It seems that it's not so good at auto configing.

    Anyhow, THANK YOU to anyone and everyone who posted here.

    (Resolved)

  9. #38
    Linux Guru
    Join Date
    May 2004
    Location
    forums.gentoo.org
    Posts
    1,817

    Re: Fixed.

    Quote Originally Posted by Sovtek
    DON'T USE GENKERNEL.
    That's a bit harsh. I'm sure I'm not the only one who has sucessfully installed with Genkernel! I don't think there is any system/method that works for all without some allowance.
    /IMHO
    //got nothin'
    ///this use to look better

  10. #39

    Angry same problem

    Hello all!
    I'm trying to install gentoo now, but get same messange as in the first post:
    Please append a correct "root=" boot option
    kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(0,0)

    Here's my grub.conf:
    timeout 7
    default 0
    title Gentoo
    root (hd0,0)
    kernel /boot/gentoo-2.6.17 root=/dev/hda1

    Here's my fstab:
    /dev/hda1 / ext3 noatime,noauto,notail 0 1
    /dev/hda2 none swap sw 0 0
    /dev/hda3 /root reiserfs user,noatime 0 0

    I use menuconfig to set up the kernel. I build reiser and ext2 / ext3 support into the kernel (not as module) and have tried everything i could think of, but still get the same error.
    Any ideas will be appreciated.

    mARGO

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •