Find the answer to your Linux question:
Page 2 of 2 FirstFirst 1 2
Results 11 to 20 of 20
Originally Posted by junkman4547 My clock was all screwed up also but I made the change through desktop GUI. The thing is, I had to do it twice ! ! ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #11
    Linux Enthusiast
    Join Date
    Jun 2005
    Location
    Odessa, FL
    Posts
    586

    Quote Originally Posted by junkman4547
    My clock was all screwed up also but I made the change through desktop GUI. The thing is, I had to do it twice ! ! The first time it reverted back to the wrong time, then I did it again, and now it's ok.
    what gui do you use? i'm wondering how i'd change the clock in xfce4? i looked for it very briefly but quickly stopped and resorted back to...
    Code:
    date MMDDhhmmYYYY
    since it seemed easy enough to do. i haven't tried fixing it since it first arose again (a few days ago after an update), but i'll try changing the time again later once i get back home from school

    i'll also update my system again, hoping that it might fix the problem

    last time i updated it...i was asked about 40+ things when i ran
    Code:
    etc-update
    ...way more than i usually have (2 or 3...if that)

  2. #12
    Linux Newbie jpalfree's Avatar
    Join Date
    Jul 2005
    Location
    Montreal, CA
    Posts
    198
    my clock has been acting up too.
    i keep setting it to the correct time...correct timezone..but it keeps messing up.
    for example, yesterday... it said it was november 24th, quarter to 4...when it was 22h30...
    i'm going to check the bios when i get home...
    Avatar from xkcd.com, a hilarious computer related webcomic.

  3. #13
    Linux Newbie
    Join Date
    May 2005
    Posts
    222
    I made the correction through KDE desktop GUI, Josolanes. At the lower right hand corner where the time is display, right click on the time and choose adjust time and date.

  4. #14
    Linux Enthusiast
    Join Date
    Jun 2005
    Location
    Odessa, FL
    Posts
    586
    Quote Originally Posted by junkman4547
    I made the correction through KDE desktop GUI, Josolanes. At the lower right hand corner where the time is display, right click on the time and choose adjust time and date.
    i tried right clicking the clock in xfce and it has an option "Xfce Clock" but it's grayed out. i thought it was because i'm a normal/non-root user, so i started xfce as root instead and that didn't help either

    the clock's still of btw...it's not bothering me much any more but it would be nice to fix it

  5. #15
    Linux Engineer
    Join Date
    Mar 2005
    Posts
    1,431
    I would check the bios clock, reboot, press F1/F2/DEL/Whatever to get into the BIOS, and there will probably be an option for changing the clock there.

  6. #16
    Linux Enthusiast
    Join Date
    Jun 2005
    Location
    Odessa, FL
    Posts
    586
    Quote Originally Posted by jaboua
    I would check the bios clock, reboot, press F1/F2/DEL/Whatever to get into the BIOS, and there will probably be an option for changing the clock there.

    that fixed it...but when i log in (cli) it shows the time 7 hours behind. when i open xfce, the time is correct. that's fine by me but i'm wondering if anyone knows why this would be

    well, i had this problem previously and the only solution that we could come up with was to use ntpdate (well...that doesn't exist any more so it's useless to me). the bios, at the time, was correct but the time in linux was off by a certain number of hours and minutes (not just hours). this is why i didn't even bother checking the bios. hmm...well, that was simple enough

    UPDATE (on the time being different in CLI)
    the first time i logged in it showed 04:28. i tried logging in in another shell...and got 18:14. thinking that was odd, i tried another shell and got 11:37 (right time). then i tried again and got 11:32.

    why is this?

  7. #17
    Linux Engineer
    Join Date
    Mar 2005
    Posts
    1,431
    That really is odd... Are you logging in as the same user? Do you still have ntpdate on? You are sure there's nothing wrong with the hardware clock?

  8. #18
    Linux Enthusiast
    Join Date
    Jun 2005
    Location
    Odessa, FL
    Posts
    586
    Quote Originally Posted by jaboua
    That really is odd... Are you logging in as the same user? Do you still have ntpdate on? You are sure there's nothing wrong with the hardware clock?
    i hope there's nothing wrong with the hardware clock...

    i logged in as the same user (root) the second and third time, the other times were with my normal user (josh)

    ntpdate is off...atleast not loading. it's not being used any more, according to portage. i lost it during one of my updates


    EDIT: if it is the hardware clock, is there anyway to fix it/get it repaired. would a new cmos battery help? (i believe that's what it is...)

  9. #19
    Linux Engineer
    Join Date
    Mar 2005
    Posts
    1,431
    hmm... I dunno how to repair a hardware clock or if replacing the cmos battery will work, but if you get into BIOS again, is the clock still right?

    I've been having some bios problems on my box too, for some weird reason the clock sometimes reverts to UTC instead of local time (therefore I gave up and started using UTC with local timezone instead of local hardware clock) and during soft reboots, there is a chance of the sound card being disabled...

  10. #20
    Linux Enthusiast
    Join Date
    Jun 2005
    Location
    Odessa, FL
    Posts
    586
    Quote Originally Posted by jaboua
    hmm... I dunno how to repair a hardware clock or if replacing the cmos battery will work, but if you get into BIOS again, is the clock still right?

    I've been having some bios problems on my box too, for some weird reason the clock sometimes reverts to UTC instead of local time (therefore I gave up and started using UTC with local timezone instead of local hardware clock) and during soft reboots, there is a chance of the sound card being disabled...
    my clock seems to be right now...that was really strange. it seemed to randomnly shift off by 4 hours . for now, i'll consider everything to be fine...i just hope i don't start having weird problems with it.

    good luck with your hardware clock and sound card problems

Page 2 of 2 FirstFirst 1 2

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •