Find the answer to your Linux question:
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 20
First, i'm using ntpdate to sync my system clock before it boots because if i don't my clock is off by 4 hours (4 hours slow). Well, i recently started ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux Enthusiast
    Join Date
    Jun 2005
    Location
    Odessa, FL
    Posts
    586

    How to disable "checking system clock [UTC]" in start-up?


    First, i'm using ntpdate to sync my system clock before it boots because if i don't my clock is off by 4 hours (4 hours slow).

    Well, i recently started using initng to start my computer services and such (starts everything in parallel)...which has sped up start up time some. but now one of two things happened when i did this...either ntpdate is starting before it checks the system clock or ntpdate isn't starting at all.

    how should i fix this?

    if i can't fix this, than can someone help me figure out why my system clock is off by 4 hours? my bios time is right and my timezone is right...

  2. #2
    Linux Engineer
    Join Date
    Mar 2005
    Posts
    1,431
    Is your system-clock (in the BIOS) set to local time or UTC? If it's for example local time and linux belive it's UTC, then you get a clock skew. This can be configured in /etc/conf.d/clock

  3. #3
    Linux Enthusiast
    Join Date
    Jun 2005
    Location
    Odessa, FL
    Posts
    586
    Quote Originally Posted by jaboua
    Is your system-clock (in the BIOS) set to local time or UTC? If it's for example local time and linux belive it's UTC, then you get a clock skew. This can be configured in /etc/conf.d/clock
    i'm not sure how to check whehter my bios clock is utc or local, but i changed the /etc/conf.d/clock to local instead of UTC and rebooted out of curiosity. the time is still the same...4 hours behind

    any idea what it might be?

    thanks for helping

  4. #4
    Linux Engineer
    Join Date
    Mar 2005
    Posts
    1,431
    Have you configured the correct timezone? Do an "ls -l /etc/localtime"

  5. #5
    Linux Enthusiast
    Join Date
    Jun 2005
    Location
    Odessa, FL
    Posts
    586
    Quote Originally Posted by jaboua
    Have you configured the correct timezone? Do an "ls -l /etc/localtime"
    this is what i get:
    Code:
    localhost josh # ls -l /etc/localtime
    lrwxrwxrwx  1 root root 36 Jul 13 06:21 /etc/localtime -> /usr/share/zoneinfo/America/New_York
    i live in fl (same timezone as new york), so it seems alright

  6. #6
    Linux Engineer
    Join Date
    Mar 2005
    Posts
    1,431
    When you changed to local time and rebooted, did you disable NTP? Have you tried symlinking /etc/localtime to /usr/share/zoneinfo/UTC or whatever it's called just to check?

  7. #7
    Linux Guru budman7's Avatar
    Join Date
    Oct 2004
    Location
    Knee deep in Grand Rapids, Michigan
    Posts
    3,242
    Instead of America/new york, maybe you sould try EST5EDT.

    I live in Michigan and that is the same timezone as N.Y. and EST5EDT is what I use.
    How to know if you are a geek.
    when you respond to "get a life!" with "what's the URL?"
    - Birger

    New users read The FAQ

  8. #8
    Linux Enthusiast
    Join Date
    Jun 2005
    Location
    Odessa, FL
    Posts
    586
    Quote Originally Posted by budman7
    Instead of America/new york, maybe you sould try EST5EDT.

    I live in Michigan and that is the same timezone as N.Y. and EST5EDT is what I use.
    that's my new timezone and it still has the same time...4 hours behind. i don't get it

  9. #9
    Linux Enthusiast
    Join Date
    Jun 2005
    Location
    Odessa, FL
    Posts
    586
    Quote Originally Posted by jaboua
    When you changed to local time and rebooted, did you disable NTP? Have you tried symlinking /etc/localtime to /usr/share/zoneinfo/UTC or whatever it's called just to check?
    i haven't tried that yet

    ...just to make sure before i do that, this is what i would type to do this...?
    Code:
    ln -s /etc/localtime /usr/share/zoneinfo/UTC
    i just want to make sure that's what i do

  10. #10
    Linux Newbie
    Join Date
    May 2005
    Posts
    222
    My clock was all screwed up also but I made the change through desktop GUI. The thing is, I had to do it twice ! ! The first time it reverted back to the wrong time, then I did it again, and now it's ok.

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •