Find the answer to your Linux question:
Page 2 of 2 FirstFirst 1 2
Results 11 to 13 of 13
Originally, I had vga=0x317, which did not work. I've just tried vga=0x305, no go. I'll give 0x311 a shot. Another question, I've been tinkering with the x window sistem, specifically ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #11
    Linux Engineer psic's Avatar
    Join Date
    Nov 2004
    Location
    Ljubljana, Slovenia
    Posts
    1,205

    Originally, I had vga=0x317, which did not work. I've just tried vga=0x305, no go. I'll give 0x311 a shot. Another question, I've been tinkering with the x window sistem, specifically with the xorg.conf file. I've gotten everything working except for the mouse, and even that works, in a way. When I test out the config or startx, I get xwindows, but the pointer jumps to the top of the screen. If I move my mouse around, it jumps left and right, sometimes down across the screen. So my mouse is working, just not usefull. Any ideas on what to check in the config file?

    Here's the "InputDevice" section:
    Identifier "Serial Mouse"
    Driver "mouse"
    Option "Protocol" "Microsoft" __> I think this might be the cause
    Option "Device" "/dev/input/mouse0"
    Option "Emulate3Buttons" "true"
    Option "Emulate3Timeout" "70" __> not sure about this one, it's the same in the kanotix config.

    My mouse is a serial, two buttons and a scrool wheel. The options are the same I had in kanotix.
    Stumbling around the 'net:
    www.cloudyuseful.com

  2. #12
    Linux Engineer
    Join Date
    Mar 2005
    Posts
    1,431
    Try using protocol "Auto" if you think that might cause an issue. But you won't need to emulate three buttons when you have a scroll wheel! Just press the scroll wheel in, it works the same way.

    About the VGA statement, try removing it. In a manually compiled kernel you can set the default displaymode directly in the kernel, don't know about genkernel which displaymode it uses. I was terrorised with it before, but after trying different of the available modes I found one working fine and added it. Also, note that if genkernel uses vesafb driver instead of vesafb-tng, you have to use vga=773 instead.

  3. #13
    Linux Engineer psic's Avatar
    Join Date
    Nov 2004
    Location
    Ljubljana, Slovenia
    Posts
    1,205


    X works! It was the 'Auto' that did it. As for the VGA, I first didn't have any statement, only when I got that error did I add one. I'll go through them all and see if any work.
    Stumbling around the 'net:
    www.cloudyuseful.com

  4. $spacer_open
    $spacer_close
Page 2 of 2 FirstFirst 1 2

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •