Find the answer to your Linux question:
Results 1 to 9 of 9
Hello all, this is my first post in these forums, I hope someone has an idea. I am running KDE 3.4 and my sound works for the OS sounds, the ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Oct 2005
    Posts
    4

    Alsa not working correctly.


    Hello all, this is my first post in these forums, I hope someone has an idea. I am running KDE 3.4 and my sound works for the OS sounds, the dings and such, but I cannot get sound with XMMS unless I choose the OSS plugin and it sounds crappy. Also I cannot get sound in Unreal Tournament 2004. When I use the Alsa Output Plugin 1.2...somethin' I can see the equalizer moving like the music is playing but no sound.

    There are no errors on startup, I have alsa loading as a module, have unmuted all that's needed in alsamixer. User is part of the audio group. I am using SB Live 24 Bit, and have installed what I believe to be the correct driver. Any other questions I will be happy to answer. Also any help would be extremely appreciated. Thanx

    -=j0nnyr0773n=-

  2. #2
    Linux Engineer
    Join Date
    Mar 2005
    Posts
    1,431
    In XMMS, try choosing the "arts" plugin. If it doesn't exist, emerge xmms-arts. Also try using "artsdsp utcommand" where utcommand is the command needed to start ut.

    The problem is that aRts (the KDE sound daemon) takes control over the sound device, and the apps aren't aware of it. "xmms-arts" plugin makes XMMS send the sound to aRts instead of directly to the sound device (oss or alsa) or another sound daemon (esound). Apps which don't have an arts plugin, can use artsdsp or something like that to pass the application sounds on to aRts.

  3. #3
    Linux Guru loft306's Avatar
    Join Date
    Oct 2003
    Location
    The DairyLand
    Posts
    1,666
    this sounds as if' 'oss' may be checked in the kernel and is blocking the 'alsa' stuff from loading also you can't have both
    ~Mike ~~~ Forum Rules
    Testing? What's that? If it compiles, it is good, if it boots up, it is perfect. ~ Linus Torvalds
    http://loft306.org

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    Oct 2005
    Posts
    4
    Oops, sorry guys, what I meant is that instead of OSS, XMMS will only work with arts, but it doesn't sound good, I would like it to use alsa. I do have the plugin in the preferences, but when I use it there is no sound just eq bouncing.

    In make menuconfig I have OSS Mixer API, and OSS PCM (digital audio) API configured as modules should I remove those and recompile kernel? I would like to use alsa for everything if possible.

    Also I have tried artsdsp ut2004 and still no sound
    Thank you for your help

    -=j0nnyr0773n=-

  6. #5
    Linux Engineer
    Join Date
    Mar 2005
    Posts
    1,431
    If you want to, you can deactivate aRts in kcontrol... Or decrease the time before aRts automaticly deactivates itself.

  7. #6
    Just Joined!
    Join Date
    Oct 2006
    Posts
    1

    Your alsa fix

    First: check /etc/make.conf "USE="mp3 alsa arts vorbis ogg xmms" should be there
    if not put it in there and run "emerge --update --deep --newuse world"
    and "emerge --update --deep --newuse system"
    now exit kde and log back in.
    Second: run "alsamixer"
    if you see IEC958 mute it(its the digital signal from your SBL 24B). also turn all your volumes to >50(SB Live have been known to skip at higher vols).
    if alsamixer dosen't work, check it in su. still no? run "alsaconfig". Your driver should be the "CA0106".
    Tell me if any of that helps and I'll get back to you.

    Stage1 Gentoo nightmares still.
    Zcomp

  8. #7
    Linux Guru Juan Pablo's Avatar
    Join Date
    Mar 2006
    Location
    /home/south_america/ecuador/quito
    Posts
    2,064
    In make menuconfig I have OSS Mixer API, and OSS PCM (digital audio) API configured as modules should I remove those and recompile kernel?
    You MUST deactivate OSS in the kernel to get ALSA to work. It is in the Gentoo webpage
    Put your hand in an oven for a minute and it will be like an hour, sit beside a beautiful woman for an hour and it will be like a minute, that is relativity. --Albert Einstein
    Linux User #425940

    Don't PM me with questions, instead post in the forums

  9. #8
    Just Joined!
    Join Date
    Sep 2006
    Posts
    3
    You MUST deactivate OSS in the kernel to get ALSA to work. It is in the Gentoo webpage
    LoL you didn't understand him - OSS Mixer API and OSS PCM is options in submenu ALSA in kernel so it is emulation of OSS, not OSS. But i have similar problem and i dont know what to do :/ I dont use aRts because i heard that's ****. I wish to use only alsa.

    Second: run "alsamixer"
    if you see IEC958 mute it(its the digital signal from your SBL 24B). also turn all your volumes to >50(SB Live have been known to skip at higher vols).
    if alsamixer dosen't work, check it in su. still no? run "alsaconfig". Your driver should be the "CA0106".
    Tell me if any of that helps and I'll get back to you.
    Yeah thanx man!!! That solved my problem by the way please admins to delete my thread about alsa Sory for spamming

  10. #9
    Linux Guru Juan Pablo's Avatar
    Join Date
    Mar 2006
    Location
    /home/south_america/ecuador/quito
    Posts
    2,064
    The best way to get OSS support without interfering with ALSA is by using alsa-oss ebuild
    Put your hand in an oven for a minute and it will be like an hour, sit beside a beautiful woman for an hour and it will be like a minute, that is relativity. --Albert Einstein
    Linux User #425940

    Don't PM me with questions, instead post in the forums

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •