Find the answer to your Linux question:
Results 1 to 3 of 3
I installed Gentoo Stage 3 on a friends machine. He wanted to be able to login to X by default. So I set the inittab file to boot to runlevel ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux Guru budman7's Avatar
    Join Date
    Oct 2004
    Location
    Knee deep in Grand Rapids, Michigan
    Posts
    3,242

    xdm and twm


    I installed Gentoo Stage 3 on a friends machine.
    He wanted to be able to login to X by default. So I set the inittab file to boot to runlevel 5 and did

    rc-update add xdm default

    Now whenever the machine boots, it will only bring up twm, no kde. No option for which session to choose from. At least not that I can see.
    KDE and Xfce4 are installed.

    So I edited inittab, set it to boot to runlevel 3.
    Created a .xinitrc file, put "exec startkde".

    But it still boots to runlevel 5 and TWM.
    So I did

    rc-update del xdm default

    Now it will boot to command-line and if I use "startx", KDE will start up.

    Does anybody know how I can get this to boot to runlevel and KDE?
    How to know if you are a geek.
    when you respond to "get a life!" with "what's the URL?"
    - Birger

    New users read The FAQ

  2. #2
    Linux Guru dylunio's Avatar
    Join Date
    Aug 2004
    Location
    Cymru
    Posts
    4,157
    erm, try setting the inittab to the default runlevel of 3, then
    Code:
    rc-update add xdm default
    and make sure he has
    exec startkde
    If that doesn't work you might want to look into gdm or kdm instead of xdm.
    Registered Linux User #371543!
    Get force-get May The Source Be With You
    /dev/null
    /dev/null2

  3. #3
    Linux Engineer psic's Avatar
    Join Date
    Nov 2004
    Location
    Ljubljana, Slovenia
    Posts
    1,205
    Just a thought: have you emerged xdm? Also, make sure your /etc/rc.conf has the DISPLAYMANAGER="xdm" line.
    Stumbling around the 'net:
    www.cloudyuseful.com

  4. $spacer_open
    $spacer_close

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •