Find the answer to your Linux question:
Results 1 to 9 of 9
Hi all. I'm new to Gentoo (and in fact to Linux in general). I decided to install it on an old machine of mine to learn more about it. I ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Oct 2005
    Posts
    1

    Gentoo nVidia problems


    Hi all.

    I'm new to Gentoo (and in fact to Linux in general). I decided to install it on an old machine of mine to learn more about it. I managed to get through the installation in the end, but I'm now stuck and would appreciate some assistance.

    I've been following the Gentoo Linux nVidia Guide (here) and the X Server Configuration HowTo (here) but when I get to the point when I run X I get the following errors:

    Code:
    NVIDI(0): Failed to initialize the NVIDIA kernel module!
    NVIDI(0): *** Aborting ***
    Screen(s) found, but none have a useable configuration.
    Can anyone offer any help? I've looked around and seen that a lot of people have problems with the nvidia drivers, but I'm not sure where to go from here.

    I can provide more info about things, if you tell me what might be useful...

  2. #2
    Just Joined!
    Join Date
    Oct 2005
    Posts
    2
    miceless,

    I'd ask you for more info if you were in a GUI enviroment and could copy/paste stuff, but I'm going to take a pot-shot and say you probably didn't reemerge nvidia-kernel after compiling your kernel, and probably have a version mismatch. To check this out, do a
    Code:
    modinfo nvidia
    At the end of this will be a line for version-magic, make sure it matches your kernel version (see uname -a). If this is all good, it most likely a typo/error in your xorg.conf that you've overlooked. Make sure you're using the "nvidia" driver NOT "nv." If you still have a problem, post the following:

    uname -a
    xorg.conf
    cat /var/log/Xorg.0.log
    dmesg (if you feel the need)

    P.S. Do not be fooled with the straightforwardness of Xorg guides. I've had to change my xorg.conf MANY times before getting things to work optimally (or at all in the beginning). In particular, you may be interested in some of the following options under the Section "Device." Here's mine:

    Code:
    Section "Device"
    
    	Identifier  "Card0"
    	Driver      "nvidia"
    	VendorName  "nVidia Corporation"
    	BoardName   "Unknown Board"
    	BusID       "PCI:5:0:0"
    	VideoRam    131072	
    	Option      "NvAGP" "1" # use nvidias agp - 1 , agpgart -2, agpgart,nvagp -3 
     	Option      "NoLogo" "true" 
     	Option      "NoRenderExtension" "false" 
     	Option      "RenderAccel" "true" 
     	Option      "AllowGLXWithComposit" "true" 
     	Option      "CursorShadow" "true" 
     	Option      "CursorShadowAlpha" "32" 
     	Option      "BackingStore" "true"
    	Option	    "NoBandWidthTest" "1" 
    	Option      "NoPowerConnectorCheck" "1"
    	Option 	    "XvmcUsesTextures" "1"
    #	Option 	    "IgnoreEDID" "1"
    EndSection

  3. #3
    Just Joined!
    Join Date
    Nov 2005
    Posts
    1

    Device node not created

    I believe this is a bug in the current 2005.1 state of affairs, but running this for me solved hte problem:

    Code:
    # /sbin/NVmakedevices.sh
    Hope that helps.

  4. #4
    Linux Guru dylunio's Avatar
    Join Date
    Aug 2004
    Location
    Cymru
    Posts
    4,157
    Yes this has been a recent bug, and if one runs
    Code:
    /sbin/NVmakedevices.sh
    it should fix it's self. You should add this command to the boot process by puting it in /etc/conf.d/local.start
    Code:
    if [ i -e /dev/nvidia0 ]; then
               /sbin/NVmakedevices.sh
    fi
    Registered Linux User #371543!
    Get force-get May The Source Be With You
    /dev/null
    /dev/null2

  5. #5
    Linux Newbie
    Join Date
    Mar 2005
    Location
    Minneapolis, MN
    Posts
    112
    I'd recommend going to the command line and downloading the latest official nVidia drivers from their website through Links. This solved the same problem for me. Follow nVidia's instructions instead of Gentoo's; they both work the same with X Server's instructions.
    --Dachnaz [Fuzzy Llama]

  6. #6
    Content Team
    Join Date
    Nov 2005
    Location
    Colorado USA
    Posts
    4
    The best solution is to file a bug report at bugs.gentoo.org and try to CC the maintainer of the package. As it stands now the best way is to do it is the Gentoo way (with emerge) and then run the script in question: /sbin/NVmkdevices

  7. #7
    Linux Newbie
    Join Date
    Mar 2005
    Location
    Minneapolis, MN
    Posts
    112
    You can always unmask the nVidia drivers so when you emerge them, you will have the latest version (which does not give this error when I tried it).

    Code:
    # echo "media-video/nvidia-kernel ~x86" >> /etc/portage/package.keywords
    # echo "media-video/nvidia-glx ~x86" >> /etc/portage/package.keywords
    # echo ">media-video/nvidia-glx-1.0.7676-r1" >> /etc/portage/package.mask
    # emerge nvidia-kernel nvidia-glx
    That should be it. Start X and enjoy! ^^
    --Dachnaz [Fuzzy Llama]

  8. #8
    Linux Newbie
    Join Date
    Apr 2005
    Location
    NJ, USA
    Posts
    104
    i had this problem when i set up my nvidia TNT2. The problem was that i compiled agpgart directly into the kernel instead of as a module...I got the exact same error message too. Try compiling agpgart as a module.
    My New years Resolution is 1280x1024

  9. #9
    Just Joined!
    Join Date
    Dec 2005
    Posts
    1

    I had that, and I can solve it

    Hey,
    I just had that problem the other day. I just decided to finally make the switch. I spent countless hours online, then I emerged nirc and went into the chat. Luckilly emorphix was in #gentoo. He helped me out, And i had to learn a little bit more to (I screwed a few things up cuz it wasnt step by step) so now i will pass the knowledge onto you.
    Heres my config. I have an nvidia GeforceFX5200 Agp, with 256MB VRAM. Ok. KDE 3.4, kernel 2.6.

    commands to type to update your kernel as well as your xorg:

    first remove the old stuff
    su - // I would assume your root already if your updating like this, but for good measure
    enter password
    rmmod nvidia // remove nvidia from memory
    emerge unmerge nvidia-glx // get rid of the current
    emerge unmerge nivia-kernel //see above
    lsmod // this makes sure that the module is gone from memory
    ACCEPT_KEYWORDS="~x86" emerge nvidia-glx // this is so u get the masked packages
    it should give u a message about running something like eselect opengl set nvida or something, RUN IT.
    then run modules-update
    reboot

    login
    startx and it will work.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •