Find the answer to your Linux question:
Page 2 of 2 FirstFirst 1 2
Results 11 to 15 of 15
here ill show you Code: localhost steven # mplayer -vo x11 /home/steven/Desktop/Movies/Movies/Fight Club DVD quality.avi MPlayer 1.0pre7try2-3.3.6 (C) 2000-2005 MPlayer Team CPU: Intel Pentium 4/Xeon/Celeron Northwood (Family: 8, Stepping: 4) ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #11
    Linux Enthusiast crashandburn0420's Avatar
    Join Date
    Jun 2005
    Location
    Naugatuck, CT
    Posts
    590

    here ill show you
    Code:
    localhost steven # mplayer -vo x11 /home/steven/Desktop/Movies/Movies/Fight Club DVD quality.avi
    MPlayer 1.0pre7try2-3.3.6 (C) 2000-2005 MPlayer Team
    CPU: Intel Pentium 4/Xeon/Celeron Northwood (Family: 8, Stepping: 4)
    Detected cache-line size is 64 bytes
    MMX supported but disabled
    MMX2 supported but disabled
    SSE supported but disabled
    SSE2 supported but disabled
    CPUflags:  MMX: 0 MMX2: 0 3DNow: 0 3DNow2: 0 SSE: 0 SSE2: 0
    Compiled for x86 CPU with extensions:
    
    
    
    85 audio & 196 video codecs
    Playing /home/steven/Desktop/Movies/Movies/Fight.
    File not found: '/home/steven/Desktop/Movies/Movies/Fight'
    Failed to open /home/steven/Desktop/Movies/Movies/Fight
    
    Playing Club.
    File not found: 'Club'
    Failed to open Club
    
    Playing DVD.
    File not found: 'DVD'
    Failed to open DVD
    
    Playing quality.avi.
    File not found: 'quality.avi'
    Failed to open quality.avi
    
    
    Exiting... (End of file)
    localhost steven #
    same error

  2. #12
    Linux Guru dylunio's Avatar
    Join Date
    Aug 2004
    Location
    Cymru
    Posts
    4,157
    You have spaces in the name of the file you wish to play you need to let it know that there are spaces in the filename, this is done with the \ (backstash). So try the following (as user first, and then root if it doesn't work):
    Code:
    mplayer -vo x11 /home/steven/Desktop/Movies/Movies/Fight\ Club\ DVD\ quality.avi
    dylunio
    Registered Linux User #371543!
    Get force-get May The Source Be With You
    /dev/null
    /dev/null2

  3. #13
    Linux Enthusiast crashandburn0420's Avatar
    Join Date
    Jun 2005
    Location
    Naugatuck, CT
    Posts
    590
    it works guess but the mplayer screen freezes and i get this
    Code:
    localhost steven # mplayer -vo x11 /home/steven/Desktop/Movies/Movies/Fight\ Club\ DVD\ quality.avi
    MPlayer 1.0pre7try2-3.3.6 (C) 2000-2005 MPlayer Team
    CPU: Intel Pentium 4/Xeon/Celeron Northwood (Family: 8, Stepping: 4)
    Detected cache-line size is 64 bytes
    MMX supported but disabled
    MMX2 supported but disabled
    SSE supported but disabled
    SSE2 supported but disabled
    CPUflags:  MMX: 0 MMX2: 0 3DNow: 0 3DNow2: 0 SSE: 0 SSE2: 0
    Compiled for x86 CPU with extensions:
    
    
    
    85 audio & 196 video codecs
    Playing /home/steven/Desktop/Movies/Movies/Fight Club DVD quality.avi.
    Cache fill: 18.75% (1572864 bytes)    AVI file format detected.
    VIDEO:  [DIV3]  720x336  24bpp  12.500 fps  410.0 kbps (50.0 kbyte/s)
    ==========================================================================
    Opening audio decoder: [mp3lib] MPEG layer-2, layer-3
    AUDIO: 44100 Hz, 2 ch, s16le, 128.0 kbit/9.07% (ratio: 16000->176400)
    Selected audio codec: [mp3] afm:mp3lib (mp3lib MPEG layer-2, layer-3)
    ==========================================================================
    vo: X11 running at 1024x768 with depth 16 and 16 bpp (":0.0" => local display)
    ==========================================================================
    Opening video decoder: [ffmpeg] FFmpeg's libavcodec codec family
    Selected video codec: [ffdivx] vfm:ffmpeg (FFmpeg DivX ;-) (MS MPEG-4 v3))
    ==========================================================================
    Checking audio filter chain for 44100Hz/2ch/s16le -> 44100Hz/2ch/s16le...
    AF_pre: 44100Hz/2ch/s16le
    [AO OSS] audio_setup: Can't open audio device /dev/dsp: Device or resource busy
    alsa-init: 1 soundcard found, using: default
    ALSA lib pcm_dmix.c:802:(snd_pcm_dmix_open) unable to open slave
    alsa-init: playback open error: Device or resource busy
    [AO ARTS] Connected to sound server.
    [AO ARTS] Stream opened.
    [AO ARTS] buffer size: 20480
    [AO ARTS] buffer size: 2048
    AO: [arts] 44100Hz 2ch s16le (2 bps)
    Building audio filter chain for 44100Hz/2ch/s16le -> 44100Hz/2ch/s16le...
    Starting playback...
    VDec: vo config request - 720 x 336 (preferred csp: Planar YV12)
    VDec: using Planar YV12 as output csp (no 0)
    Movie-Aspect is undefined - no prescaling applied.
    VO: [x11] 720x336 => 720x336 Planar YV12
    No accelerated colorspace conversion found
    SwScaler: using unscaled Planar YV12 -> BGR 16-bit special converter
    No bind found for key MOUSE_BTN2                         ??,?% 0 0 99%
    No bind found for key MOUSE_BTN2                         ??,?% 0 0 99%
    A:   0.0 V:   0.1 A-V: -0.043 ct:  0.000   2/  2 ??% ??% ??,?% 0 0 99%
    . do i have to do this to open every movie?

  4. $spacer_open
    $spacer_close
  5. #14
    Linux Guru dylunio's Avatar
    Join Date
    Aug 2004
    Location
    Cymru
    Posts
    4,157
    Erm, okay, for the choppyness do you have graphics acceleration on via graphics card drivers? if your using vesa you may want to look into these.

    You might also want to enable dma on your hard drive using hdparm
    Code:
    hdparm -d1 /dev/hda
    (replacing /dev/hda with your hard drive (note, don't put the partitions in). And then adding hdparm at boot with
    Code:
    rc-update add hdparm default
    do i have to do this to open every movie?
    Do you know about tab compleation? it's when you press the <tab> key and it will fill in the rest for you e.g. if you type
    Code:
    cd /ho<tab>
    it'l/ change to
    Code:
    cd /home/
    then if you add ste and tab it
    Code:
    cd /home/ste<tab>
    it'll come up as
    Code:
    cd /home/steve/
    and so forth. If it doesn't fill it in it means there are more than one option that it could use, to see a list of these options tap the tab key twice.
    How is this usful for you, well if you do
    Code:
    mplayer -vo x11 /home/steven/Desktop/Movies/Movies/Fight<tab>
    it should compleat it automaticly as
    Code:
    mplayer -vo x11 /home/steven/Desktop/Movies/Movies/Fight\ Club\ DVD\ quality.avi
    -- it will put in the backslashes for you.
    Registered Linux User #371543!
    Get force-get May The Source Be With You
    /dev/null
    /dev/null2

  6. #15
    Linux Enthusiast crashandburn0420's Avatar
    Join Date
    Jun 2005
    Location
    Naugatuck, CT
    Posts
    590
    i got the real mplayer to work by unchecking enable post processing.

Page 2 of 2 FirstFirst 1 2

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •