Find the answer to your Linux question:
Results 1 to 7 of 7
Hello! I've got a very annoying problem with X.org. I've used Gentoo 2005.1 for a couple of months now and it works fine except that the mouse freaks out now ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Sep 2005
    Posts
    2

    Mouse freaks out when typing


    Hello!

    I've got a very annoying problem with X.org. I've used Gentoo 2005.1 for a couple of months now and it works fine except that the mouse freaks out now and then.

    It seems to happen when I both write and use the mouse simultanously.
    For example: ctrl-clicking folders to drag them in konqueror. this works like 4 out of 5 times. but the fifth time i click, the mouse flies all over the desktop like crazy, clicking and dragging everything, exactly as if i where using the wrong protocol for it.

    I've got a Logitech optical usb-mouse and a 105key Logitech keyboard with Finnish/Swedish layout. This problem is present if I use PS/2, IMPS/2 and auto. most of the other options were worse if they worked at all.

    Any idea where the problem could be?
    I think that the problem may be some conlict between the devices...



    part of my xorg.conf:
    Code:
    Section "InputDevice"
    
        Identifier	"Keyboard1"
        Driver	"kbd"
    
    # For most OSs the protocol can be omitted (it defaults to "Standard").
    # When using XQUEUE (only for SVR3 and SVR4, but not Solaris),
    # uncomment the following line.
    
    #    Option     "Protocol"      "Xqueue"
    
        Option "AutoRepeat" "500 30"
    
        Option "XkbRules"	"xorg"
        Option "XkbModel"	"pc105"
        Option "XkbLayout"	"fi"
    
    EndSection
    
    
    Section "InputDevice"
    
    # Identifier and driver
    
        Identifier	"Mouse1"
        Driver	"mouse"
    
    # auto, PS/2 and IMPS/2 works
        Option "Protocol"     "IMPS/2"
    
    # no difference if using "/dev/input/mice"
        Option "Device"       "/dev/input/mouse0"
    
    # and also scroll key does not work even if using:
        Option "ZAxisMapping" "4 5"

  2. #2
    Linux Guru budman7's Avatar
    Join Date
    Oct 2004
    Location
    Knee deep in Grand Rapids, Michigan
    Posts
    3,242
    I have a similar problem, but with Sourcemage.
    When I first login, the mouse acts just like yours.
    What I do to solve it is to pull the PS/2 plug out of the KVM switch for 20-30 seconds, and the mouse is fine.

    I know it is not much help, but it works for me.
    How to know if you are a geek.
    when you respond to "get a life!" with "what's the URL?"
    - Birger

    New users read The FAQ

  3. #3
    Just Joined!
    Join Date
    Sep 2005
    Posts
    2

    thanks for reply

    I tried it but it had no effect...

  4. #4
    Linux Guru budman7's Avatar
    Join Date
    Oct 2004
    Location
    Knee deep in Grand Rapids, Michigan
    Posts
    3,242
    This is a really strange problem that nobody seems to have a solution for.
    I worked with an Admin at Sourcemage forums on my problem and after working for a while no solutions came up.

    Have you tried putting "/dev/psaux" in there?
    How to know if you are a geek.
    when you respond to "get a life!" with "what's the URL?"
    - Birger

    New users read The FAQ

  5. #5
    Linux Guru loft306's Avatar
    Join Date
    Oct 2003
    Location
    The DairyLand
    Posts
    1,666
    try using
    Code:
      Option "Device"  "/dev/input/mice"
    ~Mike ~~~ Forum Rules
    Testing? What's that? If it compiles, it is good, if it boots up, it is perfect. ~ Linus Torvalds
    http://loft306.org

  6. #6
    Linux Guru budman7's Avatar
    Join Date
    Oct 2004
    Location
    Knee deep in Grand Rapids, Michigan
    Posts
    3,242
    I don't seem to have a problem doing that. At least not in Gentoo. I have thesame exact mouse that you do.
    Here is my entry from my xorg.conf file.
    Code:
    # **********************************************************************
    # Core Pointer's InputDevice section
    # **********************************************************************
    
    Section "InputDevice"
    
    # Identifier and driver
    
        Identifier  "Mouse1"
        Driver      "mouse"
        Option "Protocol"    "IMPS/2"
        Option "Device"      "/dev/input/mice"
        Option "ZAxisMapping" "4 5"
    How to know if you are a geek.
    when you respond to "get a life!" with "what's the URL?"
    - Birger

    New users read The FAQ

  7. #7
    Linux Guru loft306's Avatar
    Join Date
    Oct 2003
    Location
    The DairyLand
    Posts
    1,666
    i use "evdev for my usb logitech mouse but u shouldnt have too ....but look into it it allows u to specify the actual usb device and that might help
    ~Mike ~~~ Forum Rules
    Testing? What's that? If it compiles, it is good, if it boots up, it is perfect. ~ Linus Torvalds
    http://loft306.org

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •