Find the answer to your Linux question:
Results 1 to 10 of 10
i know what alot of you are thinking "why dont you just google it and find it" well i tried and my problem is my dvd-rw and cd-rom drives arent ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux Enthusiast crashandburn0420's Avatar
    Join Date
    Jun 2005
    Location
    Naugatuck, CT
    Posts
    590

    cdrom not working


    i know what alot of you are thinking "why dont you just google it and find it" well i tried and my problem is my dvd-rw and cd-rom drives arent working. here is my /etc/fstab
    Code:
      GNU nano 1.3.7                            File: /etc/fstab
    
    
    # <fs>                  <mountpoint>    <type>          <opts>          <dump/pass>
    
    # NOTE&#58; If your BOOT partition is ReiserFS, add the notail option to opts.
    /dev/hda1               /boot           ext2            defaults,noatime        1 2
    /dev/hda2               none            swap            sw              0 0
    /dev/hda3               /               ext3            noatime         0 1
    
    none                    /proc           proc            defaults        0 0
    none                    /dev/shm        tmpfs           nodev,nosuid,noexec     0 0
    
    /dev/cdroms/cdrom0      /mnt/cdrom      auto            noauto,user     0 0
    /dev/cdroms/cdrom1      /mnt/cdrom      auto            noauto,user     0 0
    
    # NOTE&#58; The next line is critical for boot!
    
    # glibc 2.2 and above expects tmpfs to be mounted at /dev/shm for
    # POSIX shared memory &#40;shm_open, shm_unlink&#41;.
    # &#40;tmpfs is a dynamically expandable/shrinkable ramdisk, and will
    #  use almost no memory if not populated with files&#41;

  2. #2
    Linux Guru dylunio's Avatar
    Join Date
    Aug 2004
    Location
    Cymru
    Posts
    4,157
    Are you sure that your cd devices /dev/cdroms/cdrom0 ? I have /dev/hdc and /dev/hdd as my dvd and cd-rw drives.
    Registered Linux User #371543!
    Get force-get May The Source Be With You
    /dev/null
    /dev/null2

  3. #3
    Linux Enthusiast crashandburn0420's Avatar
    Join Date
    Jun 2005
    Location
    Naugatuck, CT
    Posts
    590
    i think mine is that also, ill try it right now

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Engineer
    Join Date
    Apr 2005
    Location
    Belgium
    Posts
    1,429

    cdrom, cdrom0, cdrom1, ... are mere symlinks to hdc, hdd, and so on.

    ls -l /dev will make that quite clear.
    ** Registered Linux User # 393717 and proud of it ** Check out www.zenwalk.org
    ** Zenwalk 2.8 - Xfce 4.4 beta 2- 2.6.17.6 kernel = Slack on steroids! **

  6. #5
    Linux Enthusiast crashandburn0420's Avatar
    Join Date
    Jun 2005
    Location
    Naugatuck, CT
    Posts
    590
    Quote Originally Posted by dylunio
    Are you sure that your cd devices /dev/cdroms/cdrom0 ? I have /dev/hdc and /dev/hdd as my dvd and cd-rw drives.
    thank you that worked, but only for my burner not for the regular cdrom drive

  7. #6
    Linux Guru dylunio's Avatar
    Join Date
    Aug 2004
    Location
    Cymru
    Posts
    4,157
    have you checked that it's not /dev/hda or hdb?

    Also looking at your fstab I notice that you have used the same mountpoint for both...maybe it'd be an idea to create another directory to mount the dvd drive to? e.g. /mnt/dvd ?
    Registered Linux User #371543!
    Get force-get May The Source Be With You
    /dev/null
    /dev/null2

  8. #7
    Linux Enthusiast crashandburn0420's Avatar
    Join Date
    Jun 2005
    Location
    Naugatuck, CT
    Posts
    590
    i created the dvd directory and changed the fstab mount point but my cdrom still doesnt work
    Code:
      GNU nano 1.3.7                            File&#58; /etc/fstab
    
    # /etc/fstab&#58; static file system information.
    # $Header&#58; /var/cvsroot/gentoo-src/rc-scripts/etc/fstab,v 1.18.4.1 2005/01/31 23&#58;05&#58;14 vapier Exp $
    #
    # noatime turns off atimes for increased performance &#40;atimes normally aren't
    # needed; notail increases performance of ReiserFS &#40;at the expense of storage
    # efficiency&#41;.  It's safe to drop the noatime options if you want and to
    # switch between notail / tail freely.
    #
    # See the manpage fstab&#40;5&#41; for more information.
    
    # <fs>                  <mountpoint>    <type>          <opts>          <dump/pass>
    
    # NOTE&#58; If your BOOT partition is ReiserFS, add the notail option to opts.
    /dev/hda1               /boot           ext2            defaults,noatime        1 2
    /dev/hda2               none            swap            sw              0 0
    /dev/hda3               /               ext3            noatime         0 1
    
    none                    /proc           proc            defaults        0 0
    none                    /dev/shm        tmpfs           nodev,nosuid,noexec     0 0
    
    /dev/hdc        /mnt/dvd        auto            noauto,user     0 0
    /dev/hdd        /mnt/cdrom      auto            noauto,user     0 0
    # NOTE&#58; The next line is critical for boot!
    
    # glibc 2.2 and above expects tmpfs to be mounted at /dev/shm for
    # POSIX shared memory &#40;shm_open, shm_unlink&#41;.
    # &#40;tmpfs is a dynamically expandable/shrinkable ramdisk, and will
    #  use almost no memory if not populated with files&#41;

  9. #8
    Linux Guru dylunio's Avatar
    Join Date
    Aug 2004
    Location
    Cymru
    Posts
    4,157
    Have you checked that your dvd drive isn't /dev/hdb or /dev/hda?
    Registered Linux User #371543!
    Get force-get May The Source Be With You
    /dev/null
    /dev/null2

  10. #9
    Linux Enthusiast crashandburn0420's Avatar
    Join Date
    Jun 2005
    Location
    Naugatuck, CT
    Posts
    590
    my hard drive is hda, hdb doesnt work. hdd works but only if i right click and eject it for some reason it cant read it. i guess it just the drive is messed up.

  11. #10
    Linux Engineer
    Join Date
    Apr 2005
    Location
    Belgium
    Posts
    1,429
    You won't be able to mount optical drives with hdd or hdc. Use the symlinks in /dev. cdrom, cdrom0, cdrom1, ...
    ** Registered Linux User # 393717 and proud of it ** Check out www.zenwalk.org
    ** Zenwalk 2.8 - Xfce 4.4 beta 2- 2.6.17.6 kernel = Slack on steroids! **

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •