Find the answer to your Linux question:
Page 1 of 3 1 2 3 LastLast
Results 1 to 10 of 26
how would i get my mouse scroller to work?...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux Enthusiast crashandburn0420's Avatar
    Join Date
    Jun 2005
    Location
    Naugatuck, CT
    Posts
    590

    mouse scroller


    how would i get my mouse scroller to work?

  2. #2
    Linux Guru dylunio's Avatar
    Join Date
    Aug 2004
    Location
    Cymru
    Posts
    4,157
    You'll have to add
    Code:
     Option       "ZAxisMapping" "4 5"
    to the stanza on your mouse in /etc/X11/xorg.conf.
    Registered Linux User #371543!
    Get force-get May The Source Be With You
    /dev/null
    /dev/null2

  3. #3
    Linux Guru Vergil83's Avatar
    Join Date
    Mar 2004
    Posts
    2,407
    Also, always took a look at http://gentoo-wiki.com/
    Brilliant Mediocrity - Making Failure Look Good

  4. #4
    Linux Newbie
    Join Date
    Mar 2005
    Location
    Minneapolis, MN
    Posts
    112
    For some mice, you should use

    Code:
    Option          "ZAxisMapping" "9 10"
    So if the first reply didn't work, try this. Don't forget to restart your X server when you make the changes. This way they will take effect.
    --Dachnaz [Fuzzy Llama]

  5. #5
    Linux Enthusiast crashandburn0420's Avatar
    Join Date
    Jun 2005
    Location
    Naugatuck, CT
    Posts
    590
    Quote Originally Posted by dylunio
    You'll have to add
    Code:
     Option       "ZAxisMapping" "4 5"
    to the stanza on your mouse in /etc/X11/xorg.conf.
    i tried this before and it just made the pages scroll by when ever i passed the mouse on the page.

  6. #6
    Linux Engineer
    Join Date
    Oct 2004
    Location
    Vancouver
    Posts
    1,366
    the zaxismapping option depends on how many buttons your mouse has...check out the wiki...how many buttons does your mouse have? Remember that the scroll wheel counts as 3 buttons...for example I also have to sidekeys on the mouse so my zaxismapping is "6 7"...left click button, right click button, two side buttons, middle click, scroll up, scroll down...7 buttons all together...
    Operating System: GNU Emacs

  7. #7
    Linux Enthusiast crashandburn0420's Avatar
    Join Date
    Jun 2005
    Location
    Naugatuck, CT
    Posts
    590
    i think mine only has 3. here is a website that has it http://www.radioshack.com/product/in...entPage=family

  8. #8
    Linux Engineer psic's Avatar
    Join Date
    Nov 2004
    Location
    Ljubljana, Slovenia
    Posts
    1,205
    Try adding the number of buttons:
    Option "Buttons" "5"
    The "ZAxisMapping 4 5" is fine for your mouse. If adding the above still doesn't help, play with the protocol setting.
    Stumbling around the 'net:
    www.cloudyuseful.com

  9. #9
    Linux Enthusiast crashandburn0420's Avatar
    Join Date
    Jun 2005
    Location
    Naugatuck, CT
    Posts
    590
    i tried ZAxisMapping 1 2, 2 3, 3 4, 4 5, 5 6, 6 7, 7 8, 8 9, 9 10 and none of them work

  10. #10
    Linux Engineer
    Join Date
    Apr 2005
    Location
    Belgium
    Posts
    1,429
    You should first determine how many buttons your mouse has, than map the buttons if necessary, and correct your ZAxisMapping.
    ** Registered Linux User # 393717 and proud of it ** Check out www.zenwalk.org
    ** Zenwalk 2.8 - Xfce 4.4 beta 2- 2.6.17.6 kernel = Slack on steroids! **

Page 1 of 3 1 2 3 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •