Find the answer to your Linux question:
Page 2 of 3 FirstFirst 1 2 3 LastLast
Results 11 to 20 of 22
Originally Posted by Cabhan The only thing I can think of is not following the proper order. Check get-e.org at: http://www.get-e.org/User_Guide/English/_pages/2.2.html It tells you the order you have to emerge ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #11
    Linux Engineer
    Join Date
    Apr 2005
    Location
    Belgium
    Posts
    1,429

    Quote Originally Posted by Cabhan
    The only thing I can think of is not following the proper order. Check get-e.org at:

    http://www.get-e.org/User_Guide/English/_pages/2.2.html

    It tells you the order you have to emerge the stuff.


    I've installed Enlightenment successfully, but I've not used Evidence (I use Rox), so I can't rightly help. Sorry.
    No problem , thanks for the input. Anyway, I used the Gentoo E17 wiki, so the build order's not the problem (although i compared both lists, and mine contains the iconbar entry too, yours doesn't?) But i can compile without evidence, no problem. I'm gonna try again this evening, with evidence (I wanna check all the e17 stuff ).

    @ Lakerdonald: I didn't post it yet, I figured I should try it out myself before I post it - also, I just can't find any login details in the ebuild:

    Code:
    # Copyright 1999-2005 Gentoo Foundation
    # Distributed under the terms of the GNU General Public License v2
    # $Header: /var/cvsroot/gentoo-x86/app-misc/evidence/evidence-9999.ebuild,v 1.8 2005/09/16 00:17:48 vapier Exp $
    
    ECVS_MODULE="evidence"
    ECVS_SERVER="cvs.sourceforge.net:/cvsroot/evidence"
    inherit enlightenment eutils flag-o-matic
    
    DESCRIPTION="GTK2 file-manager"
    HOMEPAGE="http://evidence.sourceforge.net/"
    
    LICENSE="GPL-2"
    IUSE="X debug gnome kde oggvorbis perl truetype xine avi mpeg"
    
    DEPEND=">=dev-util/pkgconfig-0.5
    	=x11-libs/gtk+-2*
    	oggvorbis? ( media-libs/libvorbis
    		media-libs/libogg )
    	perl? ( dev-libs/libpcre )
    	X? ( virtual/x11 )
    	truetype? ( =media-libs/freetype-2* )
    	kde? ( kde-base/kdelibs )
    	xine? ( >=media-libs/xine-lib-1_rc1 )
    	avi? ( >=media-video/avifile-0.7.38 )
    	mpeg? ( media-libs/libmpeg3 )
    	media-libs/libao
    	virtual/libc
    	sys-devel/gcc
    	virtual/fam
    	>=x11-libs/evas-0.9.9
    	>=dev-db/edb-1.0.5
    	>=dev-libs/eet-0.9.9
    	>=x11-libs/ecore-0.9.9
    	>=media-libs/imlib2-1.2.0
    	gnome? ( >=gnome-base/gnome-vfs-2.0
    		>=media-libs/libart_lgpl-2.0
    		>=gnome-base/libgnomecanvas-2.0 )"
    
    src_compile() {
    	# if we turn this on evas gets turned off (bad !)
    	#use gnome && MY_ECONF="${MY_ECONF} --enable-canvas-gnomecanvas"
    
    #		$(use_enable gnome backend-gnomevfs2)
    	export MY_ECONF="
    		--enable-ecore-ipc
    		--enable-canvas-evas2
    		--enable-extra-themes
    		--enable-extra-iconsets
    		$(use_enable xine thumbnailer-xine)
    		$(use_enable avi thumbnailer-avi)
    		$(use_enable mpeg thumbnailer-mpeg3)
    		$(use_enable perl pcre)
    		$(use_enable X x)
    		$(use_enable oggvorbis plugin-vorbis)
    		$(use_enable truetype plugin-ttf)
    		$(use_enable debug)
    		$(use_with kde)
    		"
    	enlightenment_src_compile
    }
    
    src_install() {
    	enlightenment_src_install
    
    	# Fixup broken symlinks
    	dosym efm /usr/share/evidence/icons/default
    	dosym efm /usr/share/evidence/themes/default
    	chown -R root:0 ${D}/usr/share/evidence
    
    	dodoc docs/*
    }
    So I'm a bit lost now. Did you check the ebuild itself? I suppose you diagnosed the error message... Anyway, I'm gonna post this on the Gentoo forums, see what they can do.
    ** Registered Linux User # 393717 and proud of it ** Check out www.zenwalk.org
    ** Zenwalk 2.8 - Xfce 4.4 beta 2- 2.6.17.6 kernel = Slack on steroids! **

  2. #12
    Linux Guru loft306's Avatar
    Join Date
    Oct 2003
    Location
    The DairyLand
    Posts
    1,666
    man i've just been patching the cvs ebuilds for about 2 months already..... i think i did a buggsy on it already but more might help or just piss off the dev
    ~Mike ~~~ Forum Rules
    Testing? What's that? If it compiles, it is good, if it boots up, it is perfect. ~ Linus Torvalds
    http://loft306.org

  3. #13
    Linux Engineer
    Join Date
    Apr 2005
    Location
    Belgium
    Posts
    1,429
    Well I went on the Gentoo forums, apparently I'm not the only one trying to install evidence and having problems. I checked the errors agains other (successful) logins to CVS, there's no problem with the login data. The server is just unreachable.
    Now, I've downloaded Evidence's sources, is there a way I can make portage use them with the ebuild I have?
    ** Registered Linux User # 393717 and proud of it ** Check out www.zenwalk.org
    ** Zenwalk 2.8 - Xfce 4.4 beta 2- 2.6.17.6 kernel = Slack on steroids! **

  4. #14
    Just Joined! Varean's Avatar
    Join Date
    Sep 2005
    Location
    California, USA
    Posts
    69
    It happens to me sometimes, but when I just rerun it a few times, it gets past the error.

  5. #15
    Linux Guru Cabhan's Avatar
    Join Date
    Jan 2005
    Location
    Seattle, WA, USA
    Posts
    3,252
    Quote Originally Posted by borromini
    Well I went on the Gentoo forums, apparently I'm not the only one trying to install evidence and having problems. I checked the errors agains other (successful) logins to CVS, there's no problem with the login data. The server is just unreachable.
    Now, I've downloaded Evidence's sources, is there a way I can make portage use them with the ebuild I have?
    I do believe so.

    Make sure that the .tar.gz file has the exact name as specified by the ebuild, and put the source in /usr/portage/distfiles.

    That should work.

  6. #16
    Linux Guru lakerdonald's Avatar
    Join Date
    Jun 2004
    Location
    St. Petersburg, FL
    Posts
    5,035
    Cabhan: Does the CVS checkout yield a tarball though?

  7. #17
    Linux Engineer
    Join Date
    Apr 2005
    Location
    Belgium
    Posts
    1,429
    I read on the Gentoo forums you should unpack the tarball in the dir portage will look in.
    ** Registered Linux User # 393717 and proud of it ** Check out www.zenwalk.org
    ** Zenwalk 2.8 - Xfce 4.4 beta 2- 2.6.17.6 kernel = Slack on steroids! **

  8. #18
    Linux Guru lakerdonald's Avatar
    Join Date
    Jun 2004
    Location
    St. Petersburg, FL
    Posts
    5,035
    So I guess the cvs command does yield a tarball?
    Either way, you should place the tarball itself in /usr/portage/distfiles (or whatever $DISTDIR is for you ), but don't extract it.

  9. #19
    Linux Engineer
    Join Date
    Apr 2005
    Location
    Belgium
    Posts
    1,429
    Ok, thanks.
    ** Registered Linux User # 393717 and proud of it ** Check out www.zenwalk.org
    ** Zenwalk 2.8 - Xfce 4.4 beta 2- 2.6.17.6 kernel = Slack on steroids! **

  10. #20
    Content Team
    Join Date
    Nov 2005
    Location
    Colorado USA
    Posts
    4
    CVS ebuilds do NOT yield a tarball but an image of the CVS tree stored in /usr/portage/distfiles/cvs-src/<pkg-name>. The commands to log into the CVS server for enlightenment are here: /usr/portage/eclass/enlightenment.eclass and /usr/portage/eclass/cvs.eclass. Vapier made a typo that was mentioned by lakerdonald and it has been corrected. Just re-sync and all will be good.

    And loft306, pissing vapier off is really not a good idea.

Page 2 of 3 FirstFirst 1 2 3 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •