Find the answer to your Linux question:
Page 2 of 2 FirstFirst 1 2
Results 11 to 14 of 14
if it sees eth0 as the ieee interface, then eth1 should be the net interface... try making your net config file read Code: config_eth1=("dhcp") then try starting eth1: Code: ifup ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #11
    Linux Enthusiast
    Join Date
    Dec 2004
    Location
    Rockin' in the USA!!!
    Posts
    603

    if it sees eth0 as the ieee interface, then eth1 should be the net interface... try making your net config file read
    Code:
    config_eth1=("dhcp")
    then try starting eth1:
    Code:
    ifup eth1
    and another tip, remove everything from you're /etc/resolv.conf file; that should be generated by the dhcp script:
    Code:
    echo "" > /etc/resolv.conf

  2. #12
    Just Joined!
    Join Date
    Dec 2006
    Location
    Czech Republic
    Posts
    4

    Re

    Hi, I have same issue and read something about that.
    First of all, this problem apperaed after updating system, specifically after updating udev to version 103. On my box i have one network card integrated on the motherboard (peviously eth0) and firewire. After installing udev-103, the new name of my network card is eth1_rename and firewire have eth0 . So i searched over the internet and found the same problem on gentoo forums, but i'm didn't find any solutions (maybe because i'm not originally english speaker and still don't understand completely). I posted some thread and somebody told me that i must generate new initramfs, because udev is in it, and that he does it with initramfs-update in debian. But how should i do that in gentoo? How the udev did it during the instalation?
    Thanks.

  3. #13
    Just Joined!
    Join Date
    Dec 2006
    Posts
    1
    The reason this happens is because the eth1394 driver is compiled into your kernel. On bootup it loads this module before the driver for your ethernet card (mine was 3c59x) and assigns it to eth0 and your ethernet to eth1. I have read several different methods of disabling this module however none of them have worked. (disablemodules=eth1394 on kernel line in grub, MODULES=!mod in /etc/rc.conf, and several different udev rules). The only thing that worked for me was to disable that module in the .config and rebuild the kernel.

  4. #14
    Just Joined!
    Join Date
    Dec 2006
    Location
    Czech Republic
    Posts
    4
    I have already solved it (sorry for ignorance). Only thing that I did was renaming kernel modul I think that the name was eth1394.ko to for example ~eth1394.ko. Because I have compiled kernel with genkernel most of my kernel features are compiled like moduls.

Page 2 of 2 FirstFirst 1 2

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •