Find the answer to your Linux question:
Results 1 to 4 of 4
I attempted to run this fix: Code: INSTALLATION: 1. gcc -o tp-scroll tp-scroll.c -lm 2. mkfifo /dev/imouse 3. In XF86Config, replace the InputDevice section: Section "InputDevice" Identifier "Mouse0" Driver "mouse" ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Mar 2005
    Posts
    19

    xorg.conf input device error, please help!


    I attempted to run this fix:
    Code:
      INSTALLATION:
    
       1. gcc -o tp-scroll tp-scroll.c -lm
       2. mkfifo /dev/imouse
       3. In XF86Config, replace the InputDevice section:
    
          Section "InputDevice"
                  Identifier  "Mouse0"
                  Driver      "mouse"
                  Option      "Device" "/dev/imouse"
                  Option      "Protocol" "ExplorerPS/2"
                  Option      "Emulate3Buttons" "off"
                  Option      "ZAxisMapping" "4 5"
          EndSection
    
       4. disable gpm (sorry, doesn't play nice with gpm yet)
       5. add "[path]/tp-scroll /dev/mouse /dev/imouse" to rc.local.
    
    (Worked directly as above. Added script to /etc/init.d/local.start)
    but when i restarted, i get an xorg error telling me "mouse" is not a valid keyword. What happened, and how do i fix?

    Thanks!

  2. #2
    Linux Enthusiast deltaflyer's Avatar
    Join Date
    May 2005
    Posts
    577
    try changing these around

    Code:
    Identifier "Mouse0"
    Driver      "mouse" 
    to
    Identifier  "mouse"
     Driver      "Mouse0"
    might work

    andy
    SLOMO: acer extensa 5235 2.2ghz,2gb ram 160gb hdd wireless
    SPEEDY: homebrew desktop,Amd x2 dualcore,2gb ram,500gb +1tb( 2x500gb) hdd suse 11.3,32mb fibreline
    registered linux user #401845

  3. #3
    Linux Engineer
    Join Date
    Oct 2004
    Location
    Vancouver
    Posts
    1,366
    Also, I'm not familiar with /dev/imouse, isn't gentoo usually /dev/input/mice?
    Operating System: GNU Emacs

  4. #4
    Linux Guru loft306's Avatar
    Join Date
    Oct 2003
    Location
    The DairyLand
    Posts
    1,666
    Quote Originally Posted by deltaflyer
    try changing these around

    Code:
    Identifier "Mouse0"
    Driver      "mouse" 
    to
    Identifier  "mouse"
     Driver      "Mouse0"
    might work

    andy
    ummm no

    try changing the protocol to auto[ and the device te code]Option "Protocol" "Auto"
    Option "Device" "/dev/input/mice"
    [/code]
    also check the /var/log/Xorg.0.log
    for the exact orror....
    and if u r using xorg then the config file's name is /etc/X11/xorg.conf and is created with ' xorgconfig '
    not XF86config
    ~Mike ~~~ Forum Rules
    Testing? What's that? If it compiles, it is good, if it boots up, it is perfect. ~ Linus Torvalds
    http://loft306.org

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •