Find the answer to your Linux question:
Results 1 to 8 of 8
I'm posting here in gentoo because I emerged all these programs and just did a fresh gentoo install. Mplayerplug-in works with everything but wmv embedded video. And even here it ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux Engineer spencerf's Avatar
    Join Date
    Jan 2005
    Location
    Syracuse, NY
    Posts
    1,144

    mplayerplug-in + firefox no video with wmv (SOLVED)


    I'm posting here in gentoo because I emerged all these programs and just did a fresh gentoo install. Mplayerplug-in works with everything but wmv embedded video. And even here it will play sound but no video only the grey mplayerplug-in screen. Here are my version of appropriate software

    mplayer=MPlayer 1.0pre7try2-3.3.5-20050130

    mplayerplug-in=2.80

    firefox=1.5

    Some more information. I have the appropriate .so .xpt in their respective places. Also when i do: aboutlugins in firefox it shows that everything is working including wmv.

    Anyone has any ideas or please let me know this is extremely frustrating I spend like 5 hourse last night trying to make sure I wasn't doing something stupid and googlind the h e double hockey sticks out of it.

    Thanks again.
    All right, brain. You don't like me and I don't like you, but let's just do this and I can get back to killing you with beer. All New Users Read This!!! If you have a grub problem please look at GRUB MANUAL

  2. #2
    Linux Engineer Nerderello's Avatar
    Join Date
    Apr 2003
    Location
    North East England
    Posts
    1,190
    not sure that this has anything to do with your problem, but I found that I couldn't get mplayer to show wmv files. I had to copy the win32 codecs into /usr/lib/win32 (here's a list of that folder :-
    Code:
    [root@localhost win32]# ls
    acelpdec.ax   huffyuv.dll   m3jpeg32.dll  nsrt2432.acm  vp4vfw.dll
    alf2cd.acm    i263_32.drv   m3jpegdec.ax  pclepim1.dll  vssh264core.dll
    asusasv2.dll  iccvid.dll    mcdvd_32.dll  qdv.dll       vssh264dec.dll
    asusasvd.dll  icmw_32.dll   mcmjpg32.dll  qpeg32.dll    vssh264.dll
    ativcr2.dll   imaadp32.acm  mpg4c32.dll   rt32dcmp.dll  vsslight.dll
    atrac3.acm    imc32.acm     mpg4ds32.ax   sp5x_32.dll   vsswlt.dll
    avimszh.dll   ir32_32.dll   msadp32.acm   tm20dec.ax    wma9dmod.dll
    avizlib.dll   ir41_32.dll   msg711.acm    tsccvid.dll   wmadmod.dll
    CLRVIDDC.DLL  ir50_32.dll   msgsm32.acm   tssoft32.acm  wmspdmod.dll
    clrviddd.dll  ivvideo.dll   msh261.drv    ubv263d+.ax   wmv8ds32.ax
    CtWbJpg.DLL   jp2avi.dll    msms001.vwp   ubvmp4d.dll   wmv9dmod.dll
    divxa32.acm   l3codeca.acm  msnaudio.acm  ultimo.dll    wmvdmod.dll
    divx_c32.ax   l3codecx.ax   msrle32.dll   vgpix32d.dll  wmvds32.ax
    divxc32.dll   LCodcCMP.dll  msscds32.ax   vivog723.acm
    divxdec.ax    lhacm.acm     msvidc32.dll  voxmsdec.ax
    divx.dll      m3jp2k32.dll  mvoiced.vwp   vp31vfw.dll
    Like I said, may have nothing to do with your problems, but I thought I'd chip in.

    have fun

    Nerderello

    Use Suse 10.1 and occasionally play with Kubuntu
    Also have Windows 98SE and BeOS

  3. #3
    Linux Engineer spencerf's Avatar
    Join Date
    Jan 2005
    Location
    Syracuse, NY
    Posts
    1,144
    thanx but I have all of those and more in there. Like I said before I'm really at wits end here because I've tried everything and double checked everything. Well obviously not everything because it won't work.

    here's an update though I can play this file through mplayerplug-in but nothing on cnn.com or mlb.com. I really want mlb.com stuff to work because during the baseball season I want to livecast stream games.

    http://www.philmultic.com/liufang/video/bawang03.wmv
    All right, brain. You don't like me and I don't like you, but let's just do this and I can get back to killing you with beer. All New Users Read This!!! If you have a grub problem please look at GRUB MANUAL

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Engineer spencerf's Avatar
    Join Date
    Jan 2005
    Location
    Syracuse, NY
    Posts
    1,144
    here's another update I think I found the problem mplayer itself won't play wmv9 files with video here's the output from mplayer when trying to play such a file.

    Code:
    Requested video codec family [wmv9dmo] (vfm=dmo) not available.
    Enable it at compilation.
    Requested video codec family [wmvdmo] (vfm=dmo) not available.
    Enable it at compilation.
    Cannot find codec matching selected -vo and video format 0x33564D57.
    Read DOCS/HTML/en/codecs.html!
    guess I'll look into this then report back any suggestions as always welcome.
    All right, brain. You don't like me and I don't like you, but let's just do this and I can get back to killing you with beer. All New Users Read This!!! If you have a grub problem please look at GRUB MANUAL

  6. #5
    Linux Engineer spencerf's Avatar
    Join Date
    Jan 2005
    Location
    Syracuse, NY
    Posts
    1,144
    ok think I found the problem I didn't have win32codecs set as a use flag for mplayer. Even though I emerged them seperately later I don't think mplayer compiled with them as an option and I am now compiling mplayer with this USE flag enabled and hopefully this will solve my problem I will report back in a couple of minutes hopefully with a good update.
    All right, brain. You don't like me and I don't like you, but let's just do this and I can get back to killing you with beer. All New Users Read This!!! If you have a grub problem please look at GRUB MANUAL

  7. #6
    Linux Engineer spencerf's Avatar
    Join Date
    Jan 2005
    Location
    Syracuse, NY
    Posts
    1,144
    that did it. So if you are using gentoo and want mplayerplug-in to play videos based on wmv9 you need to emerge with the USE flag win32codecs when you compile mplayer itself it is not (at least in my case) sufficient to just put these codecs into /usr/lib/win32/

    thanks for the help nerderello I knew I had the codecs but you got me thinking about why they weren't working. Hope this post helps anyone having a similar problem.
    All right, brain. You don't like me and I don't like you, but let's just do this and I can get back to killing you with beer. All New Users Read This!!! If you have a grub problem please look at GRUB MANUAL

  8. #7
    Just Joined!
    Join Date
    Jul 2006
    Posts
    11

    Help with mplayerplug-in

    Hi , I'm a newbie so...
    I have mandriva 2006 power..
    I removed the ff 1.06 and downloaded ff 1.5 . I didn't find the way to "install" it so I execute it by shell script. Now when I try to install(./configure) the plug-in, I get the following:
    "......
    checking for pkg-config... /usr/bin/pkg-config
    checking for mozilla-plugin... configure: WARNING: mozilla-plugin not found
    checking for firefox-plugin... configure: WARNING: firefox-plugin not found
    checking for seamonkey-plugin... configure: WARNING: seamonkey-plugin not found
    checking for xulrunner-plugin... configure: WARNING: xulrunner-plugin not found
    configure: error: Unable to find mozilla or firefox development files
    "
    What should I do?

  9. #8
    Just Joined!
    Join Date
    Jul 2006
    Posts
    11
    Solved it by installing rpm !

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •