Find the answer to your Linux question:
Page 3 of 3 FirstFirst 1 2 3
Results 21 to 23 of 23
Hi gruven, The first thing I would do is recompile the program that is giving me problems. I think most likely the hanging was caused by the mouse. Can I ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #21
    Linux Guru
    Join Date
    Sep 2004
    Posts
    1,814

    Hi gruven,

    The first thing I would do is recompile the program that is giving me problems.
    I think most likely the hanging was caused by the mouse. Can I try another protocol? If YES please advise how to make the change.

    $ cat /etc/X11/xorg.conf
    Code:
    .....
    Section "InputDevice"
    
    # Identifier and driver
    
        Option "Protocol"    "PS/2" # PS/2 Mouse
        Option "Device"      "/dev/input/mice"
    
    # When using XQUEUE, comment out the above two lines, and uncomment
    # the following line.
    
    #    Option "Protocol"  "Xqueue"
    
    # Mouse-speed setting for PS/2 mouse.
    
    #    Option "Resolution"        "256"
    
    # Baudrate and SampleRate are only for some Logitech mice. In
    # almost every case these lines should be omitted.
    
    #    Option "BaudRate"  "9600"
    #    Option "SampleRate"        "150"
    
    # Mouse wheel mapping.  Default is to map vertical wheel to buttons 4 & 5,
    # horizontal wheel to buttons 6 & 7.   Change if your mouse has more than
    # 3 buttons and you need to map the wheel to different button ids to avoid
    # conflicts.
    
        Option "ZAxisMapping"   "4 5 6 7"
    
    # Emulate3Buttons is an option for 2-button mice
    # Emulate3Timeout is the timeout in milliseconds (default is 50ms)
    
        Option "Emulate3Buttons"
    #    Option "Emulate3Timeout"    "50"
    
    # ChordMiddle is an option for some 3-button Logitech mice
    
    #    Option "ChordMiddle"
    
    EndSection
    .....
    TIA

    Another question, is that have you updated your compiler to 4.1.1 yet? I know it went stable not too long ago, and not sure if you are using it or not.
    Which compiler? What command shall I run?

    Others noted with tks.

    B.R.
    satimis

  2. #22
    Linux Enthusiast gruven's Avatar
    Join Date
    Dec 2004
    Location
    Arkansas
    Posts
    541
    Change this line
    Code:
        Option "Protocol"    "PS/2" # PS/2 Mouse
    to this:
    Code:
        Option "Protocol"    "IMPS/2" # PS/2 Mouse
    There are others you can try, but that is pretty much the most common one.

    Don't worry about the compiler, it was just a question that I was curious about.

    You may also may try recompiling "xf86-input-mouse".

    Try changing your XAxisMapping to "4 5" instead of "4 5 6 7".

    Those are just suggestions, though. I am not really sure what it causing the lockups.

    Although, after it locks up, you can check /var/log/Xorg.0.log and at the end of it it will tell you what crashed X.

    Linux User #376741
    Code is Poetry

  3. #23
    Linux Guru
    Join Date
    Sep 2004
    Posts
    1,814
    Hi gruven,

    Tried your suggestions without result.

    I think we were looking at the wrong direction. I recall previously I had the same problem on Ubuntu 6.0.6. Then on /boot/grub/grub.conf I added "noapic" at the of the line
    Code:
    kernel  (hd0,0)/boot/linux-2.6.17-gentoo-r7 root=/dev/hda2 noapic
    Screen hanging problem disappeared thereafter. I'm now testing it.

    B.R.
    satimis

  4. $spacer_open
    $spacer_close
Page 3 of 3 FirstFirst 1 2 3

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •