Find the answer to your Linux question:
Page 1 of 3 1 2 3 LastLast
Results 1 to 10 of 23
When i startx it i get a error unknow 999 /root/.xinitrc;line 1:exec: gnome-sessions; not found,The file .xinitrc does exsist when i nano and contain gnome- session and also XSESSIONS is ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux User mactabilis's Avatar
    Join Date
    Apr 2005
    Location
    moon
    Posts
    379

    error gnome


    When i startx it i get a error unknow 999 /root/.xinitrc;line 1:exec:
    gnome-sessions; not found,The file .xinitrc does exsist when i nano and contain gnome- session and also XSESSIONS is set at gnome in the /etc/make conf.

  2. #2
    Linux Enthusiast gruven's Avatar
    Join Date
    Dec 2004
    Location
    Arkansas
    Posts
    541
    In gentoo it is better for gnome or KDE to use "/etc/init.d/xdm start|stop|restart" to start them than xinitrc.

    Just edit your /etc/rc.conf and set your display manager to "gdm" and your Session to "Gnome". Then you would run "/etc/init.d/xdm start" and it should take you into gdm if you have your Xserver setup correctly. The Xsessions variable is not in /etc/make.conf. It is in /etc/rc.conf.

    If that works, then just open a terminal, su to root, and run "rc-update add xdm default" if you want gdm to come up every time.

    Also, you don't need to be root to type startx. That really isn't recommended at all. Just use a terminal to su to root to do what you need done, then log root out.

    Linux User #376741
    Code is Poetry

  3. #3
    Linux Guru
    Join Date
    Sep 2004
    Posts
    1,778
    Hi gruven,

    On Googling I found this thread. I have the same problem "gnome' failing to start.

    # startx
    Code:
    ....
    /root/.xinitrc: line 1: exec: gnome-session: not found
    On booting the login page did not display.

    # /etc/init.d/xdm start
    Code:
    Warning: xdm has already been started
    # rc-update add xdm default
    Code:
    xdm already installed in runlevel 'default'; skipping
    # cat /etc/rc.conf
    Code:
    ....
    ....
    DISPLAYMANAGER="xdm"
    XSESSION="Gnome"
    On /etc/make.conf
    USE="gtk gtk2 gnome hal avahi"

    # emerge --search avahi
    Code:
    net-dns/avahi not installed
    # emerge --search hal
    Code:
    ...
    app-doc/halibut [Masked]
    .... not installed
    dev-perl (CPAN-Muis-Phalanx [Masked]
    .... not installed
    games-misc/fortune-mod-simpsons-chalkboard
    .... not installed
    games-server/halflife-steam [Masked]
    .... not installed
    sys-apps/hal
    .... not installed
    Do I need all of them to start gnome?

    # emerge gnome-volume-manager
    Code:
    ...
    ....
    * Please re-emerge X11-libs/cairo with the X USE flag set
    ERROR: x11-libs/gtk+-2.8.19 failed
    Call stack
    ebuild.sh, line 1555: Called dyn-setup
    gtk+-2.8.19 ebuild, line 57 called pkg-setp die
    Cairo needs the X flag set
    Please advise how to fix the problem. TIA

    B.R.
    satimis

  4. #4
    Linux Enthusiast gruven's Avatar
    Join Date
    Dec 2004
    Location
    Arkansas
    Posts
    541
    Edit your /etc/rc.conf and set the display manager to "gdm" instead of "xdm".

    Next, make sure these use flags are in your make.conf:
    "gnome gtk esd avahi hal dbus cairo X"

    When you make sure you have all of those use flags, then issue this:
    Code:
    emerge --sync && emerge -avuDN world
    That will update your system, and also recompile any packages that have had their "use" flags changed. Then, you should be able to emerge gnome.

    Linux User #376741
    Code is Poetry

  5. #5
    Linux Guru
    Join Date
    Sep 2004
    Posts
    1,778
    Hi gruven,

    Tks for your advice.

    Edit your /etc/rc.conf and set the display manager to "gdm" instead of "xdm".
    Edited as advised.

    Next, make sure these use flags are in your make.conf:
    "gnome gtk esd avahi hal dbus cairo X"
    Edited /etc/make.conf as advised.

    USE="gnome gtk esd avahi hal dbus cairo X"

    When you make sure you have all of those use flags, then issue this:
    Code:
    emerge --sync && emerge -avuDN world
    Ran the command line. No serious warning found except some conf files need to be updated.

    # find /etc -iname '.cfg????._*'
    Code:
    /etc/conf.d/._cfg0000_rc
    /etc/conf.d/._cfg0000-clock
    /etc/ssl/misc/._cfg0000_CA.pl
    /etc/ssl/misc/._cfg0000_CA.cif
    /ect/init.d/._cfg0000_clock
    /ect/init.d/._cfg0000_shutdown.sh
    /ect/init.d/._cfg0000_bootmisc
    /ect/init.d/._cfg0000_halt.sh
    /ect/init.d/._cfg0000_localmount
    /ect/init.d/._cfg0000_net.lo
    /etc/ppp/._cfg0000_pppoe_conf
    /etc/._cfg0000_man.conf
    /etc/._cfg0000_inputrc
    /etc/._cfg0000_rc.conf
    /etc/._cfg0000_evoms.conf
    Please advise;
    1) how to manually update them

    OR

    2) if after putting following line on /etc/make.conf
    Code:
    CONFIG_PROTECT="_*"
    what command line shall I run afterwards to update the conf files

    TIA


    After finish;
    # startx
    Code:
    ....
    ....
    Using Config file "etc/X11/xorg.conf
    /root/.xinitrc : line 1 : exec : gnome-session : not found
    .....
    # ls -l /usr/bin | grep gnome-session
    # find / -name gnome-session
    Both without printout.


    Reboot PC, following warnings found;
    Code:
    ....
    Setting up xdm
    /sbin/start-stop-daemon : stat /urs/bin/xdm : No such file or directory
    ERROR : Could not start the Desplay Manager
    ....
    .....
    ERROR : cannot start netmount as net.eth0 could not start
    ....
    # ls -l /usr/bin | grep xdm
    no printout

    Please advise how to find them. Tks

    (remark : I haven't "emerge gnome-volume-manger" yet)

    B.R.
    satimis












    That will update your system, and also recompile any packages that have had their "use" flags changed. Then, you should be able to emerge gnome.[/QUOTE]

  6. #6
    Linux Enthusiast gruven's Avatar
    Join Date
    Dec 2004
    Location
    Arkansas
    Posts
    541
    You should have already issued this command:
    Code:
    emerge gnome
    That gets you gnome.

    To update your config files, you would do a:
    Code:
    etc-update
    and manually update your config files one by one. If you don't do this, then you could possibly end up with an unusable system.

    Next, you want to issue a:
    Code:
    /etc/init.d/xdm stop && /etc/init.d/xdm start
    That command will read the /etc/rc.conf file and load the login manager you chose (which would be gdm). That is the easiest way to start a desktop in linux.

    I know I have forgot this, but make sure you setup X before you try to load anything. It will need to know which drivers to use for what.
    Code:
    xorgconfig
    I can't stress enough how important etc-update is though. That is your config files, which means it decides how your system works. Please update them every time portage tells you to do it. If you don't understand it, do a search on the gentoo forums and there will be more than enough information for you to figure it out.

    Linux User #376741
    Code is Poetry

  7. #7
    Linux Guru
    Join Date
    Sep 2004
    Posts
    1,778
    Hi gruven,

    You should have already issued this command:
    Code:
    emerge gnome
    I emerge gnome-light before.

    # locate gnome-light
    found it

    Do I need to do "emerge gnome"?

    OR the execute of "gnome-light" differs from "gnome" ?


    To update your config files, you would do a:
    Code:
    etc-update
    and manually update your config files one by one. If you don't do this, then you could possibly end up with an unusable system.
    # etc-update
    displayed a list of cofig files to be updated with corresponding numbers. I took following steps;

    - Entered the corresponding number [ENTER]
    It displayed the content of the conf file (the old one, I suppose).

    - pressed "q" to exit the file
    Code:
    1) replace original with update
    2) Delete update, keeping original as it is
    3) ...
    ......
    - typed 1 [ENTER]
    Code:
    (as example)
    Replacing /etc/init.d/bootmisc with /et/init.d_cfg000_bootmisc
    mv : overwrite `/etc/init.d/bootmisc'?
    - Pressed [ENTER]
    Then displaying a new list with the above file deleted

    - Then I manually updated all conf files

    Next, you want to issue a:
    Code:
    /etc/init.d/xdm stop && /etc/init.d/xdm start
    # /etc/init.d/xdm stop && /etc/init.d/xdm
    Code:
    ERROR : could not start the Display Manager...
    xdm : no process killed
    # startx
    still unable to start gnome with the usual warning " ..... gnome-session : file not found"

    # find / -name gnome-session
    Code:
    /usr/portage/gnome-base/gnome-session
    find : /proc/6784/task/6784/fd/5 : No such file or directory
    find : /proc/6784/fd/5 : No such file or directory
    make sure you setup X before you try to load anything. It will need to know which drivers to use for what.
    Code:
    xorgconfig
    I have a working xorg.conf. TWM can be started with "startx" command before installing "gnome-light"

    Rebooted PC but still failed to start Display Manager.

    Others noted with tks.


    B.R.
    satimis

  8. #8
    Linux Enthusiast gruven's Avatar
    Join Date
    Dec 2004
    Location
    Arkansas
    Posts
    541
    Since you have gnome-light, it may or may not come with gdm, it's display manager. You don't need to worry about the "startx" command when dealing with gnome or kde, the /etc/init.d/xdm startup script will be sufficient.

    Try emerging gdm
    Code:
    emerge gdm
    and then issue the
    Code:
    /etc/init.d/xdm stop && /etc/init.d/xdm start
    The error you are getting seems to point to gdm not being installed. Try that and then report back, and we will see if we can't get you a working desktop.

    Linux User #376741
    Code is Poetry

  9. #9
    Linux Guru
    Join Date
    Sep 2004
    Posts
    1,778
    Hi gruven,

    [quote]Try emerging gdm
    Code:
    emerge gdm
    # emerge gdm
    Code:
    ERROR: x11-libs/gtk+-2.8.19 failed
    Call stack :
    ebuild.sh, line 1555: Called dyn-setup
    ebuild.sh, line 668 : Called pkg_setup
    gtk+-2.8.19 ebuild, line 57 called : die
    !!! Cairo needs the X flag set
    Similar error as on my previous posting (#3) above, when I installed gnome-volume-manager.


    B.R.
    satimis

  10. #10
    Linux Enthusiast gruven's Avatar
    Join Date
    Dec 2004
    Location
    Arkansas
    Posts
    541
    Ok, if you set the use flags as I advised above, then you would issue an
    Code:
    emerge -avuDN world
    And that will update your world and check for new use flags and recompile with the new use flags.

    If you just want to recompile cairo with new use flags, just
    Code:
    emerge -avN --oneshot cairo
    Also, I noticed it is trying to compile gtk, but that would have been installed when you emerged gnome-light (I imagine, because gnome is built on gtk).

    If I were you, I would just emerge the full gnome package. You don't have to, but it isn't a bad thing to have if you want gnome.

    If you could, please post your "emerge info" for us to see, or just post your make.conf. I will be able to help a lot more after seeing that.

    Linux User #376741
    Code is Poetry

Page 1 of 3 1 2 3 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •