Find the answer to your Linux question:
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 12
hi there, new to Gentoo but an old hat at other distros- normally I'm used to a graphical installer, and shame on me for becoming reliant on them- the thing ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Dec 2005
    Posts
    7

    Question minor issue w lilo and kernel panic {solved}


    hi there, new to Gentoo but an old hat at other distros-

    normally I'm used to a graphical installer, and shame on me for becoming reliant on them-

    the thing is I've gone through the install, and now I'm post reboot, and what do I get but a kernel panic
    seems it's looking for an init file and suggests that I pass the argument init= to the kernel to fix the issue
    /dev/hda1 is / and /boot with reiserfs
    I'm running lilo instead of grub (personal choice- I like lilo better and I can optimise it to use a bootsplash just as well as grub can do)
    I followed the install handbook to the letter, but it seems there is an issue here not covered, ideas anyone?

    Last edited by lughlamfain; 01-01-2006 at 11:17 PM. Reason: solved issue

  2. #2
    Linux Engineer Nerderello's Avatar
    Join Date
    Apr 2003
    Location
    North East England
    Posts
    1,190
    sounds like you need an initrd loading. Not sure how this is done in lilo (use grub myself), but I've seen this happen when I've forgotten to tell it (grub) about the initrd file that it needs to load.

    have fun

    Nerderello

    Use Suse 10.1 and occasionally play with Kubuntu
    Also have Windows 98SE and BeOS

  3. #3
    Linux Enthusiast gruven's Avatar
    Join Date
    Dec 2004
    Location
    Arkansas
    Posts
    541
    http://www.gentoo.org/doc/en/handboo...p=10#doc_chap3

    There it is. It is in the handbook for the boot loader setup. It explains how to do it if you used genkernel or if you didn't use genkernel. As far as I know you only NEED an initrd if you use genkernel unless you are using gensplash and then you create your own later and add the initrd when you get that made.

    I personally have never used genkernel, I always build my own, so YMMV.

    Linux User #376741
    Code is Poetry

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined! blackhawk3008's Avatar
    Join Date
    Nov 2005
    Location
    France
    Posts
    17
    Quote Originally Posted by lughlamfain
    hi there, new to Gentoo but an old hat at other distros-

    normally I'm used to a graphical installer, and shame on me for becoming reliant on them-

    the thing is I've gone through the install, and now I'm post reboot, and what do I get but a kernel panic
    seems it's looking for an init file and suggests that I pass the argument init= to the kernel to fix the issue
    /dev/hda1 is / and /boot with reiserfs
    I'm running lilo instead of grub (personal choice- I like lilo better and I can optimise it to use a bootsplash just as well as grub can do)
    I followed the install handbook to the letter, but it seems there is an issue here not covered, ideas anyone?

    Hello !!
    You have to pass root=/dev/ROOT to the kernel argument line in the config file of your bootloader, where ROOT is your root partition of course...
    After that, all went to works fine !

  6. #5
    Just Joined!
    Join Date
    Dec 2005
    Posts
    7

    Cool config...

    Quote Originally Posted by blackhawk3008
    Hello !!
    You have to pass root=/dev/ROOT to the kernel argument line in the config file of your bootloader, where ROOT is your root partition of course...
    After that, all went to works fine !

    that was already going on- /dev/hda1 was being passed as the arg (both / and /boot are on hda1)-- the arg that it wants is an init level arg, and that seems (so far) to be the issue...

  7. #6
    Just Joined!
    Join Date
    Dec 2005
    Posts
    7

    Cool

    Quote Originally Posted by gruven
    http://www.gentoo.org/doc/en/handboo...p=10#doc_chap3

    There it is. It is in the handbook for the boot loader setup. It explains how to do it if you used genkernel or if you didn't use genkernel. As far as I know you only NEED an initrd if you use genkernel unless you are using gensplash and then you create your own later and add the initrd when you get that made.

    I personally have never used genkernel, I always build my own, so YMMV.

    this was a build your own as well- no genkernels for me, though I may have to try one and use the lilo initrd= to see if that helps any-- though it may just be having issues with which init level to be running @-- been thinking that maybe the line init=default might work as well, will let others know

  8. #7
    Just Joined! blackhawk3008's Avatar
    Join Date
    Nov 2005
    Location
    France
    Posts
    17

    Thumbs up

    Quote Originally Posted by lughlamfain
    that was already going on- /dev/hda1 was being passed as the arg (both / and /boot are on hda1)-- the arg that it wants is an init level arg, and that seems (so far) to be the issue...
    Hello !
    Could you post output of :
    Code:
    # df -h
    and the section in lilo.conf that match the boot command line to launch the kernel. This could help us to solve your problem

  9. #8
    Just Joined!
    Join Date
    Dec 2005
    Posts
    7

    Cool messages and lilo

    Quote Originally Posted by blackhawk3008
    Hello !
    Could you post output of :
    Code:
    # df -h
    and the section in lilo.conf that match the boot command line to launch the kernel. This could help us to solve your problem

    sorry if I can't give you the # df -h output, but I can give you this:

    lilo.conf

    boot=/dev/hda
    prompt
    timeout=120
    default=gentoo

    image=/boot/kernel-2.6.11-gentoo-r3
    label=gentoo
    read-only
    root=/dev/hda1
    append="video=vesafb:mtrr,ywrap,1024x768-32@85"

    the error I had (recompiling kernel to see if that will help--) was:

    ...
    Freeing unused kernel memory: (XXval) freed
    Warning:unable to open an initial console
    Kernel panic- not syncing: no init found. Try passing init= option to kernel
    <5> Vendor:VBTM


  10. #9
    Just Joined! blackhawk3008's Avatar
    Join Date
    Nov 2005
    Location
    France
    Posts
    17
    Could you post your fstab ???
    It may be useful for us.
    Indeed, the error you have is that the kernel cannot found init script and so cannot continue booting.
    Could you say if your kernel is on a separated partition (ie the boot partition) and root of your system is on other one ?
    The fstab file (usually placed in /etc) may help us to know where is your root partition... and also solve your problem

  11. #10
    Just Joined!
    Join Date
    Dec 2005
    Posts
    7

    Cool fstab results...

    Quote Originally Posted by blackhawk3008
    Could you post your fstab ???
    It may be useful for us.
    Indeed, the error you have is that the kernel cannot found init script and so cannot continue booting.
    Could you say if your kernel is on a separated partition (ie the boot partition) and root of your system is on other one ?
    The fstab file (usually placed in /etc) may help us to know where is your root partition... and also solve your problem
    contents of fstab are:

    /dev/hda1 / reiserfs defaults,noatime,notail 1 1
    /dev/hda5 none swap sw 0 0
    /dev/cdroms/cdrom0 /mnt/cdrom auto noauto,ro,user 0 0
    /dev/fd0 /mnt/floppy auto noauto,rw,user 0 0
    /dev/hda7 /home ext3 defaults 0 2
    /dev/sda1 /mnt/sda1 auto noauto,user 0 0
    /dev/hda6 /usr reiserfs defaults,noatime 0 2

    none /proc proc defaults 0 0

    none /dev/shm tmpfs defaults 0 0
    none /proc/bus/usb usbfs defaults 0 0

    hope that can help some- both /root and /boot are both on /
    only /usr and /home are on seperate partitions

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •