Find the answer to your Linux question:
Results 1 to 7 of 7
Hello, II know that kde 3.5 has appear to be in testing, and I want to install it, but to install it easily, I do Code: # ACCEPT_KEYWORDS="~x86" emerge kde-3.5 ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined! blackhawk3008's Avatar
    Join Date
    Nov 2005
    Location
    France
    Posts
    17

    Red face HOWTO Install KDE 3.5


    Hello,
    II know that kde 3.5 has appear to be in testing, and I want to install it, but to install it easily, I do
    Code:
    # ACCEPT_KEYWORDS="~x86" emerge kde-3.5
    but when I've updated my portage tree with
    Code:
    # emerge --sync
    [...]
    #emerge --update --newuse --deep world
    There are a lots of errors that report that some packages are masked by "~x86" keywords... OK ! I take it in account and do
    Code:
    # ACCEPT_KEYWORDS="~x86" emerge --update --newuse --deeep world
    but, as everyone know, this command install every package which are under test on x86 architecture. But I want only to install kde3.5 and keep all other packages as they are now ! And I find the method which consists in unmasking all of kde 3.5 package and their dependancies very very long !

    Did anyone knows how to do this ? Thanks a lot for any help....

  2. #2
    Linux Guru Cabhan's Avatar
    Join Date
    Jan 2005
    Location
    Seattle, WA, USA
    Posts
    3,252
    Unfortunately, you do need to go and declare each package individually in the /etc/portage/package.keywords file. You might do the ACCEPT_KEYWORDS method with a --pretend flag, copy all those packages, then use some sort of script to add '~x86' after each line.

  3. #3
    Linux Enthusiast gruven's Avatar
    Join Date
    Dec 2004
    Location
    Arkansas
    Posts
    541
    You can do a search on the gentoo forums, and they have a command to copy all of the files from the mask to /etc/portage/package.keywords file.

    On another note, is there any reason (since you want to use ~arch software) that you don't just use ~arch for your whole system?

    And yes, I run my desktop and laptop with "ACCEPT_KEYWORDS="~x86" in my make.conf. I feel comfortable enough to fix some problems that come up, and I like to help out with the bug reports.

    Linux User #376741
    Code is Poetry

  4. #4
    Linux Guru loft306's Avatar
    Join Date
    Oct 2003
    Location
    The DairyLand
    Posts
    1,666
    And another thing to add to this is that if you emerge with
    Code:
    ACCEPT_KEYWORDS="~x86"
    and dont just echo it to the
    Code:
    echo "kde-base/kde ~x86" /etc/portage/package.keywords
    what will happen the next time that you
    Code:
    emerge world
    is that kde will revert to the x86 version
    Last edited by loft306; 01-02-2006 at 06:29 PM.
    ~Mike ~~~ Forum Rules
    Testing? What's that? If it compiles, it is good, if it boots up, it is perfect. ~ Linus Torvalds
    http://loft306.org

  5. #5
    Linux Enthusiast gruven's Avatar
    Join Date
    Dec 2004
    Location
    Arkansas
    Posts
    541
    Quote Originally Posted by loft306
    And another thing to add to this is that if you emerge with
    Code:
    ACCEPT_KEYWORDS="~x86"
    and dont just echo it to the
    Code:
    echo "kde-base/kde ~x86" /etc/portage/package.keywords
    what will happen the next time that you
    Code:
    emerge world
    is that kde will revert to the x86 version
    It won't if you put "ACCEPT_KEYWORDS="~x86" in your make.conf. If you use
    Code:
    ACCEPT_KEYWORDS="~x86" emerge kde
    on the command line it will.

    Another option would be to add all of the packages you want into /etc/portage/package.keywords using your arch keyword.

    Linux User #376741
    Code is Poetry

  6. #6
    Linux Guru loft306's Avatar
    Join Date
    Oct 2003
    Location
    The DairyLand
    Posts
    1,666
    Quote Originally Posted by gruven
    It won't if you put "ACCEPT_KEYWORDS="~x86" in your make.conf. If you use
    Code:
    ACCEPT_KEYWORDS="~x86" emerge kde
    on the command line it will.

    Another option would be to add all of the packages you want into /etc/portage/package.keywords using your arch keyword.
    Well yeah if you take the whole box to buggy then ofcourse not .....i was just expanding on the what would happen if he didnt turn it into an unstable box and didnt echo kde to keywords

    and i have never found the need to add all the pkgs to keywords....just the pkgs that wont emerge without being added to keywords (usualy comming in with a DEPEND/DEPEND issue so just adding a few to keywords solves the problem) on my servers that do still run mostly stable pkgs
    Last edited by loft306; 01-02-2006 at 06:59 PM.
    ~Mike ~~~ Forum Rules
    Testing? What's that? If it compiles, it is good, if it boots up, it is perfect. ~ Linus Torvalds
    http://loft306.org

  7. #7
    Just Joined! blackhawk3008's Avatar
    Join Date
    Nov 2005
    Location
    France
    Posts
    17
    Hello !!
    I've found the solution to my problem :
    Code:
    # for i in `ACCEPT_KEYWORDS="~x86" emerge -p kde | grep ebuild | tr -s ' ' '\t' | cut -f 4`; do \
         echo ">=$i ~x86" >> /etc/portage/package.keywords; done
    This works fine now...

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •