Find the answer to your Linux question:
Results 1 to 8 of 8
Hi. My new gentoo kernel boots up successfully (albiet without framebuffer or swap), but I have no network connection. ifconfig -a shows nothing but the local loopback. I emerged both ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux Newbie
    Join Date
    Nov 2004
    Location
    New York
    Posts
    150

    No eth0 on fresh install


    Hi. My new gentoo kernel boots up successfully (albiet without framebuffer or swap), but I have no network connection. ifconfig -a shows nothing but the local loopback. I emerged both hotplug and coldplug.

    For some reason when I was configuring the kernel, the options for hotplug and network had no box next to them, but a "---" instead. I'm not sure what this means - does it simply indicate a header/title/subsection (which is unlikely considering they have '?'-descriptions and the online install instructions tell me to answer 'Y'), or have I missed some part of the configuration process that enables these options?

    I'm on an IBM T43 with a Broadcom NetXtreme Gigabit Ethernet.
    \"Nifty News Fifty: When news breaks, we give you the pieces.\" - Sluggy Freelance

  2. #2
    Linux Guru AlexK's Avatar
    Join Date
    Feb 2005
    Location
    Earth
    Posts
    3,379
    Did you compile the driver directly into the kernel, or if you have compiled it as a module, have you told it to autoload?
    Life is complex, it has a real part and an imaginary part.

  3. #3
    Linux Newbie
    Join Date
    Nov 2004
    Location
    New York
    Posts
    150
    I browsed through the driver->network section some more and found an entry that seems to work for my card. I missed that whole submenu until now because it was nested pretty deep and not mentioned in the online guide. It works now, thanks.
    \"Nifty News Fifty: When news breaks, we give you the pieces.\" - Sluggy Freelance

  4. #4
    Just Joined!
    Join Date
    Jan 2006
    Posts
    1
    Hi Workaphobia,

    Could you spell out to me how you solved your problem ... I'm experiencing the same issue ....

    Net connection worked fine during install from CD, but after reboot, I can't get any communication. My IP information looks fine in resolv.conf, and I've fiddled with the other /etc/ network-related files with no success.

    Thanks,
    Karl

  5. #5
    Linux Enthusiast
    Join Date
    Jun 2005
    Location
    Odessa, FL
    Posts
    586
    Quote Originally Posted by staser88
    Hi Workaphobia,

    Could you spell out to me how you solved your problem ... I'm experiencing the same issue ....

    Net connection worked fine during install from CD, but after reboot, I can't get any communication. My IP information looks fine in resolv.conf, and I've fiddled with the other /etc/ network-related files with no success.

    Thanks,
    Karl
    ok, i'll try to help you the best i can . there are 2 solutions to this, manually editting the kernel to add support for your network card (the first that i explain) or installing programs that will find your card for you (second one that i explain).

    manually editting your kernel....
    find out what your network card is, then do the following in a terminal as root:
    Code:
    cd /usr/src                (go to /usr/src)
    ls                  (this is to see what's in this directory)
    cd linux-<number>                  (where <number> is the end of what you saw in the above "ls" command)
    make menuconfig && make && made modules_install         (this will bring you to a menu, you should have seen this during the install...it will then compile your kernel)
    # browse through "Device Drivers--->Network Device support--->(find what seems applicable and type "y" to compile it into the kernel)"
    # when you're done, exit from the menu...it'll eventually ask if you want to save your settings, choose "Yes"
    # now it'll start compiling your kernel...this may take a while
    # when it's done, do the following so that it gets updated in your boot menu:
    cp arch/i386/boot/bzImage /boot/kernel-custom && cp .config /boot/config-custom
    now go to your bootloader's config script. if it's grub, than the config will be found at "/boot/grub/grub.conf". if it's lilo, it'll be found at "/etc/lilo.conf"

    to edit these, do the following:
    for grub...
    Code:
    nano /boot/grub/grub.conf
    within the config file, copy the other kernel entry but edit the location of the kernel to "/boot/kernel-custom"
    when you've finished this, do CTRL+X to exit, than type y to confirm saving it

    for lilo...
    Code:
    nano /etc/lilo.conf
    within the config file, copy the other kernel entry and change the location of the kernel to "/boot/kernel-custom"
    when you've finished this, do CTRL+X to exit, than type y to confirm saving it

    hope this helps

    EDIT:
    ------------------------------------------------------------------------------------------

    installing hotplug and coldplug to find your network card for you.....
    an alternative way to fix this is to install hotplug and coldplug and have them start at boot-up and find everything for you. to do this, you'd have to chroot into your gentoo system using the gentoo install cd:
    place the cd in the drive
    boot up your computer
    enter the command prompt supplied by the cd
    do the following:
    Code:
    mount /dev/<drive-and-partition> /mnt
    (where <drive-and-partition> is where your gentoo install is installed (such as hda1, if it's on your first partition of your first drive)
    Code:
    chroot /mnt /bin/basg
    source /etc/profile
    (you are now in your gentoo install, using the kernel from the cd...but this is only temporary and we'll make it a permanent fix soon)

    Code:
    emerge hotplug coldplug
    rc-update add hotplug default
    rc-update add coldplug default
    (now hotplug and coldplug will find the necessary modules for your kernel...like the cd does)

    restart and eject the cd and you should boot up into your gentoo system, complete with internet access

  6. #6
    Linux Newbie
    Join Date
    Nov 2004
    Location
    New York
    Posts
    150
    Quote Originally Posted by staser88
    Could you spell out to me how you solved your problem ... I'm experiencing the same issue ....
    Run the make menuconfig, and then go to the driver section, and from there the networking menu. The part that adds support for specific network cards is split into three categories by speed - 10MB/100MB, 1GB, and 10GB. I made the mistake of forgetting that I had a 1GB card, not 100MB. Anyway, you can try saying yes to every single card in all three submenus - it can't hurt. If it works, you can go back later and uncheck everything but your own specific card.

    I would compile these drivers right into the kernel, not as modules. Then rebuild the kernel with make install, which should put the new kernel image in /boot. Double check that grub.conf points to it.

    Good luck.
    \"Nifty News Fifty: When news breaks, we give you the pieces.\" - Sluggy Freelance

  7. #7
    Linux Guru AlexK's Avatar
    Join Date
    Feb 2005
    Location
    Earth
    Posts
    3,379
    The better thing would be to just compile whatever driver/s you think is correct as a module, then use coldplug to launch the correct driver for you. Note coldplug needs to be in the default runlevel for this to work.

    Otherwise, you can findout which driver the install cd uses by using the lsmod command in the installation environment, and/or searching the internet, then just compile that module into the kernel, no need for coldplug or anything.
    Life is complex, it has a real part and an imaginary part.

  8. #8
    Linux Engineer d38dm8nw81k1ng's Avatar
    Join Date
    Mar 2005
    Location
    Newcastle
    Posts
    793
    Quote Originally Posted by Workaphobia
    Run the make menuconfig, and then go to the driver section, and from there the networking menu. The part that adds support for specific network cards is split into three categories by speed - 10MB/100MB, 1GB, and 10GB. I made the mistake of forgetting that I had a 1GB card, not 100MB. Anyway, you can try saying yes to every single card in all three submenus - it can't hurt. If it works, you can go back later and uncheck everything but your own specific card.

    I would compile these drivers right into the kernel, not as modules. Then rebuild the kernel with make install, which should put the new kernel image in /boot. Double check that grub.conf points to it.

    Good luck.
    unless you are using hotplug or coldplug (don't know the difference) then this won't work. i had a similar problem with my kernel, and i eventually found the problem was that i somehow had a different module compiled in as well as the one i selected. i took it out and recompiled the kernel and it was all good.
    Here's why Linux is easier than Windows:
    Package Managers! Apt-Get and Portage (among others) allow users to install programs MUCH easier than Windows can.
    Hardware Drivers. In SuSE, ALL the hardware is detected and installed automatically! How is this harder than Windows' constant disc changing and rebooting?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •