Find the answer to your Linux question:
Results 1 to 6 of 6
After installing Gentoo Linux, I tried to boot back into windows but got this error message: Error 13: Invalid or unsupported executable format Output of fdisk -l Device Boot Start ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jul 2005
    Posts
    36

    Grub gives Error 13 when trying to boot Windows XP


    After installing Gentoo Linux, I tried to boot back into windows but got this error message:
    Error 13: Invalid or unsupported executable format
    Output of fdisk -l
    Device Boot Start End Blocks Id System
    /dev/hda1 1 548 4401778+ c W95 FAT32 (LBA)
    /dev/hda2 * 549 6294 46150817+ 7 HPFS/NTFS
    /dev/hda3 * 6294 6298 36057+ 83 Linux
    /dev/hda4 6299 19457 105699667+ 5 Extended
    /dev/hda5 6299 6361 506016 82 Linux swap / Solaris
    /dev/hda6 6362 19457 105193588+ 83 Linux
    Sorry it looks so bad.

    I have this as my grub.conf file
    default 0
    timeout 30
    splashimage=(hd0,2)/boot/grub/splash.xpm.gz

    title=Gentoo Linux
    root(hd0,2)
    kernel /boot/kernel-genkernel-x86-2.6.14-gentoo-r5 root=/dev/ram0 init=/linuxrc ramdisk=8192 real_root=/dev/hda6 udev vga=0x318 video=vesafb:mtrr,ywrap,1024x768-32@85
    initrd /boot/initramfs-genkernel-x86-2.6.14-gentoo-r5

    title=Windows XP
    rootnoverify (hd0,1)
    makeactive
    chainloader +1

  2. #2
    Linux Engineer Nerderello's Avatar
    Join Date
    Apr 2003
    Location
    North East England
    Posts
    1,190
    please confirm which partition equates to your WinXP C: drive.

    At the moment grub is looking at /dev/hda2 for the C: drive , is this correct (remember that grub counts from zero and not one).

    {b]If[/b] your C: drive is the fat32 partition - /dev/hda1 - then grub needs to point at (hd0,0) (ie. 'rootnoverify (hd0,0)' ).


    Nerderello

    Use Suse 10.1 and occasionally play with Kubuntu
    Also have Windows 98SE and BeOS

  3. #3
    Just Joined!
    Join Date
    Jul 2005
    Posts
    36
    /dev/hda2 is the windows C: drive, the reason why /dev/hda1 is fat32, is because my computer only came with HP Recovery CD's, and I couldn't choose which partition to install Windows on, it just automatically did it and added an extra HP_Recovery partition for some reason.
    But yes, /dev/hda2 is supposed to be C:

  4. #4
    Linux Engineer Nerderello's Avatar
    Join Date
    Apr 2003
    Location
    North East England
    Posts
    1,190
    what haapens if you put 'rootnoverify (hd0,0)' ?

    Nerderello

    Use Suse 10.1 and occasionally play with Kubuntu
    Also have Windows 98SE and BeOS

  5. #5
    Just Joined!
    Join Date
    Jul 2005
    Posts
    36
    I know what will happen, it's not a bootable partition. I use /dev/hda1 to transfer files between Windows and Linux. (Before, I was using SuSE). But I got it to boot... I'm not sure what I did for it to work though.

  6. #6
    Just Joined!
    Join Date
    Dec 2005
    Posts
    54
    You really dont need that makeactive statement, but does no harm. Why dont you give setting rootnoverify (hd0,0) a try. From looking at fdisk output I see that the first parition is very small, bout the size of a boot partition maybe?. It could be that windows xp has the boot information on that partition, in which case you need to boot to it.


    Also, check /boot/grub for the correct stage files. I cant remember which one boots windows but its probably fat_stage1_5.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •