Find the answer to your Linux question:
Results 1 to 4 of 4
Ok, I installed gentoo on my desktop system and so far everything except wireless works fine. The card I am using is a Netgear wg311v2 (acx111 chipset) with ndiswrapper as ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux Guru AlexK's Avatar
    Join Date
    Feb 2005
    Location
    Earth
    Posts
    3,379

    Wireless problem with ndiswrapper and wpa


    Ok,
    I installed gentoo on my desktop system and so far everything except wireless works fine. The card I am using is a Netgear wg311v2 (acx111 chipset) with ndiswrapper as the driver. I am using ndiswrapper for the driver as wpa_supplicant doesn't support the native acx driver. The error message I get is:

    Feb 1 11:30:11 Mercury ndiswrapper version 1.1 loaded (preempt=yes,smp=no)
    Feb 1 11:30:11 Mercury ndiswrapper: driver wg311v2 (NETGEAR, Inc.,06/17/2004,6.0.5.30) loaded
    Feb 1 11:30:11 Mercury ACPI: PCI Interrupt Link [LNKD] enabled at IRQ 5
    Feb 1 11:30:11 Mercury ACPI: PCI Interrupt 0000:01:07.0[A] -> Link [LNKD] -> GSI 5 (level, low) -> IRQ 5
    Feb 1 11:30:11 Mercury ndiswrapper: using irq 5
    Feb 1 11:30:11 Mercury wlan0: ndiswrapper ethernet device 00:0f:b5:43:83:1f using driver wg311v2, configuration file 104C:9066:1385:4C00.5.conf
    Feb 1 11:30:11 Mercury wlan0: encryption modes supported: WEP, WPA with TKIP
    Feb 1 11:30:17 Mercury rc-scripts: No loaded modules provide "default" (default_start)
    Feb 1 11:30:17 Mercury rc-scripts: ERROR: Problem starting needed services.

    Feb 1 11:30:17 Mercury rc-scripts: "netmount" was not started.
    /etc/conf.d/net contains the following:
    config_eth0=( "192.168.0.111" )
    routes_eth0=( "default gw 192.168.0.1" )

    modules=( "wpa_supplicant" )
    wpa_supplicant_wlan0="-Dndiswrapper"
    config_wlan0=( "192.168.0.5" )
    config_wlan0=( "default gw 192.168.0.1" )
    channel_wlan0="9"
    mode_wlan0="manged"
    /etc/wpa_supplicant.conf contains:
    ctrl_interface=/var/run/wpa_supplicant
    ctrl_interface_group=0
    network={
    ssid="my_ssid"
    mode=0
    proto=WPA
    key_mgmt=WPA-PSK
    psk="my_wpa_passphrase"
    priority=5
    }
    I linked net.wlan0 to net.lo i.e. ln -s net.lo net.wlan0 (in /etc/inid.d dir), added net.wlan0 to default runlevel and removed the wired card (eth0), but still no go.

    ndiswrapper -l returns hardware + driver present, iwconfig shows an entry for wlan0, but still that error comes. Ping does not work, returns cannot connect to network.

    Also, another strange thing is iwconfig shows that the card is associated with AP, but ifconfig doesn't show the card.

    Any help is appreciated.
    Life is complex, it has a real part and an imaginary part.

  2. #2
    Linux Engineer spencerf's Avatar
    Join Date
    Jan 2005
    Location
    Syracuse, NY
    Posts
    1,144
    can you connect manually by issuing these commands?

    Code:
    #ifconfig wlan0 up
    #iwconfig wlan0 key "key-if-you-have-one"
    #iwconfig wlan0 essid "name-of-your-essid"
    #dhcpcd wlan0
    if this works then its something in your script if not then your interface isn't set up right


    EDIT: I just saw that you linked to net.lo you don't want this I don't think look at my post below for linking to net.eth0
    All right, brain. You don't like me and I don't like you, but let's just do this and I can get back to killing you with beer. All New Users Read This!!! If you have a grub problem please look at GRUB MANUAL

  3. #3
    Linux Engineer spencerf's Avatar
    Join Date
    Jan 2005
    Location
    Syracuse, NY
    Posts
    1,144
    also I believe to make net.wlan0 an initscript all you need to do is

    ln -s net.eth0 net.wlan0 in the /etc/init.d/ directory

    also under your net script you have "manged" instead of "managed"

    also do you have a static ip or dynamic ip because if its dynamic then config_wlan0 should be set to dhcp

    next. I don't know if you need the wpa_supplicant because gentoo has a file you can edit in /etc/conf.d/wireless

    for setting up the init script of net.wlan0

    take a look at the wireless config file it is well documented and works great for me. If you edit this you can just

    rc-update add net.wlan0 default

    then add ndiswrapper to /etc/modules.autoload.d/kernel-2.6
    All right, brain. You don't like me and I don't like you, but let's just do this and I can get back to killing you with beer. All New Users Read This!!! If you have a grub problem please look at GRUB MANUAL

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Guru AlexK's Avatar
    Join Date
    Feb 2005
    Location
    Earth
    Posts
    3,379
    spencerf, thanks for your replies and tips. Especially the spelling mistake


    The reason why I used wpa_supplicant.conf instead of wireless is because my network uses wpa encryption, the configuration need to reside in wpa_supplicant.

    The problem was solved thanks to a hint from a poster on gentoo forums. It was another "spelling" mistake on my part

    in my /etc/conf.d/net, this line:
    config_wlan0=( "default gw 192.168.0.1" )
    should infact be changed to
    routes_wlan0=( "default gw 192.168.0.1" )

    once again, thanks for all your help and hints.
    Life is complex, it has a real part and an imaginary part.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •