Find the answer to your Linux question:
Results 1 to 5 of 5
Hi all, I'm fairly new to linux, only a month or two's experience, but i'm getting the following error when trying to run emerge These are the packages that I ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Mar 2006
    Posts
    7

    Emerge and errors


    Hi all, I'm fairly new to linux, only a month or two's experience, but i'm getting the following error when trying to run emerge

    These are the packages that I would merge, in order:

    !!! ARCH is not set... Are you missing the /etc/make.profile symlink?
    !!! Is the symlink correct? Is your portage tree complete?

    I've never had this problem before and everything has been working fine, now all of a sudden I get this? Any help would be greatly appreciated as I'm not sure where to start. The make.profile file is listed when I do an ls, but when i try to open it says "make.profile: No such file or directory" Thanks an advance for any help you can give me.

  2. #2
    Linux Enthusiast
    Join Date
    Feb 2005
    Location
    Luton, England, UK, Earth
    Posts
    639
    Sounds like you made a mistake when you installed it, when you install portage during the gentoo installation, you have to set a few variables, arch, use and that sort of thing, it sounds like you made a mistake when you were writing them, try and go back to where they are, and set the ARCH again to whatever platform you use.

    Although I could be wrong, I dont use gentoo and havent in a while

  3. #3
    Just Joined!
    Join Date
    Mar 2006
    Posts
    7
    Wouldn't it have not worked in the first place though. It's been working properly for the last couple of months, I was then trying to update clamav and got that error.

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    Mar 2006
    Posts
    7
    here are the details when i use emerge info
    emerge info
    [Portage 2.0.51-r3 (default-linux/x86/2004.3, gcc-3.3.4, glibc-2.3.4.20040808-r1, 2.4.26-gentoo-r9 i686)
    ================================================== ===============
    System uname: 2.4.26-gentoo-r9 i686 Intel(R) Pentium(R) 4 CPU 3.00GHz
    Gentoo Base System version 1.4.16
    distcc 2.16 i686-pc-linux-gnu (protocols 1 and 2) (default port 3632) [disabled]
    Autoconf: sys-devel/autoconf-2.59-r5
    Automake: sys-devel/automake-1.8.5-r1
    Binutils: sys-devel/binutils-2.15.90.0.1.1-r3
    Headers: sys-kernel/linux-headers-2.4.21-r1
    Libtools: sys-devel/libtool-1.5.2-r7
    ACCEPT_KEYWORDS=""
    AUTOCLEAN="yes"
    CFLAGS="-O2 -march=pentium4 -fomit-frame-pointer"
    CHOST="i686-pc-linux-gnu"
    COMPILER=""
    CONFIG_PROTECT="/etc /usr/X11R6/lib/X11/xkb /usr/kde/2/share/config /usr/kde/3/share/config /usr/share/config /var/bind /var/qmail/control"
    CONFIG_PROTECT_MASK="/etc/gconf /etc/terminfo /etc/env.d"
    CXXFLAGS="-O2 -march=pentium4 -fomit-frame-pointer"
    DISTDIR="/usr/portage/distfiles"
    FEATURES="autoaddcvs ccache distlocks sandbox"
    GENTOO_MIRRORS="http://gentoo.osuosl.org http://distro.ibiblio.org/pub/Linux/distributions/gentoo"
    MAKEOPTS="-j2"
    PKGDIR="/usr/portage/packages"
    PORTAGE_TMPDIR="/var/tmp"
    PORTDIR="/usr/portage"
    PORTDIR_OVERLAY=""
    SYNC="rsync://rsync.gentoo.org/gentoo-portage"
    USE="berkdb bzlib calendar crypt ctype curl dbm dbx dvd ftp gd gdbm gif imap innodb ipv6 java jpeg kerberos krb4 ldap libg++ libwww mime msql mssql mysql mysqli ncurses odbc pdflib perl php png postgres python readline samba session shared sharedmem simplexml snmp sockets spell ssl tcpd tiff tokenizer usb vhosts x86 xml xml2 zlib"

  6. #5
    Just Joined!
    Join Date
    Mar 2006
    Posts
    7
    nevermind everyone I think I've fixed it. rm make.profile and then pointed to the correct file. everything is working now. thanks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •