Find the answer to your Linux question:
Results 1 to 8 of 8
Hi, im haveing some probs with my new gentoo install. im haveing trouble getting samba to work correctly. the situation is, that it seems as if the two daemons are ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Dec 2005
    Posts
    8

    smbd and nmbd not startet in gentoo?


    Hi, im haveing some probs with my new gentoo install.

    im haveing trouble getting samba to work correctly.


    the situation is, that it seems as if the two daemons are startet - so im told by the terminal, but all signs point at they arent!

    at boot, i get told, when init runs the scripts in /etc/runlevels/default (runlevel3) - that the samba script gets run and startet succesfully by:

    samba -> start: smbd... [OK]
    samba -> start: nmbd... [OK]


    ...
    but when i later did
    "smbclient -L localhost" (or 127.0.0.1)
    ..i got:
    error connectiing (Connection reset by peer)

    ...
    This narrowed it down to 2 options
    1)either the daemons were not running
    2)the ports where not activated / in "LISTIN"

    but since the boot told me they were, i concluded it was the port for samba

    ...
    okey, so i found out that i had no /etc/inetd/ !!!
    and since i couldnt find it in portage-tree, i decided to go with "xinetd"
    -
    i added the following file:
    /etc/xinet.d/netbios-nns

    with the content of:
    service netbios-ssn
    {
    socket_type = stream
    protocol = tcp
    wait = yes
    user = root
    server = /usr/sbin/smbd
    server_args = -D
    disable = no
    bind = 127.0.0.1
    }


    ..and tried the command: netstat -a
    which showed me that i had a TCP-port in listin state now!:

    Active Internet connections (servers and established)
    Proto Recv-Q Send-Q Local Address Foreign Address State
    tcp 0 0 *:swat *:* LISTEN
    tcp 0 0 localhost.l:netbios-ssn *:* LISTEN
    tcp 0 0 *:distcc *:* LISTEN
    udp 0 0 localhost.lo:netbios-ns *:*
    udp 0 0 *:bootpc *:*
    Active UNIX domain sockets (servers and established)


    but is was still unable to get listed shares via ""smbclient -L localhost" (or 127.0.0.1)"
    ...

    okey i now thought i would see what SWAT said to all of this, so i enabled swat by in the:

    /etc/xinetd.d/swat
    -----------------
    service swat
    {

    port = 901
    socket_type = stream
    protocol = tcp
    wait = no
    user = root
    server = /usr/sbin/swat
    log_on_failure += USERID
    disable = no
    only_from = localhost

    }


    ...

    i opened swat by "http ://127.0.0.1:901"

    and saw to my surprise that smbd and nmbd were NOT running!
    which made sense since the error by"smbclient -L localhost" could be caused by the daemon not running too!

    ::::

    i have since tried restating my box, and samba services by "/etc/init.d/samba restart/start/stop"

    ive made sure that xinetd also was running by doing the same.


    Help?

  2. #2
    Just Joined! scottro's Avatar
    Join Date
    Feb 2006
    Posts
    57
    I haven't used Gentoo in awhile, however, didn't they have an rc-update script that you would use for services like samba?

    Hopefully, someone more expert in Gentoo will soon give you a better answer.

  3. #3
    Linux Guru AlexK's Avatar
    Join Date
    Feb 2005
    Location
    Earth
    Posts
    3,379
    rc-update is just used for telling which services should be started on certain run-levels.

    @ Nimda, you can see if smbd/nmbd is running with:
    Code:
    ps -e | grep smbd
    also, you can execute /etc/init.d/samba restart to restart the service once logged in.

    Now, I haven't setup Xinetd on my server and samba still works fine, now, you have run testparm to see that smb.conf file is setup correctly?
    Also do you have 127.0.0.1 localhost lo in /etc/hosts?
    Have you turned off any firewall service which may be running on the server?
    Also, have you added root as a samba user?
    Life is complex, it has a real part and an imaginary part.

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    Dec 2005
    Posts
    8
    okey, its up and running now, thanks !

    i noticed that everytime i was shutting samba down i got:

    samba -> stop: smbd ... [ !! ]
    samba -> stop: nmbd ... [OK]

    wired!... so i tried ps -e | grep smbd (after making sure that i had manually started it)
    and the daemon was not in the PS list!

    Then this is what i did:
    -removed xinetd
    -updated samba to newest version

    ..and now she works!

    BUT there is one problem left now. since xinetd was the one making sure SWAT's port was open, i cant access swat because of no-open port ! - im pretty blank on how to dealing with this.

    thanks in advance

  6. #5
    Linux Guru AlexK's Avatar
    Join Date
    Feb 2005
    Location
    Earth
    Posts
    3,379
    Personally, i don't like SWAT, and just edit the smb.conf file manually. If you wish to do it this way, check out this tutorial.

    Now if you want to set it up via swat, when you try to access it in a browser, what error do you get?
    Life is complex, it has a real part and an imaginary part.

  7. #6
    Just Joined!
    Join Date
    Dec 2005
    Posts
    8
    Quote Originally Posted by AlexK
    Personally, i don't like SWAT, and just edit the smb.conf file manually. If you wish to do it this way, check out this tutorial.

    Now if you want to set it up via swat, when you try to access it in a browser, what error do you get?
    well i am more than capable of manually editing, i just want to check out the posibilities and extras that come with samba, and SWAT sounds intriguing!

    when i connect to http://127.0.0.1:901 (or localhost) i get "connection refused" - which before, was solved by installing xinetd and opening the port? but im afraid that will screw my smb deamons up again

  8. #7
    Linux Guru AlexK's Avatar
    Join Date
    Feb 2005
    Location
    Earth
    Posts
    3,379
    Ok,
    did a bit of searching about that problem. Now it seems that other people don't add the netbios-nns files in xinetd. All they do is just have the swat entry for xinetd and they are fine. See this wiki entry, towards the end, they just emerge xinetd, rc-update it to default and add the entry for swat in xinetd.

    Yes, I know that SWAT sounds intrigueing, but just in my experience, it just wasn't worth the trouble setting it up, Ihad to edit the smb.conf file anyway to get things working the way I wanted.
    Life is complex, it has a real part and an imaginary part.

  9. #8
    Just Joined!
    Join Date
    Dec 2005
    Posts
    8
    Quote Originally Posted by AlexK
    Ok,
    did a bit of searching about that problem. Now it seems that other people don't add the netbios-nns files in xinetd. All they do is just have the swat entry for xinetd and they are fine. See this wiki entry, towards the end, they just emerge xinetd, rc-update it to default and add the entry for swat in xinetd.

    Yes, I know that SWAT sounds intrigueing, but just in my experience, it just wasn't worth the trouble setting it up, Ihad to edit the smb.conf file anyway to get things working the way I wanted.
    okey. thanks for your help mate. really appreciated!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •