Find the answer to your Linux question:
Results 1 to 7 of 7
Whenever I do a (well something like "emerge -uvDNp world", I get this: Code: These are the packages that I would merge, in order: Calculating world dependencies .....  ...done! ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux Enthusiast Weedman's Avatar
    Join Date
    May 2005
    Location
    Tasmania, Australia
    Posts
    640

    I don't think i want this...


    Whenever I do a (well something like "emerge -uvDNp world", I get this:
    Code:
    These are the packages that I would merge, in order:
    
    Calculating world dependencies  .....  ...done!
    [ebuild     U ] sys-devel/gnuconfig-20060227 [20050324] 0 kB 
    [ebuild     U ] sys-devel/gcc-config-1.3.13-r1 [1.3.11-r4] 0 kB 
    [ebuild     U ] sys-devel/m4-1.4.4 [1.4.3] +nls 299 kB 
    [ebuild     U ] sys-devel/bison-2.1 [1.875d] +nls -static 982 kB 
    [ebuild     U ] sys-apps/sed-4.1.4-r1 [4.1.4] -bootstrap -build +nls -static 775 kB 
    This >  [ebuild  NS   ] sys-devel/gcc-3.4.5  (-altivec) -bootstrap -boundschecking -build -doc +fortran -gcj +gtk -hardened -ip28 (-multilib) -multislot (-n32) (-n64) +nls -nocxx -nopie -nossp -objc -vanilla 27,703 kB 
    And This >[ebuild     U ] sys-devel/gcc-3.3.6 [3.3.5.20050130-r1] (-altivec) -bootstrap -boundschecking -build -doc +fortran -gcj +gtk -hardened -ip28 (-multilib) -multislot (-n32) (-n64) +nls -nocxx -nopie -nossp -objc -vanilla 23,522 kB 
    [ebuild     U ] sys-libs/glibc-2.3.5-r2 [2.3.4.20041102-r1] -build -erandom -glibc-compat20 -glibc-omitfp -hardened -linuxthreads-tls (-multilib) +nls -nptl -nptlonly -pic -profile (-selinux) -userlocales 15,628 kB 
    [ebuild     U ] sys-apps/texinfo-4.8-r2 [4.8] -build +nls -static 1,486 kB 
    [ebuild     U ] sys-apps/man-1.6-r1 [1.6] +nls 228 kB 
    [ebuild     U ] sys-apps/man-pages-2.25 [2.02] +nls 1,719 kB 
    [ebuild     U ] sys-apps/grep-2.5.1-r8 [2.5.1-r7] -build +nls -static 667 kB 
    [ebuild     U ] sys-libs/db-4.2.52_p2-r1 [4.2.52_p2] -bootstrap -doc -java -nocxx -tcltk 3,980 kB 
    [ebuild     U ] sys-libs/gdbm-1.8.3-r2 [1.8.3-r1] +berkdb 223 kB 
    [ebuild     U ] dev-perl/Locale-gettext-1.05 [1.03] -minimal 7 kB 
    [ebuild     U ] sys-devel/autoconf-2.59-r7 [2.59-r6] -emacs 903 kB 
    [ebuild     U ] sys-libs/readline-5.1_p2 [5.0-r2] 0 kB 
    [ebuild     U ] dev-libs/openssl-0.9.7i [0.9.7e-r1] -bindist -emacs -test +zlib 3,204 kB 
    [ebuild  N    ] app-misc/ca-certificates-20050804  91 kB 
    [ebuild     U ] sys-apps/sandbox-1.2.12 [1.2.11] 217 kB 
    [ebuild     U ] app-misc/pax-utils-0.1.10 [0.1.9] -caps 50 kB 
    [ebuild     U ] sys-apps/debianutils-2.14.1-r1 [2.13.1-r1] -build -static 123 kB 
    [ebuild     U ] sys-apps/coreutils-5.2.1-r7 [5.2.1-r6] -acl -build +nls (-selinux) -static 4,235 kB 
    [ebuild     U ] sys-devel/make-3.80-r4 [3.80-r1] -build +nls -static 899 kB 
    [ebuild   R   ] sys-kernel/gentoo-sources-2.6.15-r1  -build -doc -symlink* (-ultra1) 0 kB 
    [ebuild     U ] sys-devel/libtool-1.5.22 [1.5.18-r1] 2,853 kB 
    [ebuild     U ] media-libs/libpng-1.2.8-r1 [1.2.8] -doc 0 kB 
    [ebuild     U ] app-crypt/hashalot-0.3-r2 [0.3] 78 kB 
    [ebuild     U ] sys-devel/flex-2.5.33-r1 [2.5.4a-r5] +nls -static 679 kB 
    [ebuild     U ] sys-libs/cracklib-2.8.5-r1 [2.8.3-r1] +nls +python 547 kB 
    [ebuild     U ] sys-libs/pam-0.78-r3 [0.78-r2] +berkdb -nis -pam_chroot -pam_console -pam_timestamp -pwdb (-selinux) 6,345 kB 
    [ebuild     U ] sys-apps/shadow-4.0.14-r1 [4.0.7-r3] +nls -nousuid +pam (-selinux) -skey 1,217 kB 
    [ebuild     U ] sys-apps/pam-login-4.0.14 [3.17] -livecd +nls (-selinux) -skey 0 kB 
    [ebuild     U ] sys-libs/com_err-1.38 [1.37] +nls 3,536 kB 
    [ebuild     U ] sys-libs/ss-1.38 [1.37] +nls 0 kB 
    [ebuild     U ] sys-fs/e2fsprogs-1.38-r1 [1.37-r1] +nls -static 0 kB 
    [ebuild     U ] sys-apps/util-linux-2.12r-r2 [2.12i-r1] +crypt +nls -old-crypt +pam +perl (-selinux) -static 1,502 kB 
    [ebuild     U ] app-arch/bzip2-1.0.3-r6 [1.0.3-r4] -build -static 653 kB 
    [ebuild     U ] x11-base/opengl-update-2.2.4 [2.2.1] 0 kB 
    [ebuild   R   ] x11-base/xorg-x11-6.8.2-r6  -3dfx +3dnow* +bitmap-fonts -cjk -debug -dlloader -dmx -doc -font-server -insecure-drivers +ipv6 -minimal +mmx* +nls -nocxx +opengl +pam -sdk +sse -static +truetype-fonts +type1-fonts (-uclibc) -xprint +xv 0 kB 
    [ebuild     U ] sys-apps/file-4.13 [4.12] -build +python 410 kB 
    [ebuild     U ] app-arch/cpio-2.6-r5 [2.6-r4] +nls 437 kB 
    [ebuild     U ] sys-apps/findutils-4.1.20-r2 [4.1.20-r1] -build +nls (-selinux) -static 759 kB 
    [ebuild     U ] sys-apps/module-init-tools-3.2.1 [3.0-r2] 393 kB 
    [ebuild     U ] x11-drivers/ati-drivers-8.23.7 [8.22.5] +opengl 33,641 kB 
    [ebuild     U ] app-misc/mime-types-5 [4] 6 kB 
    [ebuild     U ] app-editors/nano-1.3.9 [1.3.7] -build -debug -justify -minimal +ncurses +nls -slang +spell -unicode 1,109 kB 
    [ebuild     U ] sys-process/procps-3.2.6 [3.2.5-r1] (-n32) 272 kB 
    [ebuild   R   ] media-libs/libmikmod-3.1.11-r1  +alsa +esd* +oss 0 kB 
    [ebuild   R   ] media-libs/libsdl-1.2.9-r1  +X -aalib +alsa -arts -dga -directfb +esd* -fbcon -ggi -libcaca -nas -noaudio -noflagstrip -nojoystick -novideo +opengl +oss -svga -xinerama +xv 0 kB 
    [ebuild   R   ] media-sound/xmms-1.2.10-r15  +3dnow +alsa -arts -directfb +esd* +flac* -jack -lirc +mad +mikmod +mmx +mp3 +nls +oss -sndfile +vorbis 0 kB 
    [ebuild     U ] sys-apps/gawk-3.1.5 [3.1.3-r2] -build +nls 2,256 kB 
    [ebuild  N    ] media-plugins/xmms-esd-1.2.10-r1  +oss 0 kB 
    [ebuild     U ] app-text/poppler-0.5.0-r5 [0.5.0-r4] -cairo +jpeg 0 kB 
    [ebuild   R   ] net-print/cups-1.1.23-r7  +gnutls* +nls +pam +samba -slp +ssl 0 kB 
    [ebuild  N    ] sys-apps/ed-0.2-r6  181 kB 
    [ebuild     U ] net-fs/samba-3.0.21b [3.0.14a-r2] -acl -async -automount +cups -doc -examples -kerberos -ldap -ldapsam -libclamav +mysql -oav +pam -postgres +python -quotas +readline (-selinux) -swat -syslog -winbind -xml +xml2 17,143 kB 
    [ebuild     U ] net-misc/wget-1.10.2 [1.9.1-r5] -build -debug +ipv6 +nls -socks5 +ssl -static 1,189 kB 
    [ebuild   R   ] media-libs/imlib2-1.2.1.009  +X +bzip2 -doc +gif +jpeg +mmx* +mp3 +nls +png +tiff* +zlib 0 kB 
    [ebuild   R   ] gnome-base/libgnome-2.12.0.1  -debug -doc +esd* -static 0 kB 
    [ebuild   R   ] app-editors/gvim-6.4  -acl -bash-completion -cscope +gnome* +gpm +gtk +motif +nls +perl +python -ruby 0 kB 
    [ebuild     U ] net-misc/openssh-4.2_p1-r1 [3.9_p1-r2] -X509 -chroot -hpn +ipv6 -kerberos -ldap -libedit +pam (-selinux) -sftplogging -skey -smartcard -static +tcpd 892 kB 
    [ebuild   R   ] media-sound/alsa-tools-1.0.10  -fltk +gtk* 0 kB 
    [ebuild   R   ] media-sound/mpg123-0.59s-r9  +3dnow* +esd* +mmx* -nas +oss 0 kB 
    [ebuild     U ] app-arch/tar-1.15.1-r1 [1.15.1] -build +bzip2* +nls -static 1,573 kB 
    [ebuild  NS   ] media-gfx/splash-themes-livecd-2006.0  0 kB 
    [ebuild     U ] net-misc/dhcpcd-2.0.3 [2.0.0] -build -debug -static 120 kB 
    [ebuild     U ] www-client/mozilla-launcher-1.49 [1.45] 5 kB 
    [ebuild   R   ] gnome-extra/libgsf-1.12.1  +bzip2 -debug -doc +gnome* -static 0 kB 
    [ebuild   R   ] dev-php/mod_php-4.4.0-r9  +X +apache2 +berkdb +crypt -curl -debug -doc -fdftk -firebird -flash -freetds -gd -gd-external +gdbm -gmp -hardenedphp -imap -informix +ipv6 -java +jpeg -kerberos -ldap -mcal -memlimit -mssql +mysql +nls -oci8 -odbc +pam +png -postgres -snmp +spell +ssl +tiff* +truetype +xml2 -yaz 0 kB 
    [ebuild   R   ] dev-php/php-4.4.0-r4  +X +berkdb +crypt -curl -debug -doc -fdftk -firebird -flash -freetds -gd -gd-external +gdbm -gmp -hardenedphp -imap -informix +ipv6 -java +jpeg -kerberos -ldap -mcal -memlimit -mssql +mysql +ncurses +nls -oci8 -odbc +pam +png -postgres +readline -snmp +spell +ssl +tiff* +truetype +xml2 -yaz 0 kB 
    [ebuild     U ] sys-apps/hdparm-6.3 [5.9] 43 kB 
    [ebuild     U ] sys-apps/kbd-1.12-r6 [1.12-r5] +nls 867 kB 
    [ebuild     U ] sys-apps/less-385_p4-r2 [382-r2] -unicode 482 kB 
    [ebuild   R   ] app-office/abiword-2.2.11  -debug +gnome* +jpeg +spell +xml2 0 kB 
    [ebuild     U ] net-misc/rsync-2.6.0-r6 [2.6.0-r5] -acl -build -livecd -static -xinetd 458 kB 
    [ebuild     U ] sys-process/psmisc-22.1 [21.5] +X +ipv6 +nls (-selinux) 230 kB 
    [ebuild   R   ] sys-apps/pcmcia-cs-3.2.8-r2  +X* +gtk -trusted -vanilla -xforms 0 kB 
    [ebuild     U ] x11-libs/fltk-1.1.7 [1.1.6] -debug -noxft +opengl 2,012 kB 
    [ebuild     U ] x11-apps/ati-drivers-extra-8.23.7 [8.22.5] +qt* 0 kB 
    
    Total size of downloads: 168,853 kB
    That was a full log of emerge's output.

    As you can see, it wants to update the currently installed version, and install the latest stable version of gcc.

    I don't think I want this, how do I stop emerge from doing this?
    ~weed
    "Time has more than one meaning, and is more than one dimension" - /.unknown
    --Registered Linux user #396583--

  2. #2
    Linux Engineer spencerf's Avatar
    Join Date
    Jan 2005
    Location
    Syracuse, NY
    Posts
    1,144
    what gcc version are you currently using? Have you read the gcc upgrade guide? here
    All right, brain. You don't like me and I don't like you, but let's just do this and I can get back to killing you with beer. All New Users Read This!!! If you have a grub problem please look at GRUB MANUAL

  3. #3
    Linux Engineer
    Join Date
    Oct 2004
    Location
    Vancouver
    Posts
    1,366
    Just mask the packages then, man emerge and man portage both tell how to with little difficulty
    Operating System: GNU Emacs

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    Mar 2006
    Posts
    2
    Or you could make a compelte gcc upgrade with a system & world updates.

    Just upgraded to gcc 3.4.5 on amd64 myself. No problems whatsoever.

  6. #5
    Linux Enthusiast Weedman's Avatar
    Join Date
    May 2005
    Location
    Tasmania, Australia
    Posts
    640
    Quote Originally Posted by gloomy
    Or you could make a compelte gcc upgrade with a system & world updates.

    Just upgraded to gcc 3.4.5 on amd64 myself. No problems whatsoever.
    I have decided that I will update the system/world right after I reinstall the base gentoo when I reinstall gentoo on my laptop. I went a bit over the top when I was trying Gentoo for the first time. I totally screwed up my use flags.

    ~weed
    "Time has more than one meaning, and is more than one dimension" - /.unknown
    --Registered Linux user #396583--

  7. #6
    Linux Guru loft306's Avatar
    Join Date
    Oct 2003
    Location
    The DairyLand
    Posts
    1,666
    at this point all you realy need to do is to edit your use flags and then simply either
    Code:
    emerge -e world
    to simply rebuild the system & all the other packages or
    Code:
    emerge -N world
    to simply re-emerge everything with the new Use flags. There is no need to reinstall
    ~Mike ~~~ Forum Rules
    Testing? What's that? If it compiles, it is good, if it boots up, it is perfect. ~ Linus Torvalds
    http://loft306.org

  8. #7
    Linux Enthusiast Weedman's Avatar
    Join Date
    May 2005
    Location
    Tasmania, Australia
    Posts
    640
    That was a rather interesting experience.

    Updating gcc on first install wasn't that hard, but the first time I did it, I didn't follow the instructions set on the Gentoo website. So I broke my system. Second attempt proved successful.

    I then proceded to update system, and now I have a very up to date laptop indeed.

    Thanks guys,
    ~the_weedman
    "Time has more than one meaning, and is more than one dimension" - /.unknown
    --Registered Linux user #396583--

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •