Find the answer to your Linux question:
Page 2 of 2 FirstFirst 1 2
Results 11 to 20 of 20
Originally Posted by spencerf what about same command but to /dev/sound/dsp so: Code: cat /dev/urandom > /dev/sound/dsp it this works you could try a symbolic link to from /dev/sound/dsp to ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #11
    Linux Enthusiast crashandburn0420's Avatar
    Join Date
    Jun 2005
    Location
    Naugatuck, CT
    Posts
    590

    Quote Originally Posted by spencerf
    what about same command but to /dev/sound/dsp

    so:

    Code:
    cat /dev/urandom > /dev/sound/dsp
    it this works you could try a symbolic link to from /dev/sound/dsp to /dev/dsp
    localhost steven # cat /dev/urandom > /dev/sound/dsp
    bash: /dev/sound/dsp: No such file or directory

  2. #12
    Linux Enthusiast crashandburn0420's Avatar
    Join Date
    Jun 2005
    Location
    Naugatuck, CT
    Posts
    590
    Quote Originally Posted by bryansmith
    How does my solution not work (just curious)? Do you get an error or does firefox still not produce any sound?

    Bryan
    still no sound in firefox

  3. #13
    Linux Guru bryansmith's Avatar
    Join Date
    Nov 2004
    Location
    /Ontario/Canada
    Posts
    2,619
    Sorry, I'm fresh out of ideas. I hope someone else can help.

    Bryan
    Looking for a distro? Look here.
    "There can be no doubt that all our knowledge begins with experience." - Immanuel Kant (Critique of Pure Reason)
    Queen's University - Arts and Science 2008 (Sociology)
    Registered Linux User #386147.

  4. $spacer_open
    $spacer_close
  5. #14
    Linux Engineer spencerf's Avatar
    Join Date
    Jan 2005
    Location
    Syracuse, NY
    Posts
    1,144
    well if you don't have /dev/sound/dsp then I believe that your alsa setup is not correct because in gentoo this is where the device is setup. /dev/dsp is where oss emulation is setup.

    Does sound work normally with something like mplayer?

    both oss and alsa?

    you can test by

    Code:
    mplayer -ao alsa somefile.avi
    mplayer -ao oss somefile.avi
    All right, brain. You don't like me and I don't like you, but let's just do this and I can get back to killing you with beer. All New Users Read This!!! If you have a grub problem please look at GRUB MANUAL

  6. #15
    Linux Enthusiast crashandburn0420's Avatar
    Join Date
    Jun 2005
    Location
    Naugatuck, CT
    Posts
    590
    only alsa works

  7. #16
    Linux Engineer d38dm8nw81k1ng's Avatar
    Join Date
    Mar 2005
    Location
    Newcastle
    Posts
    793
    if i understand spencer correctly, then possibly OSS emulation is broken. this could be the reason for the lack of sound.
    Here's why Linux is easier than Windows:
    Package Managers! Apt-Get and Portage (among others) allow users to install programs MUCH easier than Windows can.
    Hardware Drivers. In SuSE, ALL the hardware is detected and installed automatically! How is this harder than Windows' constant disc changing and rebooting?

  8. #17
    Linux Engineer spencerf's Avatar
    Join Date
    Jan 2005
    Location
    Syracuse, NY
    Posts
    1,144
    that seems to be the case even though it was my understanding that gentoo set up device points at /dev/sound/dsp for alsa and /dev/dsp for oss and it seems that you have /dev/dsp but not /dev/sound/dsp.

    but that doesn't really matter because the problem is you don't have oss support enabled. You need to go into your kernel and add oss emulation support.

    Code:
      <M> Advanced Linux Sound Architecture                 
                     <M> Sequencer support                                 
                     < >   Sequencer dummy client                          
                     <M> OSS Mixer API                                     
                     --- OSS PCM (digital audio) API                       
                    [*] OSS Sequencer API                                
                     [ ] Verbose printk                                    
                     [ ] Debug                                             
                         Generic devices  --->                             
                         PCI devices  --->
    this is what I have and make sure you run alsaconf afterwords
    All right, brain. You don't like me and I don't like you, but let's just do this and I can get back to killing you with beer. All New Users Read This!!! If you have a grub problem please look at GRUB MANUAL

  9. #18
    Linux Guru loft306's Avatar
    Join Date
    Oct 2003
    Location
    The DairyLand
    Posts
    1,666
    First of all if you are using alsa in the kernel you must not have any oss in the kernel....if u need oss emulation and it is good to have for apps that still arent using alsa you put 'oss' in UES flags

    also as stated above you run 'alsaconf' as root ad that should be it

    Secound if you are using the alsa-driver you have neither alsa or oss in the kernel and you place 'oss' in USE flags to get oss emulation. Also remember to re emerge alsa-driver after every kernel compile

    however i have seen some versions of ffx having the wrong permissions on some files and some plugins on my older amd64 box and thus dosnt have sound with some videos .....and it is a pain i was told to chmod +ax to thease files though i havent done this as of yet.....
    Last edited by loft306; 04-28-2006 at 01:01 AM.
    ~Mike ~~~ Forum Rules
    Testing? What's that? If it compiles, it is good, if it boots up, it is perfect. ~ Linus Torvalds
    http://loft306.org

  10. #19
    Linux Enthusiast crashandburn0420's Avatar
    Join Date
    Jun 2005
    Location
    Naugatuck, CT
    Posts
    590
    I recompiled my kernel, did everything right and still no sound in firefox. also to enable oss emulation edit /etc/conf.d/alsasound

  11. #20
    Just Joined!
    Join Date
    Aug 2006
    Posts
    1
    #emerge esound
    #/etc/init.d/esound start
    #rc-update add esound default

    nano /usr/bin/firefox
    (or firefox-bin)
    Change:
    exec /usr/libexec/mozilla-launcher "$@"
    to:
    #exec /usr/libexec/mozilla-launcher "$@"
    aoss /usr/libexec/mozilla-launcher "$@"

    (or use aoss32)
    and it's done.

    Source:
    http://mx.grulic.org.ar/lurker/messa...52f870.es.html

    Saludos desde Guatemala

Page 2 of 2 FirstFirst 1 2

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •