Find the answer to your Linux question:
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 16
I installed Gentoo a few days ago, I have been working with ALSA and all that trying to get my sound working. I have an Intel i810 sound card, which ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    kbk
    kbk is offline
    Linux User kbk's Avatar
    Join Date
    Jun 2005
    Location
    Ohio, USA
    Posts
    361

    No sound at all


    I installed Gentoo a few days ago, I have been working with ALSA and all that trying to get my sound working. I have an Intel i810 sound card, which ALSA figures out just fine, but sound still won't work. I have my speakers plugged into the headphone jack (easier for me to get to). Any help with this would be appreciated.

  2. #2
    Linux Guru Cabhan's Avatar
    Join Date
    Jan 2005
    Location
    Seattle, WA, USA
    Posts
    3,252
    Well, two things:

    1) I assume that you installed ALSA support for your card? May be silly, but some people forget stuff like this.

    2) If you run alsamixer, is your Master muted? Are any other channels muted or set too low?

    'alsamixer' is in the 'alsa-utils' package, if you need to install it. These are the two most common problems I can think of.

  3. #3
    kbk
    kbk is offline
    Linux User kbk's Avatar
    Join Date
    Jun 2005
    Location
    Ohio, USA
    Posts
    361
    Well my master sound would be my headphone outlet, so shouldn't I have that one enabled and the rest disabled? Of course I installed ALSA support for my card, I went through the whole alsaconf thing and everything at least twice..

  4. #4
    Linux Guru Cabhan's Avatar
    Join Date
    Jan 2005
    Location
    Seattle, WA, USA
    Posts
    3,252
    You need several channels enabled and working:

    - Master (this is the Master volume, controlling total output)
    - PCM (not sure what this does, but has something to do with sound output)

    I personally have my Headphone channel muted right now and can still play through my headphones (and speakers when they're plugged in). I only have Master, PCM, Treble, and Bass channels up.

    So try fiddling around with the levels there. If it still doesn't work, we go into super troubleshoot mode.

  5. #5
    kbk
    kbk is offline
    Linux User kbk's Avatar
    Join Date
    Jun 2005
    Location
    Ohio, USA
    Posts
    361
    Well into super troubleshoot mode we must go then.. Nothing is working or has worked so far, I have not heard the slightest noise from the speakers. I asked on the Gentoo official forums as well and have gotten nothing. I need to have this working by sunday so that I can play in my Wolfenstein clan match..

  6. #6
    Just Joined! pupdaleon's Avatar
    Join Date
    Apr 2005
    Location
    Hamilton ON Canada
    Posts
    85
    i have the SAME problem as many do with the SAME CARD...

    i'm still looking for an answer. till then i use another card (i know giving up is bad)

  7. #7
    kbk
    kbk is offline
    Linux User kbk's Avatar
    Join Date
    Jun 2005
    Location
    Ohio, USA
    Posts
    361
    I'm not giving up. and I can't afford a new card, so I'm stuck.

  8. #8
    Linux Engineer spencerf's Avatar
    Join Date
    Jan 2005
    Location
    Syracuse, NY
    Posts
    1,144
    have you actually pressed the "M" key to unmute the card and not just raised the levels?
    All right, brain. You don't like me and I don't like you, but let's just do this and I can get back to killing you with beer. All New Users Read This!!! If you have a grub problem please look at GRUB MANUAL

  9. #9
    kbk
    kbk is offline
    Linux User kbk's Avatar
    Join Date
    Jun 2005
    Location
    Ohio, USA
    Posts
    361
    Yes, I have, thanks for the vote of confidence. The reason I am posting this now is because there has been a new development, I got new speakers. There is still no ******* sound. What the hell can I do now?!

  10. #10
    Linux Engineer d38dm8nw81k1ng's Avatar
    Join Date
    Mar 2005
    Location
    Newcastle
    Posts
    793
    Code:
    lspci | grep audio
    this should tell you what your sound card is recognised as. also, try running it from the liveCD if it doesn't work off the hdd install. you may not have enabled the right modules for it in the sound drivers.
    Here's why Linux is easier than Windows:
    Package Managers! Apt-Get and Portage (among others) allow users to install programs MUCH easier than Windows can.
    Hardware Drivers. In SuSE, ALL the hardware is detected and installed automatically! How is this harder than Windows' constant disc changing and rebooting?

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •