Find the answer to your Linux question:
Results 1 to 8 of 8
Hi. I have a Gentoo box that has no monitor attached to it. I access it through VNC. When I open up the VNC connection, X Windows runs, and then ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    May 2006
    Posts
    9

    Can't get KDE to run as default


    Hi.
    I have a Gentoo box that has no monitor attached to it. I access it through VNC. When I open up the VNC connection, X Windows runs, and then from there I run the startkde command. So, KDE is running within X Windows. This means that I have the teal X Windows bar at the top of all windows (including desktop and kicker) and multiple desktops and the toolbar do not work since the program windows are all managed by X Windows instead of KDE. How can I set it so that KDE is the one that starts instead of X Windows? I have already edited the ~/.xinitrc file so it reads echo "exec startkde" . What else can I do? I am a new user, so please explain very clearly and simply, without assuming I know much .

  2. #2
    Linux Guru budman7's Avatar
    Join Date
    Oct 2004
    Location
    Knee deep in Grand Rapids, Michigan
    Posts
    3,242
    Have you tried the "startx" command instead of "starkde"?
    How to know if you are a geek.
    when you respond to "get a life!" with "what's the URL?"
    - Birger

    New users read The FAQ

  3. #3
    Just Joined!
    Join Date
    May 2006
    Posts
    9
    Yep.

    New development: I had a friend who's a Gentoo wizard look what I'd done already, and he says I've done almost all I can, and that I should switch the default run level from 3 to 5, so that the VNC will correctly follow the protocol that I've set up instead of going it's own way. But, since I'm going in through VNC only, wouldn't that probably cause me to not be able to access the system at all through VNC?

    Any thoughts?

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Guru budman7's Avatar
    Join Date
    Oct 2004
    Location
    Knee deep in Grand Rapids, Michigan
    Posts
    3,242
    What happened when you tried startx?
    How to know if you are a geek.
    when you respond to "get a life!" with "what's the URL?"
    - Birger

    New users read The FAQ

  6. #5
    Just Joined!
    Join Date
    May 2006
    Posts
    9
    X Window System Version 6.8.2
    Release Date: 9 February 2005
    X Protocol Version 11, Revision 0, Release 6.8.2
    Build Operating System: Linux 2.6.15-gentoo-r1 i686 [ELF]
    Current Operating System: Linux localhost 2.6.15-gentoo-r1 #1 PREEMPT Wed Apr 19 14:12:09 Local time zone must be set--see i686
    Build Date: 22 April 2006
    Before reporting problems, check http://wiki.X.Org
    to make sure that you have the latest version.
    Module Loader present
    Markers: (--) probed, (**) from config file, (==) default setting,
    (++) from command line, (!!) notice, (II) informational,
    (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
    (==) Log file: "/var/log/Xorg.0.log", Time: Wed May 10 14:37:05 2006
    (EE) Unable to locate/open config file
    Using vt 7
    xf86AutoConfig: Primary PCI is 1:0:0
    Running "/usr/bin/getconfig -X 60802000 -I /etc/X11,/usr/X11R6/etc/X11,/usr/lib/modules,/usr/X11R6/lib/X11/getconfig -v 0x1002 -d 0x4742 -r 0x5c -s 0x1028 -b 0x4082 -c 0x0300"
    getconfig.pl: Version 1.0.
    getconfig.pl: Xorg Version: 6.8.2.0.
    getconfig.pl: 23 built-in rules.
    getconfig.pl: rules file '/usr/X11R6/lib/X11/getconfig/xorg.cfg' has version 1.0.
    getconfig.pl: 1 rule added from file '/usr/X11R6/lib/X11/getconfig/xorg.cfg'.
    getconfig.pl: Evaluated 24 rules with 0 errors.
    getconfig.pl: Weight of result is 500.
    New driver is "ati"
    (==) Using default built-in configuration (53 lines)
    (EE) open /dev/fb0: Unknown error 999
    exec startkde

    waiting for X server to shut down

    localhost ~ #

    That's what comes up when I type in startx instead of startkde . It doesn't seem to do anything in particular, but I am already in VNC (and thus X Windows) at the time that I type this in. I've tried typing it in while in Putty (SSH) but it does not seem to make a difference, it acts the same once I go in through VNC.

  7. #6
    Just Joined!
    Join Date
    May 2006
    Posts
    6
    Edit your /etc/conf.d file. At the end, there should be a line that looks similar to this:
    XSESSION="kde-3.4.3"
    Make sure you use the version number you installed.

  8. #7
    Just Joined!
    Join Date
    May 2006
    Posts
    9
    Ok, now the problem gets weirder...

    I finally got a montior to hook up to the box, and now neither KDE nor X Windows will run. They seem like they will; when I use the startx command the screen goes black, and I see my mouse cursor for an instant, then it is back to terminal. From the it gives me, it seems to me that it is opening X Windows, but then immediately shutting it down. They still, however, both run when I use VNC to get into the box.

    Also, when I try to open /etc/conf.d it says "Error reading file", which is odd, because I know I have opened that file before.

  9. #8
    Just Joined!
    Join Date
    May 2006
    Posts
    6
    Quote Originally Posted by sadly_duckish
    Ok, now the problem gets weirder...
    Also, when I try to open /etc/conf.d it says "Error reading file", which is odd, because I know I have opened that file before.
    /etc/conf.d is a directory. But that's not where you need to be to tweak Xfree86 settings. You need to edit /etc/xorg.conf to tweak things.

    What's the last error message after it dies? If you're unsure, it'll be in the /var/log/Xorg.0.log.

    If you're using VNC, I'm wondering if it's trying to map to the wrong display. Should be trying to map to display 0:0

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •