Find the answer to your Linux question:
Results 1 to 2 of 2
I run gentoo current stable on my home server. I recently upgraded the system to a new motherboard. Old system was a PIII 500 and the new is a P4 ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Dec 2005
    Posts
    54

    sata_sil causing system to lock.


    I run gentoo current stable on my home server. I recently upgraded the system to a new motherboard. Old system was a PIII 500 and the new is a P4 2.4Ghz with gig of ram in it. I used in my make.conf file -march=pentium3 and then switched it to pentium4 after the switch. I dont see this causing any problems as the p4 can handle all the p3 stuff, I only mention it in case im wrong in this assumtion.

    The problem Im having is that the faster board also has built in SATA raid controller so I can now get rid of the pci adaptor I was using. I Could of sworn that I have gotten the sata working on this board before a year or so back but cant member for certain. Im running 2.6.16-r3 and tried to modprobe sata_sil which supports the siI 3112 chipset it has onboard and the system locks. I then upgraded the kernel to 2.6.16-r7 and recompiled from scratch and tried yet again with the same results. Compiling into the kernel makes the system unbootable.. soon as it loads or trys to load the driver rather the system hangs. Nothing in logs or anything...

    Any suggestions would be most appreciated.

  2. #2
    Just Joined!
    Join Date
    May 2006
    Posts
    1
    I tried the same thing for the same chipset, and no such luck even from a fresh install. It does not appear to match up to the driver.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •