Find the answer to your Linux question:
Results 1 to 4 of 4
Hi, I am having a problem when I try starting x with startx as my user. When I type startx and press enter, it brings up a black screen with ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Mar 2006
    Posts
    32

    Black screen, gray lines


    Hi, I am having a problem when I try starting x with startx as my user. When I type startx and press enter, it brings up a black screen with gray lines going down the right side of it, and then nothing happens. The wierd thing is though, that I am able to see the mouse moving in those gray lines if I move it. Is there anyway to fix this?

  2. #2
    Linux User oosterhouse's Avatar
    Join Date
    Jan 2006
    Location
    Grand Rapids, MI
    Posts
    318
    Make sure you did xorgconfig correctly. Your Horizontal/Vertical Sync, Graphics card, etc. probably aren't configured right. Also, make sure your resolution is right in /etc/X11/xorg.conf after you use xorgconfig. Hope that helps.

  3. #3
    oz
    oz is offline
    forum.guy
    Join Date
    May 2004
    Location
    arch linux
    Posts
    18,733
    Sounds like maybe wrong video driver, wrong screen resolution, or perhaps incorrect Horiz and/or Vert refresh. Was it working properly before and then it stopped?

    What video card & driver are you using?

    What settings are you using in xorg.conf?
    oz

  4. #4
    Just Joined!
    Join Date
    Mar 2006
    Posts
    32
    Ok, it is fixed. But now that I have kde up and running a few questions have arrisen. First, how do I make it so that cd's, dvds, and flash drives dont need to be written if fstab to be recognized and able to be open? Also, I have sound in my system, I just need a way to make it be there when I restart my computer instead of always having to /etc/init.d/alsasound start when I enter the KDE environment. Also having to do with sound, I seem to be having trouble hearing sound from things such as flash videos and games. Another problem; for some reason I cannot login to kde as root. I know that it is hightly unadvised, but everyonce and a while I would have to do it. Something else, is there any way of making it so when I turn on my computer, it acts a little like a live cd and provides a graphical login instead of alway having to su - justin, then startx. And finally, for some reason when something asks me for my user password and I enter it CORRECTLY, it says that it is incorrect. For example, when I tried testing to see if CUPS worked, and it asked me for my user name's password, I entered it and it said it was wrong. I had to put in my root's password just to see if my printer worked. Sorry about all the questions, but I'm new to Gentoo and somewhat new to Linux. Thanks for your help

    [edit]
    1) fixed the sound at startup problem
    2)found out how to fix logging on as root problem
    3)found out how to do the graphical login
    4)fixed my password for my user
    5)able to open usb and access the files now

    Things not fixed: Sound in flash videos, cd's and dvd playback

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •