Find the answer to your Linux question:
Results 1 to 4 of 4
So i decided that my network problem was something i missed in the install process. So i opted to try again. I figured since the LiveCD can detect all my ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    May 2006
    Posts
    10

    Grub splash not there!


    So i decided that my network problem was something i missed in the install process. So i opted to try again. I figured since the LiveCD can detect all my hardware with no problems and everything works fine i should try Genkernel....which i know generates a generic kernel which applys to most hardware. So i did. Now onto the new problem i have....When i boot up my Grub splash screen does not show, i just get a black screen...i know i pointed to the right destination (splashimage = (hd0,1) /boot/grub/......)....when i hit enter linux boots, and then i get white lines down the screen for a few seconds and i cant read a thing....then Gentoo starts bootiing up..and everything is fine.....i set the vga statement to 794 in the kernel line...anybody know what the issue could be here???

    here is my grub file

    default=0
    timeout=30

    splashimage=(hd0,1)/grub/splash.xpm.gz

    title=Gentoo Linux 2.6.15
    root (hd0,1)
    kernel /kernel-genkernel-x86_64-2.6.15-gentoo-r5 root=/dev/raminit=/linuxrc
    ramdisk=8192 real_root=/dev/hda4 udev vga=794
    initrd /initramfs-genkernel-x86_64-2.6.15-gentoo-r5

    # Dual boot to Win XP
    title=Windows XP
    root (hd0,0)
    makeactive
    chainloader +1

  2. #2
    Just Joined!
    Join Date
    Jun 2006
    Posts
    3

    I had the same problem!!!

    I had the same problem, how I solved it was changing part of the conf file. the line where it says (splashimage=hd0,1) change it to (splashimage=hd0,0) and leave everything else alone. that is how I solved it. let me know if it works for you too. Althoug mine did not have the (/grub/splash.xpm.gz) after the hard drive, so it may not work, but let me know, it is just pointing to the wrong area for the splash image, just play with it to figure out what works for you.

  3. #3
    Linux Engineer spencerf's Avatar
    Join Date
    Jan 2005
    Location
    Syracuse, NY
    Posts
    1,144
    This is what I have with boot located on a seperate partition located at /dev/hda2

    Code:
    splashimage=(hd0,1)/boot/grub/splash.xpm.gz
    All right, brain. You don't like me and I don't like you, but let's just do this and I can get back to killing you with beer. All New Users Read This!!! If you have a grub problem please look at GRUB MANUAL

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    Jun 2006
    Posts
    3

    boot splash problem!!

    here was my original conf file, when I had a similar problem.

    default 0
    timeout 30
    splashimage=(hd2,0)/grub/splash.xpm.gz
    title=Gentoo Linux
    root (hd2,0)
    kernel /kernel-genkernel-x86-2.6.15-gentoo-r5 root=/dev/ram0 init=/linuxrc ramdisk=8192 real_root=/dev/sdc3
    initrd /initramfs-genkernel-x86-2.6.15-gentoo-r5

    this is what I changed it to and now I am up and running.

    default 0
    timeout 30
    splashimage=(hd0,0)/grub/splash.xpm.gz
    title=Gentoo Linux
    root (hd0,0)
    kernel /kernel-genkernel-x86-2.6.15-gentoo-r5 root=/dev/ram0 init=/linuxrc ramdisk=8192 real_root=/dev/sdc3
    initrd /initramfs-genkernel-x86-2.6.15-gentoo-r5

    just to let you know I put all of linux on my 2nd had drive according to the bios. I did not want windows and linux to see eachother. so I have to boot my 1st drive when I want windows and my 2nd when I want linux. In the original conf file is where linux did everything for me and I had no bootsplash and could not load anything at all until I modified the line for root (hd2,0) and changed it to root (hd0,0), when it was loading it looked messed up but straightened up while booting. I went in and modified the conf file to what you see above, and viola, everything booted up normally with bootsplash and crystal clear graphics. I don't know if it will help you or not but that is how I solved my problem. The reason why I didn't want the two opperating system to see eachother is so if a virus did get in I would have at least one bootable opperating system. I hope in some way this helps. I will continue to check other thing out and see if I can solve it for you. Best of luck!!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •