Find the answer to your Linux question:
Results 1 to 7 of 7
I've been trying to install with the live CD installer... from boot, I use "ide=nodma" and I've tried several other options, but whenever it gets to "scrambling root password" I ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    May 2006
    Posts
    9

    "lost interrupt" Gateway 5150 CD Install


    I've been trying to install with the live CD installer...

    from boot, I use "ide=nodma" and I've tried several other options, but whenever it gets to "scrambling root password" I get dumped out with

    hdc: lost interrupt

    is there something I can do or should I move on to another distro?
    thanks

  2. #2
    Linux Guru antidrugue's Avatar
    Join Date
    Oct 2005
    Location
    Montreal, Canada
    Posts
    3,211
    Is that a laptop? Do you have a SATA drive on that machine?

    Please give more details about your hardware.
    "To express yourself in freedom, you must die to everything of yesterday. From the 'old', you derive security; from the 'new', you gain the flow."

    -Bruce Lee

  3. #3
    Just Joined!
    Join Date
    May 2006
    Posts
    9
    Yes, it's a Gateway Solo 5150 Laptop... I think it's from 1999. 196 megs of RAM, 40 gig hard drive. I don't know what SATA means... I know the hard drive is newer than the laptop. Is there anything else I can tell you? Thank you very much.

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Guru antidrugue's Avatar
    Join Date
    Oct 2005
    Location
    Montreal, Canada
    Posts
    3,211
    Either you have a problem with the hard drive (unlikely), the ide controler (unlikely as well), or you must figure out proper boot options.

    First make sure you have latest BIOS version for your machine (version 11.09) in order to rule that out:
    http://support.gateway.com/support/d...os=10405&type=

    Try booting with different options (F1 for help at the boot screen):
    Code:
    acpi=off nolapic

    Or more simply try another version of the Gentoo Live CD (newer or older). Or you may be able to choose from different kernels to boot from with this Live CD.
    "To express yourself in freedom, you must die to everything of yesterday. From the 'old', you derive security; from the 'new', you gain the flow."

    -Bruce Lee

  6. #5
    Just Joined!
    Join Date
    May 2006
    Posts
    9
    Well, I tried the options on boot, and it still does it. I checked the bios and it's up to date. I don't think there are any older or newer versions of the gentoo CD.

  7. #6
    Linux Guru antidrugue's Avatar
    Join Date
    Oct 2005
    Location
    Montreal, Canada
    Posts
    3,211
    Not sure if Gentoo Live CD accepts it, but you can try:
    Code:
    irqpoll
    as a boot parameter.
    "To express yourself in freedom, you must die to everything of yesterday. From the 'old', you derive security; from the 'new', you gain the flow."

    -Bruce Lee

  8. #7
    Just Joined!
    Join Date
    Apr 2008
    Posts
    1

    HOWTO fix your problem...

    Your laptop has a CD-ROM drive with "tricky" DMA. Most Linux distros enable DMA as default for CDs - and that is causing the problem (hence DMA "timeout" errors".
    Install with Debian requires selecting the gui install at boot - then at the first window CTRL+ALT+F4 to get the terminal that shows the install process (vt4) - you should see no CD errors there yet... ALT+F2 then hit enter to get a terminal - "cd /proc/ide/hdc" (for the solo 5150) - "cat settings" should show Using DMA as "1".... meaning enabled. "echo -n "using_dma:0" > settings".
    Now "cat settings" should show as follows...
    gateway:/proc/ide/hdc# cat settings
    name value min max mode
    ---- ----- --- --- ----
    current_speed 33 0 70 rw
    dsc_overlap 0 0 1 rw
    init_speed 33 0 70 rw
    io_32bit 0 0 3 rw
    keepsettings 0 0 1 rw
    nice1 1 0 1 rw
    number 2 0 3 rw
    pio_mode write-only 0 255 w
    unmaskirq 0 0 1 rw
    using_dma 0 0 1 rw
    gateway:/proc/ide/hdc#

    When the install gets to the "find cd"/"load components from cd" it will NOT fail . After the install is completed add the apropriate entry to HAL (if you install it) so that DMA is disabled on the cd from boot. Or "hdparm -d0 /dev/hdc".
    NOTE: I haven't installed Ubuntu to this machine... mine has only 128M RAM so KDE (or gNOme) would be too slow. XFCE works fine for me.
    Now if I could just turn off shadowing and get my IRDa working in FIR mode...

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •