Find the answer to your Linux question:
Results 1 to 9 of 9
Hey guys I read here on these forums that nexuiz 2.0 was just released the other day and a bug report on bugs.gentoo.com has been opened about a new ebuild. ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux Engineer spencerf's Avatar
    Join Date
    Jan 2005
    Location
    Syracuse, NY
    Posts
    1,144

    Nexuiz 2.0 ebuild for those interested


    Hey guys I read here on these forums that nexuiz 2.0 was just released the other day and a bug report on bugs.gentoo.com has been opened about a new ebuild. Well it hasn't gotten done exactly but there is diff posted between the two ebuilds so if anyone is interested I created an ebuild for this package.

    To install you need to have this in your /etc/make.conf

    PORTDIR_OVERLAY="/usr/local/portage"

    then if you didn't have this you need to:

    Code:
    mkdir /usr/local/portage
    then:
    Code:
    mkdir /usr/local/portage/games-fps
    mkdir /usr/local/portage/games-fps/nexuiz
    cd /usr/local/portage/games-fps/nexuiz
    nano nexuiz-2.0.ebuild
    [copy the contents of the attached file into the nexuiz-2.0.ebuild file]
    ebuild nexuiz-2.0.ebuild digest
    emerge -va nexuiz
    Attached Files Attached Files
    All right, brain. You don't like me and I don't like you, but let's just do this and I can get back to killing you with beer. All New Users Read This!!! If you have a grub problem please look at GRUB MANUAL

  2. #2
    Linux Newbie jpalfree's Avatar
    Join Date
    Jul 2005
    Location
    Montreal, CA
    Posts
    198
    I hadn't come across this game until your post. It looks cool. Thanks!

    I tried your ebuild and it installed alright. But once I get into the main menu of the game I can't get any further without it crashing. This is with both the normal and sdl versions. If I run it in a terminal I get the following output:
    ^7Client opened a socket on address local:2
    ^7Client opened a socket on address 0.0.0.0:32772
    ^7VID_Restart: changing from fullscreen 800x600x16bpp, to fullscreen 1152x864x16bpp.
    ^7OpenGL Backend shutting down
    FATAL: fglX11FreeBuffer: firegl_FreeBuffer() failed!
    Do you have any ideas as to why this is happening?
    Avatar from xkcd.com, a hilarious computer related webcomic.

  3. #3
    Linux Engineer spencerf's Avatar
    Join Date
    Jan 2005
    Location
    Syracuse, NY
    Posts
    1,144
    the first and most obvious question would be whether you have 3d support enabled?

    glxinfo | grep rendering
    All right, brain. You don't like me and I don't like you, but let's just do this and I can get back to killing you with beer. All New Users Read This!!! If you have a grub problem please look at GRUB MANUAL

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Newbie jpalfree's Avatar
    Join Date
    Jul 2005
    Location
    Montreal, CA
    Posts
    198
    yes. I do have 3d support. Which is why I'm puzzled. It is an ati. Maybe it's just because the drivers suck...
    Avatar from xkcd.com, a hilarious computer related webcomic.

  6. #5
    Linux Newbie jpalfree's Avatar
    Join Date
    Jul 2005
    Location
    Montreal, CA
    Posts
    198
    I got it working. I had to pass the following option to nexuiz while executing.
    Code:
    $ nexuiz -noshadinglanguage100
    Let the fragging begin!
    Avatar from xkcd.com, a hilarious computer related webcomic.

  7. #6
    Linux Guru bigtomrodney's Avatar
    Join Date
    Nov 2004
    Location
    Ireland
    Posts
    6,133
    I've been playing with Nexuiz today, I hadn't played it since about version 1.0 last year. I like the game, pretty good for a laugh but every time I exit the game it causes X to runn at 99% CPU. You guys aren't getting anything like this are you?

  8. #7
    Linux Engineer spencerf's Avatar
    Join Date
    Jan 2005
    Location
    Syracuse, NY
    Posts
    1,144
    Quote Originally Posted by bigtomrodney
    I've been playing with Nexuiz today, I hadn't played it since about version 1.0 last year. I like the game, pretty good for a laugh but every time I exit the game it causes X to runn at 99% CPU. You guys aren't getting anything like this are you?
    No I haven't been getting any abnormal cpu usage after exiting the game. Maybe you aren't getting a clean exit and some resources are being tied up.
    All right, brain. You don't like me and I don't like you, but let's just do this and I can get back to killing you with beer. All New Users Read This!!! If you have a grub problem please look at GRUB MANUAL

  9. #8
    Just Joined!
    Join Date
    Mar 2006
    Posts
    34
    I emerged the ebuild, and it worked without a hitch. However, when I joined a multiplayer game, I got a message saying that my version of Nexuiz was out of date. I'm behind a NAT firewall, so at first I assumed that that was the issue, but the problem continued after I turned on DMZ. Is this a known issue with Nexuiz?

  10. #9
    Linux Engineer spencerf's Avatar
    Join Date
    Jan 2005
    Location
    Syracuse, NY
    Posts
    1,144
    I just joined a multiplayer game and had no problems. Maybe it was just the server you joined?
    All right, brain. You don't like me and I don't like you, but let's just do this and I can get back to killing you with beer. All New Users Read This!!! If you have a grub problem please look at GRUB MANUAL

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •